Hi all,
Why is OpenDeploy base not starting when i issue the command /etc/init.d/iwod60 start. I'm receiving this warning everytime i attemp to start opendeploy.
But the other box which is also Solaris 8, it starts.
WARNING: The OpenDeploy server is still not responding.
WARNING: Please check the OpenDeploy server log.
WARNING: OpenDeploy might have failed during start up or
it might still be in the process of starting up.
Make sure OpenDeploy server successfully
started up before doing deployments.
<---In case you to see the log file.--->
iwod60:20050111:2111: Starting OpenDeploy server and its RMI registry.
iwod60:20050111:2111: OpenDeploy server home is /usr/Interwoven/OpenDeployNG
iwod60:20050111:2111: OpenDeploy instance name is initial
Starting OpenDeploy server.
processod: OpenDeploy home = /usr/Interwoven/OpenDeployNG
processod: RMI registry port = 9173
processod: OpenDeploy instance name = initial
DEPLOYAPI_AGENT_CMD "/usr/Interwoven/OpenDeployNG/jre/bin/java" -Xss2m -Xms32m -Xmx256m -classpath "/usr/Interwoven/OpenDeployNG/lib/odcomboint.jar:/usr/Interwoven/OpenDeployNG/lib/ddcombo.jar:/usr/Interwoven/OpenDeployNG/lib/odapi_svr100.jar:/usr/Interwoven/OpenDeployNG/lib/odapi_cl100.jar:/usr/Interwoven/OpenDeployNG/lib/odng.jar:/usr/Interwoven/OpenDeployNG/lib/version.jar:/usr/Interwoven/OpenDeployNG/userlib/odadapter.jar:/usr/Interwoven/OpenDeployNG/userlib/ddtpp.jar:/usr/Interwoven/OpenDeployNG/drivers/classes12.zip:/usr/Interwoven/OpenDeployNG/jre/lib/sparc:/usr/Interwoven/OpenDeployNG/lib/odcombo.jar:/usr/Interwoven/OpenDeployNG/websvc/lib/wasp_combo.jar:/usr/Interwoven/OpenDeployNG/jre/lib/dt.jar" -Djava.library.path="/usr/Interwoven/OpenDeployNG/lib:/usr/Interwoven/OpenDeployNG/jre/lib/sparc:/usr/lib" -Djava.rmi.server.codebase="file:///usr/Interwoven/OpenDeployNG/lib/odapi_cl100.jar file:///usr/Interwoven/OpenDeployNG/openjms/lib/openjms-rmi-0.7.2.jar" -Djava.rmi.server.useCodebaseOnly=true -Djava.security.manager -Djava.security.policy="/usr/Interwoven/OpenDeployNG/lib/deployapi.policy" -Dod.home="/usr/Interwoven/OpenDeployNG" -Dod.inst.name=initial com.interwoven.deploy.cdmain.IWCDMain "/usr/Interwoven/OpenDeployNG/etc/deploy.cfg"
START OD AGENT
SVR: 2005-01-11 21:11:27 HKT GMT+00:00 Begin initialization of OpenDeploy server.
SVR: 2005-01-11 21:11:27 HKT GMT+08:00 Version: 6.0.0.0.0 Build 36714 Interwoven 20040622
SVR: 2005-01-11 21:11:27 HKT GMT+08:00 Using time zone: Hong Kong Time
SVR: 2005-01-11 21:11:27 HKT GMT+08:00 Using locale: en_US
SVR: 2005-01-11 21:11:27 HKT GMT+08:00 Using file encoding: ISO8859-1
SVR: 2005-01-11 21:11:27 HKT GMT+08:00 Using OpenDeploy home directory: /usr/Interwoven/OpenDeployNG
SVR: 2005-01-11 21:11:27 HKT GMT+08:00
--License info--
License Information
Product Type : easy
Trial Period (days) : 0
-----------------
No license expiration date
FileNotFoundException: /usr/Interwoven/OpenDeployNG/install/odlic_datadeploy (No such file or directory)
SVR: 2005-01-11 21:11:27 HKT GMT+08:00 DataDeploy License not found
FileNotFoundException: /usr/Interwoven/OpenDeployNG/install/odlic_intelligentdelivery (No such file or directory)
SVR: 2005-01-11 21:11:27 HKT GMT+08:00 Intelligent Delivery License not found
SVR: 2005-01-11 21:11:27 HKT GMT+08:00 Got arguments: /usr/Interwoven/OpenDeployNG/etc/deploy.cfg
SVR: 2005-01-11 21:11:27 HKT GMT+08:00 Reading configuration file: /usr/Interwoven/OpenDeployNG/etc/deploy.cfg
SVR: 2005-01-11 21:11:28 HKT GMT+08:00 RMI server binding hostname/IP address not requested in deploy.cfg file.
SVR: 2005-01-11 21:11:28 HKT GMT+08:00 Will use default which is the local hostname.
SVR: 2005-01-11 21:11:28 HKT GMT+08:00 RMI server binding hostname/IP address in Java property is null.
SVR: 2005-01-11 21:11:28 HKT GMT+08:00 Using server config file specified in deploy.cfg: /usr/Interwoven/OpenDeployNG/etc/odbase.xml
SVR: 2005-01-11 21:11:28 HKT GMT+08:00 Using server nodes config file specified in deploy.cfg: /usr/Interwoven/OpenDeployNG/etc/odnodes.xml
SVR: 2005-01-11 21:11:28 HKT GMT+08:00 Using server log directory /usr/Interwoven/OpenDeployNG/log specified in server config file.
SVR: 2005-01-11 21:11:28 HKT GMT+08:00 Using OpenDeploy Server log file: /usr/Interwoven/OpenDeployNG/log/_odbase.log
SVR: 2005-01-11 21:11:28 HKT GMT+08:00 Start logging to OpenDeploy server log.
21:11:31.823 ERROR [main] - Failed to initialise JNDI
org.exolab.jms.jndi.FailedToInitialiseJndiServerException: Exception in RmiJndiServer.<init> java.rmi.UnknownHostException: Unknown host: ftp1_ext; nested exception is:
java.net.UnknownHostException: ftp1_ext
at org.exolab.jms.jndi.rmi.RmiJndiServer.init(Unknown Source)
at org.exolab.jms.server.JmsServer.init(Unknown Source)
at org.exolab.jms.server.JmsServer.main(Unknown Source)
OpenJMS 0.7.2 (build 14)
Exolab Inc. (C) 1999-2002. All rights reserved.
www.openjms.orgStarting Tyrex Version 0.9.8.7
Intalio Inc. (C) 1999-2001. All rights reserved.
org.exolab.jms.server.FailedToInitialiseServerException: init failed org.exolab.jms.jndi.FailedToInitialiseJndiServerException: Exception in RmiJndiServer.<init> java.rmi.UnknownHostException: Unknown host: ftp1_ext; nested exception is:
java.net.UnknownHostException: ftp1_ext
at org.exolab.jms.server.JmsServer.init(Unknown Source)
at org.exolab.jms.server.JmsServer.main(Unknown Source)
WARNING: The OpenDeploy server is still not responding.
WARNING: Please check the OpenDeploy server log.
WARNING: OpenDeploy might have failed during start up or
it might still be in the process of starting up.
Make sure OpenDeploy server successfully
started up before doing deployments.