Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
OpenDeploy
ml372
Hi,
we have some problems with a transactional fanout deployment.
only one server throughs follow exception:
ERROR: outer-loop recv failure, fd=61, err=131 [Unknown socket error]
the log-file of od-receiver is fine and say deployment completet, but the od-base weits of the commitment from the od-rcvr.
when we deploy the file in a single deploy, ist also fine??
Anyone an idea?
Thanks
Find more posts tagged with
Comments
Adam Stoller
How many definitions in the deployment?
If you have N definitions in the deployment and they are being deployed transactionally, in parallel, then you might run into some timeout problems if one of the 'leg's of the deployment is significantly smaller or larger than the other 'leg's.
We had this problem at one of my customer sites where if the difference between deploying the smallest leg and largest leg of the deployment was greater than 1 hour - a timeout would occur while the smaller leg was waiting for all the other legs to finish so it could move on to the next step.
We never completely proved whether the problem was in OpenDeploy or in the firewall at the customer's site - we ended up turning off the transactional option.
Does this sound like what you're experiencing? If not - you might try posting your deployment config file so that folks could take a look at it...
--fish
Senior Consultant, Quotient Inc.
http://www.quotient-inc.com
Migrateduser
If running on Unix, excessive deployment legs may consume too many file descriptors. Check out the section "Certified Limits for Number of Deployment Legs" in the OD 6.0 or 5.6 Admin Guide for more info.
Todd Scallan
Director of Product Management
Interwoven
t: 408-530-7167
e:
tscallan@interwoven.com
ml372
Hi,
thanks for your help.
Now, at first our configurations.
We use OpenDeploy 5.6, without Service Pack 1.
The Config-File:
<deploymentConfiguration>
<logRules maxBytes="32Mb" level="verbose">
</logRules>
<localNode host="TS_PROD" />
<replicationFarmSet >
<replicationFarm name="fanout">
<nodeRef useNode="$node" />
<nodeRef useNode="$node2" />
<nodeRef useNode="$node3" />
<nodeRef useNode="$node4" />
</replicationFarm>
</replicationFarmSet>
<definition name="dn1_filelist_deploy">
<source>
<sourceFilesystem area="$area^" filelist="$filelist^">
<pathSpecification>
<path name=".">
<filters>
<excludePattern regex="templatedata\/.*$" />
<excludePattern regex="dn.*\/WEB-INF\/.*$" />
<exceptPattern regex="dn.*\/WEB-INF\/jsp\/.*\.(html|jsp)$" />
<exceptPattern regex="dn.*\/WEB-INF\/errorCodesTranslations.xml$" />
<exceptPattern regex="dn.*\/WEB-INF\/PortalSecurity.xml$" />
</filters>
</path>
</pathSpecification>
</sourceFilesystem>
</source>
<target useReplicationFarm="fanout">
<targetFilesystem area="$targetarea^">
</targetFilesystem>
<filters>
<excludePattern regex="templatedata\/.*$" />
<excludePattern regex="dn.*\/WEB-INF\/.*$" />
<exceptPattern regex="dn.*\/WEB-INF\/jsp\/.*\.(html|jsp)$" />
<exceptPattern regex="dn.*\/WEB-INF\/errorCodesTranslations.xml$" />
<exceptPattern regex="dn.*\/WEB-INF\/PortalSecurity.xml$" />
</filters>
<comparisonRules
dateDifferent="yes"
revert="no"
ignoreAcls="no"
ignoreModes="yes"
ignoreUser="yes"
ignoreGroup="yes" >
</comparisonRules>
<transferRules doDeletes="yes" />
<permissionRules
amask=""
omask=""
directory="0775"
file="0775"
user="root"
group="staff">
</permissionRules>
</target>
</definition>
<deployment transactional="yes" >
<execDeploymentTask useDefinition="dn1_filelist_deploy" >
<deployNRun>
<dnrDeployment
location="target"
when="after"
triggerPoint=""
state="success">
<script
cmd="/bin/sh /usr/local/bea/jspc.sh $dnrparam"
as="root"
async="no"
/>
</dnrDeployment>
<!--<dnrDeployment
location="source"
when="after"
triggerPoint=""
state="success">
<script
cmd="/bin/rm $filelist"
as="root"
async="no"
/>
</dnrDeployment>-->
</deployNRun>
</execDeploymentTask>
</deployment>
</deploymentConfiguration>
Originally i want use two definitions, because we must deploy the filelist in two different directories on the target-hosts.
But, when i use two definitions, an error was throughn.
I look in the Froum, an find a info that i must install SP1 to resolve the problem.
Now, i started two deployments with seperatly config files, to deploy to two different targets. the only different between the config files is the target.
I think, that perhaps we have a deadlock between teh two deployments, because they deploy teh sam files - can it?
Migrateduser
I seem to recall the multi-definition problem you mention. That should be fixed if you apply the latest SP and patch.
You should be able to run a two-definition deployment with no problem, provided the two definitions don't update the same target directory.
Alternatively, consider using a multiple sub-source structure. This serializes the deployment but lets you update multiple different target areas. See p. 137 in the OD 5.6 Admin Guide, Nov. 2003 edition, for an example.
Todd Scallan
Director of Product Management
Interwoven
t: 408-530-7167
e:
tscallan@interwoven.com