Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
OpenDeploy no longer starts
Paul
Last Friday we were working on some coding changes in one of our deployment script files. One of those changes caused the script to go into a loop and the server ran out of space. We addressed the space issue (killed the file it generated) and rebooted the server (Windows2003 Server with TeamSite 6.1.0 and OpenDeploy 6.0).
Once the server rebooted, OpenDeploy fails to start and gives us the following error:
ENG: 2005-01-14 16:12:24 EST GMT-05:00 ***ERROR - SQLException: User not found: SA
java.sql.SQLException: User not found: SA
at org.hsql.Trace.getError(Trace.java:124)
at org.hsql.Trace.getError(Trace.java:115)
at org.hsql.Trace.error(Trace.java:130)
at org.hsql.Access.get(Access.java:109)
at org.hsql.Access.getUser(Access.java:88)
at org.hsql.Database.connect(Database.java:60)
at org.hsql.jdbcConnection.openStandalone(jdbcConnection.java:662)
at org.hsql.jdbcConnection.(jdbcConnection.java:524)
at org.hsql.jdbcDriver.connect(jdbcDriver.java:78)
at java.sql.DriverManager.getConnection(DriverManager.java:512)
at java.sql.DriverManager.getConnection(DriverManager.java:172)
at com.interwoven.deploy.engine.TMacroDeployInitiator.compactHsql(TMacroDeployInitiator.java:2573)
at com.interwoven.deploy.engine.TMacroDeployInitiator.shutdownScheduler(TMacroDeployInitiator.java:2484)
at com.interwoven.deploy.engine.TMacroDeployInitiator.stop(TMacroDeployInitiator.java:480)
at com.interwoven.deploy.engine.TDeploySvrEngine.stop(TDeploySvrEngine.java:1286)
at com.interwoven.deployapi.deploy.IWODServerAction.stopServer(IWODServerAction.java:954)
at com.interwoven.deployapi.deploy.IWODServerRemoterImpl.stopServer(IWODServerRemoterImpl.java:226)
at java.lang.reflect.Method.invoke(Native Method)
at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:236)
at sun.rmi.transport.Transport$1.run(Transport.java:147)
at java.security.AccessController.doPrivileged(Native Method)
at sun.rmi.transport.Transport.serviceCall(Transport.java:143)
at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:460)
at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:701)
at java.lang.Thread.run(Thread.java:479)
ENG: 2005-01-14 16:12:24 EST GMT-05:00 ***ERROR - Compacting HSQL script file
ENG: 2005-01-14 16:12:24 EST GMT-05:00 Successfully updated schedule extension file
ENG: 2005-01-14 16:12:24 EST GMT-05:00 Sender stopped.
ENG: 2005-01-14 16:12:24 EST GMT-05:00 Listener stopped.
ENG: 2005-01-14 16:12:24 EST GMT-05:00 Stopping event server ...
ENG: 2005-01-14 16:12:28 EST GMT-05:00 Event server stopped.
Frankly, we're at a loss as to where to turn next. Any guidance would be greatly appreciated.
Paul
Find more posts tagged with
Comments
Migrateduser
Exactly which file did you delete? I would guess that you killed the event reporting database and hsql created a new instance without an sa user. I'm hypothesizing, but it seems a good guess.
Migrateduser
This seemed like your hypersonic DB used for scheduling got screwed up. The easiest way I can think of is backup all your conf files and uninstall and reinstall OD, which should be relativelt easy.
Paul
Here's what our issue was. We just came across this and it worked.
OpenDeploy Startup Failures
Knowledge Base Article: 50708
Type: Tech Note
Synopsis
This article explains why the following error may appear and OpenDeploy fails to start:
***ERROR -SQLException: User not found: SA
Details
It is possible that something modified or corrupted the schedDB.script file, causing the "user not found" error. Check the schedDB.script file to confirm this entry:
"CREATE USER SA PASSWORD "" ADMIN"
If this line is not present or the file has otherwise been altered or corrupted, the resolution is to rename the schedDB.properties file to, for example, schedDB.properties.bak and restart the OpenDeploy service. Upon restarting the OD services, the schedDB.script file will be recreated and will once again have the 'CREATE USER SA PASSWORD "" ADMIN' line entry such that user SA will be granted access. Note: If you want to confirm schedDB.script content change, you will have to stop OD services again to open and view the file.
An example hostname_odbase log file is shown below and reflects the error message that you will likely see:
***ERROR -SQLException: User not found: SA
Inspection of the odbase.xml file reveals the scheduler DB attributes are accurate:
Migrateduser
Now that you remind me of the KB, I remember running into this exact problem about a year ago on OD5.6.