Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
OD fall-back solutions?
Sharty
All,
Our client would like to have a 99,5% guarantie, that scheduled or instant deployments are going to the live site. Because OD seems to fail quite some time here, and because we are building right now a new application for the stock market, we need to have a fall-back solution and some kind of redundancy system, so that we can make 100% sure that, if OD is failing on one box, the files will be deployed to the live site for sure.
Is there any possibility to make an OD redundancy? Having two servers with OD running on?
Is there another tool what we can use, which is checking, if OD hasn't deployed the file, that they will be anyway put to the live server? (Legal timeframe for that would be 30 seconds.... - we only deploy files not larger than 10K)
Thanks for the reply.
Regards, Jens
Find more posts tagged with
Comments
JonathonG
You say that OD fails quite often for you. What is the cause of the failures? I ask because depending on the cause, a "backup" system may not do you much good. For example, here's a few failure scenarios that I can think of and whether or not a backup system would help:
1. Network connectivity problem prevents OD from transferring file - any backup system you would put in place would be subject to the same network connectivity problem.
2. Files on the target are "locked" by some process, thus causing OD to fail to write the files (typically, only applies on MS OSes) - again, any backup system would have the same problem with these files.
3. OD Receiver process stopping/becoming unavailable - a backup system here has a chance of helping you out, since it wouldn't be relying on the OD Receiver process
So, as you can see, of the 3 failure scenarios I can think of, only one has a reasonable "redundant" system. And even number 3 may be an issue depending on the reason for the failure of the OD Receiver.
Perhaps, instead of looking for a backup for OD, you want to think about instituting periodic retries. But again, that depends on why OD is failing in the first place.
Jonathon
Interwoven Developer
Allstate, Inc.
nipper
I would agree with Jonathon, OD in our environment is very close to 100%. Issues I have with content not getting
to production are when datadeploy fails before the open deploy is to kick off.
Can you characterize the "massive" OD failures you see ?
Migrateduser
A couple of new features in OD 6.0 that may be helpful include SNMP monitoring/traps and the ability to run multiple instances of an OD server (base or receiver) on a host.
But as mentioned by Jonathan, it's hard to recommend an approach without knowing why your deployments are failing.
Fyi, one of the most common causes of OD failures is multiple deployments or legs of a deployment attempting to update the same target directories at the same time. OD 6.0 has a new concurrency management feature that queues up colliding deployments at the target receiver.
Todd Scallan
Director of Product Management
Interwoven
t: 408-530-7167
e:
tscallan@interwoven.com
Sharty
Hi All,
we are right now investigating in detail, why OD is failing at least once/month.
Some of the reasons why OD was failing before was
- port 20014 was closed... (I know, redundancy wouldn*t have helped there..)
- the server where OD and TS is runing on went out of memory (the iwserver process takes right now about 2,5 GB ram...)
Most of the times OD was failing was, because TS was doing damage to the server - and OD is installed on the same box...
But it is good to know, the OD 6 is offering a set of tools to make OD somehow more reliable and redundant and be able to monitore, what is going on on these servers.
Cheers, Jens