Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
Preview and generate
chiksur
We are having a problem with a dcr file.
We have a template data folder and there is a subdirectory called data where the dcr are stored.
and in it we have a file named training.when I am trying to generate
that page it gives me the error stated below.
Template Preview And Generate Error:
The following error occured while creating file
/.iwmnt/default/main/InternetMarketing/SystemsIntegrator/WORKAREA/Common/zz_tst_sun_lock:
No such file or directory
The templated file was not generated.
sun_lock : is the owner of the file.
All the files are in cms
It would be of great help if anyone could let me know how to resolve this issue.
Find more posts tagged with
Comments
chiksur
I would like to know if it a problem with respect to a locking issue.
do you think the work area Is using a submit-lock model?
TCavanaugh
Do you have a directory called "Common" at the root of your branch? Also, does the user performing this operation have the necessary access to create the temporary files at this location?
End of Page.jpg
Sart of next page.jpg
BIRT Report desgin.jpg
Adam Stoller
Common is the name of the workarea - not a subdirectory.
For what it's worth - my customer had some problems the other day with generating pages and it turned out to be due to two (not one, but two) of their RAID disks failing - causing a bunch of NFS flakiness with the mount points that TeamSite uses.
You might try running the equivalent command from the command line on the server and see if you can do so successfully several times (that would tend to rule out the NFS issue)
--fish
Senior Consultant, Quotient Inc.
http://www.quotient-inc.com
chiksur
Yes we have a directory called common at the root of this branch and the user is a mster for team site and he has permissions to create temporary files at this location
chiksur
Yes we have a directory called common at the root of this branch
I am not even able to edit and datacapture.cfg file in any branch.it says the file is not present .
the error seems to be a bit vague.
Adam Stoller
I suggest you check out the permissions of all the branches, workareas, directories and files (especially datacapture.cfg and zz* files) from the command line. It sounds like something, somewhere is over-protected (at the OS level) and preventing you from generating these files.
--fish
Senior Consultant, Quotient Inc.
http://www.quotient-inc.com
chiksur
HI fish
our iwmnt mount point is a read only mount point I means it has permissions like drwxr-xr-x root
we have a directory under it named default which has file permissions like dr-xr-xr-x root
we have a directory under it named main which has file permissions like drwxrwxr-x root
we have a directory under it named staging,editionworkarea which has file permissions like dr-xr-xr-x root
and we have directory named systems which has permissions named drwxrwxr-x sys.
Do you think by changing the file permissions of default to 777 will globally change the file permissions all the directories and subdirectories which will resolve the issue.
Adam Stoller
If you can create a file in a workarea - ignore the protections on the mount point, branch, edition, and WORKAREA directories. Concentrate your effort on the protections of the actual workarea directory (e.g. .../WORKAREA/this-directory) and potentially its sub-directories.
Have you ruled out NFS problems?
Have you physically rebooted the server?
Have you opened a case with Support?
--fish
Senior Consultant, Quotient Inc.
http://www.quotient-inc.com
chiksur
HIi,
our issue got resolved when we stopped and restarted the server.
the problem we faced was that there was a user in the group who vreated files in our unix box and in the interwoven.he left the compnay so he was removed from our directory structure.so when unix checked for his permission using ldap it didnt find him so it replaced the directory structure he created with 101 for the user group.
so we changed the owner to root and restarted the server so it worked.
thanks a lot fish .
It was a lot of help from your side .
surya,
interwoven consultant
Sony Electronics