Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
open deploy external tuple processor
axaaus
I am using external tuple processor for OpenDeploy. It was working on the old version. On version 6.1 i have defined the name of class file in the config file and put the jar file in <home>/userlib directory. When i run the perl script using
d:\iw-home\custom\components\file_list_source_dd.ipl d:/OpenDeployNG/tmp/source/dump /home/teamsite/dmsBase/dump integration.s7d0..file_list..dd /default/main/shared/WORKAREA/workarea integration_app
it displays error
Locating OpenDeploy service.
Got OpenDeploy service
>>>>>-- Start deployment dd/file_list_source_wide_dd.
iwodstart running in default synchronous mode.
Need to wait for deployment to complete.
>>>>>-- Deployment dd/file_list_source_wide_dd finished:
ID: m1 Start time: Tue Feb 08 16:50:53 EST 2005
Status: Completed with error
After initial investigation i have found that the config file is being read but after that it is not executing the java class specified in the file.
the contents of config file is
<data-deploy-configuration>
<data-deploy-elements filepath="d:/OpenDeployNG/etc/database.xml" />
<external-tuple-processor class-name="com.axa.interwoven.datadeploy.WLPTupleProcessor,com.axa.interwoven.datadeploy.PathTupleProcessor" />
<client>
<deployment name="file_list_wide_dd">
<source>
<!-- Pull data tuples from TeamSite EA's -->
<teamsite-extended-attributes options="full,wide" area="$sourceArea">
<path filelist="$fileList" />
</teamsite-extended-attributes>
</source>
<filter name="ExcludeTemplatedata">
<!-- Excludes the templatedata from the deployment -->
<discard>
<field name="path" match="templatedata/*" />
</discard>
</filter>
<substitution name="slashes">
<field name="path" match="\\" replace="/" global="yes" />
</substitution>
<destinations>
<xml-formatted-data file="$fileList.wide_dump" />
</destinations>
</deployment>
</client>
</data-deploy-configuration>
you help will be really appriciated.
Find more posts tagged with
Comments
Migrateduser
Hi,
What does the script :
"<od_home>/script custom\components\file_list_source_dd.ipl " do?
Was the custom . jar was added into the <od_home>/userlib directory after the OD server was up and running. In such a case, the class path might not have been set to include your jar.
Are the results the same when you run "iwodcmd start" from the command line.
thanks
srini
Michael
Hi there AXA
Did you recompile the classes in the jar as part of your upgrade? I am not sure if it is required but when I had a look at the 6.0.1 doco it says:
This Java file should be compiled using JDK1.3 or later.
CLASSPATH should include the following file:
od-home/lib/ddcombo.jar
After a successful compilation, you package your Java class files into a .jar file, and place it in the following directory:
od-home/(od-instance)/userlib
You must then restart the OpenDeploy server.
Perhaps when the classes were originally compiled 'od-home/lib/ddcombo.jar' may not have been in the classpath? This could possibly result in some kind of error -- this is a bit of a wild stab in the dark though sorry.
If this doesn't sound right then it is probably worthwhile including in your post the error messages that show in detail where it is failing and why.
Hope this helps
Cheers
Michael
PS: Nice looking deployment script!
Migrateduser
Did you ever get this resolved? I am having the same problem.
-------------------------------
E-Mail :
farnsaw@stonedoor.com