Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
OD affecting ACCESS ?
System
We suspect that recent upgrade of OPEN DEPLOY (OD 560 SP1) onto our IIS Web Server has caused our other applications that use ACCESS DB to fail with the following error.
Microsoft OLE DB Provider for ODBC Drivers (0x80004005)
[Microsoft][ODBC Microsoft Access Driver] The Microsoft Jet database engine cannot open the file '(unknown)'. It is already opened exclusively by another user, or you need permission to view its data.
/boc/Articles/ShowDocumentList.asp, line 25
Has anybody come across this before - we will have to backout OD until a solution is found.
Thanks
Pete
Find more posts tagged with
Comments
Migrateduser
I just wanted to let you know, in case this happens anywhere else, that the Open Deploy Upgrade that caused us some drama on our Intranet server that took us a few days to solve. The morning after the upgrade we noticed that any ASP pages on our Intranet that communicated with local Access databases all stopped working and would throw ASP errors complaining about not enough permission. I checked all the usual places that the IUSR_ user ID (default IIS user that the web server runs as) needs permission to and everything looked fine. And because we had changed nothing within these ASP's or the Access databases I was scratching my head.
Only after a lot of investigation did I realise that the IUSR_ user had lost permission to the default system %TMP% (and possibly %TEMP%) directories. Apparently the JET database system which controls all calls to Access databases writes temp files into %TMP% and possibly %TEMP% and becuase the IUSR_ user didn't have access it would fail. There was a Microsoft MSDN article about this (315456). Restoring permission fixed the problem.
It looks like the installation of Open Deploy Receiver had reset the security on the above folders.
We also had another problem in some of the other Access database calls (the DSN-less ones) where the IUSR_ user had lost permission to part of the Registry (to Key "HKLM\SOFTWARE\ODBC"). ASP errors complaining about no access to the Registry was the symptom for these. I had to go into the Registry and enable security permissions for the ODBC folder so that the IUSR_ user could read the ODBC folder. It looks like Open Deploy also reset this security. MSDN article 295297 pointed me in the right direction on this one.
Note that our Windows 2000 Server is on a service pack level higher than the Open Deploy documentation said it was tested on. Not sure if that may have contributed to the problem.
Anyway, this is just for your info if you happen to encounter this anywhere else. Everything is fine for us now.
Migrateduser
Would appreciate if you could open a case with Tech Support and ask them to attach it to feature request #34958, which asks for OpenDeploy not to rely on TMP.
Thanks.
Todd Scallan
Director of Product Management
Interwoven
t: 408-530-7167
e:
tscallan@interwoven.com