Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
Deployments Causing File Deletions
rajit
Hi
We are finding that due to some reason the Transactional deployment is failing and then tries rollback. Looks like the rollback also fails to restore files and the result is that the files go missing from the target directory. Here is an excerpt of the log
ENG: 2005-05-25 17:58:37 EDT GMT-04:00 Thread-1757 exiting awaiting-commit
ENG: 2005-05-25 17:58:37 EDT GMT-04:00 Thread-1757 entering commit
id=0 server: COMMITTING Transactional Deployment
(3) id=0 server: Renaming: [/www/gmgwh/gmcardvauxhall/content/images/card_features.iwnew] -> [/www/gmgwh/gmcardvauxhal
l/content/images/card_features]
(3) id=0 server: Cleaning: /www/gmgwh/gmcardvauxhall/content/images/card_features
(3) id=0 server: Deleting dir: /www/gmgwh/gmcardvauxhall/content/images/card_features
ERROR: RemoveDir for /www/gmgwh/gmcardvauxhall/content/images/card_features failed with errno = 17
ERROR: Failed removing directory (/www/gmgwh/gmcardvauxhall/content/images/card_features)
ERROR: Failed deleting item(/www/gmgwh/gmcardvauxhall/content/images/card_features)
ERROR: Replacing [/www/gmgwh/gmcardvauxhall/content/images/card_features.iwnew] -> [/www/gmgwh/gmcardvauxhall/content/images/
card_features]
.
ERROR: Failed deploying file_list.
ENG: 2005-05-25 17:58:37 EDT GMT-04:00 Thread-1757 After COMMIT res=-1
ENG: 2005-05-25 17:58:37 EDT GMT-04:00 Thread-1757 exiting commit
ENG: 2005-05-25 17:58:37 EDT GMT-04:00 Thread-1757 entering awaiting-rollback
ENG: 2005-05-25 17:58:37 EDT GMT-04:00 Thread-1757 Got task failed in COMMIT
ENG: 2005-05-25 17:58:37 EDT GMT-04:00 Thread-1757 still waiting for 0
ENG: 2005-05-25 17:58:37 EDT GMT-04:00 Thread-1757 exiting awaiting-rollback
ENG: 2005-05-25 17:58:37 EDT GMT-04:00 Thread-1757 entering rollback
ENG: 2005-05-25 17:58:37 EDT GMT-04:00 Thread-1757 failedCommit=true shouldWait=true
id=0 server: ROLLBACK Transactional Deployment
(3) id=0 server: Restoring: [/www/gmgwh/gmcardvauxhall/content/images/card_features.iwold] -> [/www/gmgwh/gmcardvauxha
ll/content/images/card_features]
(3) id=0 server: Cleaning: /www/gmgwh/gmcardvauxhall/content/images/card_features
(3) id=0 server: Deleting dir: /www/gmgwh/gmcardvauxhall/content/images/card_features
ERROR: RemoveDir for /www/gmgwh/gmcardvauxhall/content/images/card_features failed with errno = 17
ERROR: Failed removing directory (/www/gmgwh/gmcardvauxhall/content/images/card_features)
ERROR: Failed deleting item(/www/gmgwh/gmcardvauxhall/content/images/card_features)
ERROR: Failed restore [/www/gmgwh/gmcardvauxhall/content/images/card_features.iwold] -> [/www/gmgwh/gmcardvauxhall/content/im
ages/card_features]
(3) id=0 server: Restoring: [/www/gmgwh/gmcardvauxhall/content/images/index.iwold] -> [/www/gmgwh/gmcardvauxhall/conte
nt/images/index]
(3) id=0 server: Cleaning: /www/gmgwh/gmcardvauxhall/content/images/index
(3) id=0 server: Deleting dir: /www/gmgwh/gmcardvauxhall/content/images/index
(3) id=0 server: Deleted: /www/gmgwh/gmcardvauxhall/content/images/index
(3) id=0 server: Copying dir: /www/gmgwh/gmcardvauxhall/content/images/index.iwold to /www/gmgwh/gmcardvauxhal
l/content/images/index
Has anyone seen such an issue. Any guesses on what could be the possible reason. The directory permissions for the folders is
755 and the files is also 755. Any inputs/directions in this regard will be really helpful.
Thanks
Rajit
Find more posts tagged with
Comments
rajit
We are using OD 5.5.1 on Solaris environment. Both base server and target are Solaris boxes.
madan1
I am using od6.02. One possibility might be due to this with respect to OD6.02
Error ENG00013:
pathSpecification is
null. Please check the
deployment
configuration file.
Failure in the validation of
configuration file.
Check deployment
configuration file for
errors.
Adam Stoller
The error messages that rajit posted are clearly coming from a running deployment;
The error messages that you (madan) posted are clearly coming from a deployment that failed to run at all -- thus are unlikely to shed much light here.
ERROR: RemoveDir for /www/gmgwh/gmcardvauxhall/content/images/card_features failed with errno = 17
This is kind of interesting as errno 17 seems to be equated (on a Solaris 9 system) with EEXIST (
file exists
) which seems a strange message to get for trying to
remove
a directory.
The problem seems centered on this one directory in both directions.
What are the access rights on the directories (
/bin/ls -ld
)?:
/www
/www/gmgwh
/www/gmgwh/gmcardvauxhall
/www/gmgwh/gmcardvauxhall/content
/www/gmgwh/gmcardvauxhall/content/images/card_features
Also who owns the OD process? Is it running as 'root' or as some-other-user?
--fish
Senior Consultant, Quotient Inc.
http://www.quotient-inc.com