Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
unknown properties on DCR
nagendra
Hi all,
System: Teamsite 6.5 sp1 on solaris.
we are using xslt 'java -jar /usr/saxon/saxon6.5.3.jar DCRvpath merge.xsl' in one of our scripts.
sometimes this is giving following error
Failure reading file:/default/main/al/00_final/WORKAREA/content
/templatedata/node/content/data/sale_Calls: no more input
Recoverable error
when I check the above DCR it has shown some unknown properties on it
those are as follows:
TeamSite/Metadata/Description
TeamSite/Metadata/Keywords
TeamSite/Metadata/Title
numberOfChunks : 1
subjectMetadata0 : <?xml ....
questions:
1) Are these unknown properties casuing the issue?
2) What are these properties and when / how they came on the DCR.
-nagendra
Find more posts tagged with
Comments
ISCBorisB
You may want to check datacapture.cfg and metadata-rules.cfg in <iwhome>/local/config
to see Meta Data set for this DCR Type.
- Your "unknown properties" are plain vanilla TS Meta Data. They are implemented as Extended attributes
with certain naming Convention. There are several ways to set them (like File Menu -> Tag). Usually it's done by
Content Contributor(s) using MD Datacapture form or automatically by scripts / WFs
- If the file you are looking at is a DCR, it should also have "TeamSite/Templating/DCR/Type" attribute.
An absence of this one may cause all sort of problems. Without it TS would not consider this file a DCR
gzevin
the extended attributes cannot cause your DCR to fail to load. As it was mentioned, the EAs that you see were set by the tagger (set metadata).
Greg Zevin, Ph.D. Comp. Sc.
Independent Interwoven Consultant/Architect
Sydney, AU
nagendra
TeamSite/Templating/DCR/Type attribute is present, apart from that those extra properties are appeared on dcr. these extra properties are not appeared to all of the dcrs, only some of the dcrs got these. and also we are not using metadata form for capturing meta data.
following is the metadata-rules.cfg
<?xml version="1.0" encoding="UTF-8" ?>
<metadata-rules>
<cond vpath-regex=".">
<rule name="Default Rule" />
</cond>
</metadata-rules>
Edited by nagendra on 02/01/06 08:54 PM (server time).