Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
OD Can't find mounted drive?
Herman
I use OD6.0.1 on my windows 2003 server,
I mount Z: ( the C: drive of another server) on my server.
Then I use Z:\test to be my source of deployment,
But OD system display can't find Z:\test,
and if I use Z:\test to be my target deployment,
it's also fail.
How can i use mounted drive to deploy?
Find more posts tagged with
Comments
Migrateduser
OD can deploy to mounted drives.... can you post your cfg and log files?
Mariam
Product Manager
Interwoven
Herman
If I used Source(mounted Drive), admin UI will response :
Start Deployment Failed
Case2/MountTest
Area = Z:\Tamis2_Deploy_Case2 not found.
ONLY one log:
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
ENG: 2005-10-03 19:43:02 CST GMT+08:00 Begin logfile [C:\od-home\base\OpenDeployNG\log\Case2\src.MountTest.log] ---------
ENG: 2005-10-03 19:43:02 CST GMT+08:00 Job ID=m3 Deployment=Case2/MountTest
ENG: 2005-10-03 19:43:02 CST GMT+08:00 Deployment config file[C:\od-home\base\OpenDeployNG\conf\Case2\MountTest.xml]
ENG: 2005-10-03 19:43:02 CST GMT+08:00 -----------------------------------------------------------
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<deploymentConfiguration>
<logRules maxBytes="32Mb" level="verbose"/>
<localNode host="TEMP2"/>
<replicationFarmSet>
<replicationFarm name="MYFARMNAME">
<nodeRef useNode="MyLocalHost"/>
</replicationFarm>
</replicationFarmSet>
<definition name="MYDEFINITIONNAME">
<source>
<fileSystem>
<remoteDiff area="Z:\Tamis2_Deploy_Case2">
<pathSpecification>
<path name="."/>
</pathSpecification>
</remoteDiff>
</fileSystem>
</source>
<target>
<targetFilesystem area="C:\Tamis2_Deploy_Case2"/>
<comparisonRules dateDifferent="yes"/>
<replicationFarmLink>
<internal name = "MYFARMNAME"/>
</replicationFarmLink>
</target>
</definition>
<deployment transactional="no">
<execDeploymentTask useDefinition="MYDEFINITIONNAME"/>
</deployment>
</deploymentConfiguration>
ENG: 2005-10-03 19:43:02 CST GMT+08:00 -----------------------------------------------------------
ENG: 2005-10-03 19:43:02 CST GMT+08:00 End of deployment config file[C:\od-home\base\OpenDeployNG\conf\Case2\MountTest.xml]
ENG: 2005-10-03 19:43:02 CST GMT+08:00 ***ERROR - Area = Z:\Tamis2_Deploy_Case2 not found.
ENG: 2005-10-03 19:43:02 CST GMT+08:00 ***ERROR - Failed to start deployment.
ENG: 2005-10-03 19:43:02 CST GMT+08:00 End logfile [C:\od-home\base\OpenDeployNG\log\Case2\src.MountTest.log]
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Target:MountedDrive-log
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 Begin logfile [C:\od-home\base\OpenDeployNG\log\Case2\rcv.MountToODServerForCustomer.MYDEFINITIONNAME.temp2.to.mylocalhost.log] ---------
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 Job ID=m4 Deployment=Case2/MountToODServerForCustomer.MYDEFINITIONNAME.mylocalhost
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 OpenDeploy Version is 6.0.1.0.0
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 Owner started the deployment is TEMP2\administrator
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 Internal config file is C:\od-home\base\OpenDeployNG\db\.odrcvr.20014
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 ** Simulate flag = false
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 ** Synchronous flag = false
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 exiting initial
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 entering setup
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 Path registry check (sec): checkinterval=30
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 Path registry check disabled
LIB: 2005-10-03 19:45:03 LOGFILE=[C:\od-home\base\OpenDeployNG\log\Case2\rcv.MountToODServerForCustomer.MYDEFINITIONNAME.temp2.to.mylocalhost.log]
LIB: 2005-10-03 19:45:03 Locale=[TraditionalChinese_Taiwan.MS950@Binary]
LIB: (2) 2005-10-03 19:45:03 Bound to port 20014
LIB: 2005-10-03 19:45:03 [Mon Oct 03 19:45:03 2005] Deployment INITIATED
LIB: id=m4 2005-10-03 19:45:03 Interwoven OpenDeploy(6.0.1.0.0 Build 41860 Interwoven 20041018)
LIB: id=m4 2005-10-03 19:45:03 LIB: Component Version (6.0.1.0.0 Build 41860 Interwoven 20041018)
LIB: id=m4 2005-10-03 19:45:03 Protocol Version(5.0) OK
LIB: id=m4 2005-10-03 19:45:03 Connection Id(id=m4)
LIB: id=m4 2005-10-03 19:45:03 platform: server(MSWIN32), client(MSWIN32)
LIB: id=m4 2005-10-03 19:45:03 Transaction Mode: ON
LIB: id=m4 2005-10-03 19:45:03 Mode(normal)
LIB: id=m4 2005-10-03 19:45:03 Protocol(normal)
LIB: id=m4 2005-10-03 19:45:03 Buffer Size (8000)
LIB: id=m4 2005-10-03 19:45:03 Host(TEMP2)
LIB: id=m4 2005-10-03 19:45:03 User(nt authority\system)
LIB: id=m4 2005-10-03 19:45:03 Deployname(.MountToODServerForCustomer.MYDEFINITIONNAME.mylocalhost)
LIB: (2) id=m4 2005-10-03 19:45:03 Connection accepted!
LIB: (2) id=m4 2005-10-03 19:45:03 Buffer Size (8000)
LIB: id=m4 2005-10-03 19:45:03 Number of local_directories to deploy: 1
LIB: id=m4 2005-10-03 19:45:03 BEGINNING Transactional Deployment
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 After SETUP res=0
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 exiting setup
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 entering awaiting-dotask
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 still waiting for 0
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 exiting awaiting-dotask
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 entering dotask
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 COMPARE
LIB: id=m4 2005-10-03 19:45:03 FailedCommit 0.
LIB: id=m4 2005-10-03 19:45:03 Destination directory [z:\tamis2_deploy_case2]
LIB: 2005-10-03 19:45:03 ERROR: z:\tamis2_deploy_case2 could not be created.
LIB: 2005-10-03 19:45:03 ERROR: Failed deploying local_directory[0] (C:\Inetpub\wwwroot\TamisWeb_Dev\Tamis) to (z:\tamis2_deploy_case2)
LIB: 2005-10-03 19:45:03 ERROR: Failed 1 of 1 local_directories
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 After COMPARE res=-1
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 Got Task failed string in COMPARE sub stage
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 write Longline TASKFAIL in COMPARE sub stage
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 exiting dotask
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 entering awaiting-rollback
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 Got task failed in precommit
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 still waiting for 0
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 exiting awaiting-rollback
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 entering rollback
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 failedCommit=false shouldWait=true
LIB: id=m4 2005-10-03 19:45:03 FailedCommit 0.
LIB: id=m4 2005-10-03 19:45:03 ROLLBACK Transactional Deployment
LIB: id=m4 2005-10-03 19:45:03
*** ROLLBACK performed: Saved txlist file (c:\temp\iwdir3) ***
LIB: id=m4 2005-10-03 19:45:03
Directories deployed : 0 Files deployed : 0 Links deployed : 0
Directories failed : 0 Files failed : 0 Links failed : 0
Directories deleted : 0 Files deleted : 0 Links deleted : 0
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 After ROLLBACK res=0
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 exiting rollback
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 entering awaiting-cleanup
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 still waiting for 0
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 exiting awaiting-cleanup
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 entering cleanup
LIB: id=m4 2005-10-03 19:45:03 FailedCommit 0.
LIB: id=m4 2005-10-03 19:45:03 File Content transferred: 0 bytes
LIB: id=m4 2005-10-03 19:45:03 [Mon Oct 03 19:45:03 2005] Deployment COMPLETED
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 After CLEANUP res=1
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 exiting cleanup
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 entering task-failed
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 still waiting for 0
ENG: 2005-10-03 19:45:03 CST GMT+08:00 External version for Sender = 6.0.1.0.0
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Published receive event depUuid=[229a3a50-3403-11da-beda-e4463e343462] legLabel=[mylocalhost]
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 Job ID=m4 Deployment leg=Case2/MountToODServerForCustomer.MYDEFINITIONNAME.mylocalhost Elapsed Time=250 ms <<<
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 End logfile [C:\od-home\base\OpenDeployNG\log\Case2\rcv.MountToODServerForCustomer.MYDEFINITIONNAME.temp2.to.mylocalhost.log]
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 Begin logfile [C:\od-home\base\OpenDeployNG\log\Case2\rcv.MountToODServerForCustomer.MYDEFINITIONNAME.temp2.to.mylocalhost.log] ---------
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 Job ID=m4 Deployment=Case2/MountToODServerForCustomer.MYDEFINITIONNAME.mylocalhost
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 OpenDeploy Version is 6.0.1.0.0
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 Owner started the deployment is TEMP2\administrator
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 Internal config file is C:\od-home\base\OpenDeployNG\db\.odrcvr.20014
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 ** Simulate flag = false
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 ** Synchronous flag = false
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 exiting initial
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 entering setup
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 Path registry check (sec): checkinterval=30
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 Path registry check disabled
LIB: 2005-10-03 19:45:03 LOGFILE=[C:\od-home\base\OpenDeployNG\log\Case2\rcv.MountToODServerForCustomer.MYDEFINITIONNAME.temp2.to.mylocalhost.log]
LIB: 2005-10-03 19:45:03 Locale=[TraditionalChinese_Taiwan.MS950@Binary]
LIB: (2) 2005-10-03 19:45:03 Bound to port 20014
LIB: 2005-10-03 19:45:03 [Mon Oct 03 19:45:03 2005] Deployment INITIATED
LIB: id=m4 2005-10-03 19:45:03 Interwoven OpenDeploy(6.0.1.0.0 Build 41860 Interwoven 20041018)
LIB: id=m4 2005-10-03 19:45:03 LIB: Component Version (6.0.1.0.0 Build 41860 Interwoven 20041018)
LIB: id=m4 2005-10-03 19:45:03 Protocol Version(5.0) OK
LIB: id=m4 2005-10-03 19:45:03 Connection Id(id=m4)
LIB: id=m4 2005-10-03 19:45:03 platform: server(MSWIN32), client(MSWIN32)
LIB: id=m4 2005-10-03 19:45:03 Transaction Mode: ON
LIB: id=m4 2005-10-03 19:45:03 Mode(normal)
LIB: id=m4 2005-10-03 19:45:03 Protocol(normal)
LIB: id=m4 2005-10-03 19:45:03 Buffer Size (8000)
LIB: id=m4 2005-10-03 19:45:03 Host(TEMP2)
LIB: id=m4 2005-10-03 19:45:03 User(nt authority\system)
LIB: id=m4 2005-10-03 19:45:03 Deployname(.MountToODServerForCustomer.MYDEFINITIONNAME.mylocalhost)
LIB: (2) id=m4 2005-10-03 19:45:03 Connection accepted!
LIB: (2) id=m4 2005-10-03 19:45:03 Buffer Size (8000)
LIB: id=m4 2005-10-03 19:45:03 Number of local_directories to deploy: 1
LIB: id=m4 2005-10-03 19:45:03 BEGINNING Transactional Deployment
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 After SETUP res=0
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 exiting setup
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 entering awaiting-dotask
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 still waiting for 0
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 exiting awaiting-dotask
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 entering dotask
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 COMPARE
LIB: id=m4 2005-10-03 19:45:03 FailedCommit 0.
LIB: id=m4 2005-10-03 19:45:03 Destination directory [z:\tamis2_deploy_case2]
LIB: 2005-10-03 19:45:03 ERROR: z:\tamis2_deploy_case2 could not be created.
LIB: 2005-10-03 19:45:03 ERROR: Failed deploying local_directory[0] (C:\Inetpub\wwwroot\TamisWeb_Dev\Tamis) to (z:\tamis2_deploy_case2)
LIB: 2005-10-03 19:45:03 ERROR: Failed 1 of 1 local_directories
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 After COMPARE res=-1
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 Got Task failed string in COMPARE sub stage
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 write Longline TASKFAIL in COMPARE sub stage
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 exiting dotask
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 entering awaiting-rollback
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 Got task failed in precommit
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 still waiting for 0
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 exiting awaiting-rollback
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 entering rollback
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 failedCommit=false shouldWait=true
LIB: id=m4 2005-10-03 19:45:03 FailedCommit 0.
LIB: id=m4 2005-10-03 19:45:03 ROLLBACK Transactional Deployment
LIB: id=m4 2005-10-03 19:45:03
*** ROLLBACK performed: Saved txlist file (c:\temp\iwdir3) ***
LIB: id=m4 2005-10-03 19:45:03
Directories deployed : 0 Files deployed : 0 Links deployed : 0
Directories failed : 0 Files failed : 0 Links failed : 0
Directories deleted : 0 Files deleted : 0 Links deleted : 0
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 After ROLLBACK res=0
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 exiting rollback
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 entering awaiting-cleanup
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 still waiting for 0
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 exiting awaiting-cleanup
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 entering cleanup
LIB: id=m4 2005-10-03 19:45:03 FailedCommit 0.
LIB: id=m4 2005-10-03 19:45:03 File Content transferred: 0 bytes
LIB: id=m4 2005-10-03 19:45:03 [Mon Oct 03 19:45:03 2005] Deployment COMPLETED
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 After CLEANUP res=1
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 exiting cleanup
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 entering task-failed
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 still waiting for 0
ENG: 2005-10-03 19:45:03 CST GMT+08:00 External version for Sender = 6.0.1.0.0
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Published receive event depUuid=[229a3a50-3403-11da-beda-e4463e343462] legLabel=[mylocalhost]
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 Job ID=m4 Deployment leg=Case2/MountToODServerForCustomer.MYDEFINITIONNAME.mylocalhost Elapsed Time=250 ms <<<
ENG: 2005-10-03 19:45:03 CST GMT+08:00 Thread-23 End logfile [C:\od-home\base\OpenDeployNG\log\Case2\rcv.MountToODServerForCustomer.MYDEFINITIONNAME.temp2.to.mylocalhost.log]
Migrateduser
OD can deploy to/from mounted drives, but only on Win2k and below. This is due to limitations imposed by Windows in how they actually map drives starting in Windows XP. In Win2k and earlier, a drive was mapped globally to the machine and any user with the proper credentials could have access to it. In Windows XP and beyond, each drive is mapped per logon. That means that each OD service would have to "somehow" map it's own drive letter for it's logon session.
Starting with OD6.0.2_SP1 which was just released, we support the use of UNC pathnames instead of mapped drives so you can avoid this problem on newer Windows boxes.
--
Mike Szela
Sr. Member of Technical Staff
Interwoven, inc.
MixedAggregation.rptdesign
Herman
SO,
I must use windows 2003 Server(with Sp1),
What 's the best solution of Interwoven' production?
Teamsite 6.5 sp2
OpenDeploy 6.0.2 Sp1
Do I use the latest version?
Migrateduser
If you use UNC path naming as described by Mike, you should be ok.
Alternatively, instead of starting OD as a service, run OD in the foreground from a DOS console to access the mapped drive: <od-home>/test/deploy_agent.bat
Todd Scallan
Sr. Dir. Product Mgt.
Interwoven
t: 408-530-7167
e:
tscallan@interwoven.com
Herman
Now I installed OD6.0.2 and Sp1,
and use UNC to deploy:
<target>
<targetFilesystem area="\\ServerName\Deploy_Case\"/>
<comparisonRules dateDifferent="yes"/>
<replicationFarmLink>
<internal name = "MYFARMNAME"/>
</replicationFarmLink>
</target>
</definition>
But I didn't make it success.
Is this configure correct?
Migrateduser
Make sure you've got the allowed dir configured properly on the target using the UNC convention.
Todd Scallan
Sr. Dir. Product Mgt.
Interwoven
t: 408-530-7167
e:
tscallan@interwoven.com