Hi,
Teamsite 6.5 sp2 - solaris. We are trying to configure RDBMS, Oracle 9i for Event subsystem
Have followed all the steps mentioned in the documentation. However when i stop and start the Event subsystem, it fails to start.
This is what I see in the error logs (eventsubd.log)
EVENTSUBD_HOME is set to /usr/iw-home/eventsubsystem
OpenJMS 0.7.6.1
The OpenJMS Group. (C) 1999-2004. All rights reserved.
http://openjms.sourceforge.netorg.exolab.jms.server.FailedToCreateServerException: org.exolab.jms.config.ConfigurationFileException: Error occured in /usr/iw-home/eventsubsystem/conf/jmsconfignew.xml ValidationException: user is a required field.;
- location of error: XPATH: Configuration/DatabaseConfiguration/RdbmsDatabaseConfiguration{file: [not available]; line: 76; column: 17}
at org.exolab.jms.config.ConfigurationManager.setConfig(Unknown Source)
at org.exolab.jms.server.JmsServer.(Unknown Source)
at org.exolab.jms.server.JmsServer.main(Unknown Source)
A standalone Java program to test the connectivity to Oracle DB was written and it works fine.
following is my jmsconfignew.xml file
databaseType="rdbms"
garbageCollectionInterval="180"
garbageCollectionBlockSize="500"
garbageCollectionThreadPriority = "5" >
driver="oracle.jdbc.driver.OracleDriver"
url="jdbc

racle:thin:
@135.8.224.93:1521:ecmd"
userName="iweventsubd"
password="N3wY3ars"
retries="5"
timeout="2000"/>
script="${openjms.home}\bin\startjms.bat"
config="${openjms.home}\config\examples\tcp_jms_full.xml" />
lowWaterThreshold="20"
garbageCollectionInterval="120"
garbageCollectionThreadPriority="5">
Will appreciate if someone can help me with this..
Thanks and Regards
Hemanth