Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
evebt subsytem / disk space
Valentine
Just upgraded the dev box to 6.5SP1. Everything seems to be OK, except for
the "eventsubsytem" which is taking all of the diskspace with the openjms.db file ...
So, what is the role of the event subsytem? OD deployments?
DAS?
log_event* ?
Can I disable it as suggested previously?
Find more posts tagged with
Comments
stefanmaier
Hi,
the event subsystem is a message delivering mechanism which can be used for triggering different actions.
Some processes can publish events (perhaps if a authors saves a DCR in his workrea or a user starts a deployment),
some processes can listen for events and react on an event (e.g. a DAS deployments starts if a DCr save event is recognized).
So, if you want to use this auto trigger mechanism, you have to active the event subsystem.
I don't know if the event subsystem can complete shut down, perhaps someone else could throw light on this...
If you have problems with the file size of the events DB and if you have the possibility to write your events into
an additional SQL server, you should reconfigure your event subsystem like described in the TS admin guide, so that events
are written into a external DB.
Stefan
Valentine
This is ridiculous. The openjms.db is now 11Gb after 2 days of usage.
And yes, the eventd is a requirement, but we do not have a spare RDBMS.
smenon
The problem you are seeing is a known issue with OpenJMS which is the underlying technology for the event subsystem. I would recommend that you try and get a copy of MySQL (which is very cheap) and configure the event subsystem to persist its data to MySQL. There is a KB article available that discusses how to configure the event subsystem with MySQL.
thanks
--Sunil Menon
Sr. Product Manager
Interwoven, Inc.
Migrateduser
You can have the event subsystem disable to run teamsite, but you will need it running if you plan on using the search functionality or the reporting functionality as these two components require you to have the subsystem running.
pbenn
****! This is affecting our other server ... how big does the table space need to be for the jms server? Does it need to be cleared out periodcially?
P.
smenon
If you are using MySQL, SQL Server, Oracle or DB2, this should not be a problem.. OpenJMS cleans up the events after they are consumed and disk space is really not a big issue in that case. If you are using the "default" option for OpenJMS which is their "flat-file" openjms.db, then the bug prevents the event information from being cleared up and hence you see the growth which could be pretty rapid depending on usage..
If you are seeing rapid growth to the extent that it is affecting your server, I would recommend at least using MySQL as the database for the event subsystem. It is a very inexpensive option and it is good enough to handle the requirements for the event susbsystem.
thanks
--Sunil Menon
Sr. Product Manager
Interwoven, Inc.
Johnny
Have you considered fixing the bug in openJMS so that your customers do not have to rely on an external rdbms? Not everybody has access to one.
Considering Interwoven *heavily* relies on open source products - I see this as a perfect opportunity to contribute back while providing a fix to their customers instead of standing behind another products bug.
John Cuiuli
chuckles
That, or bundling with MySQL or some other free DB with the option to configure with whatever DB the customer may have.
For now, you can add "IWHOME/private/bin/iweventsubd stop" to your start up script. That will stop it from logging events.
Edited by chuckles on 10/25/05 08:23 AM (server time).
w18111
looks like we are running into the same issue, could I just disbale eventsubsystem in iw.cfg ??
i.e. ew_enable=false
Phil
Changing ew_enable to false does not prevent this file from growing and causing problems. If you do not have access to a RDBMS and are not relying on the data in the event subsystem then your best option is to prevent the event subsystem from starting up. On Solaris we modified the startup script (/etc/init.d/iw.server) and commented out the lines that start the iweventsubd process.
Phil
Migrateduser
how about a fix for this instead of suggesting customers to buy additional products?
see my post here:
http://devnet.interwoven.com/forums/cgi-bin/showflat.pl?Cat=&Board=PRODUCTS_OPENDEPLOY&Number=69282&page=2&view=collapsed&sb=5&o=0&part=
openjms.log is now over 130meg...when it finally opens here is the error repeated over and over...
07:19:35.460 ERROR [Thread-1] - Failed to create new connection
java.net.SocketException: Socket closed
at java.net.PlainSocketImpl.socketAccept(Native Method)
at java.net.PlainSocketImpl.accept(PlainSocketImpl.java:353)
at java.net.ServerSocket.implAccept(ServerSocket.java:448)
at java.net.ServerSocket.accept(ServerSocket.java:419)
at org.exolab.core.mipc.MultiplexConnectionServer.run(MultiplexConnectionServer.java:152)
07:19:35.460 ERROR [Thread-1] - Failed to create new connection
java.net.SocketException: Socket closed
at java.net.PlainSocketImpl.socketAccept(Native Method)
at java.net.PlainSocketImpl.accept(PlainSocketImpl.java:353)
at java.net.ServerSocket.implAccept(ServerSocket.java:448)
at java.net.ServerSocket.accept(ServerSocket.java:419)
at org.exolab.core.mipc.MultiplexConnectionServer.run(MultiplexConnectionServer.java:152)
07:19:35.460 ERROR [Thread-1] - Failed to create new connection
java.net.SocketException: Socket closed
at java.net.PlainSocketImpl.socketAccept(Native Method)
at java.net.PlainSocketImpl.accept(PlainSocketImpl.java:353)
at java.net.ServerSocket.implAccept(ServerSocket.java:448)
at java.net.ServerSocket.accept(ServerSocket.java:419)
at org.exolab.core.mipc.MultiplexConnectionServer.run(MultiplexConnectionServer.java:152)
07:19:35.460 ERROR [Thread-1] - Failed to create new connection
java.net.SocketException: Socket closed
at java.net.PlainSocketImpl.socketAccept(Native Method)
at java.net.PlainSocketImpl.accept(PlainSocketImpl.java:353)
at java.net.ServerSocket.implAccept(ServerSocket.java:448)
at java.net.ServerSocket.accept(ServerSocket.java:419)
at org.exolab.core.mipc.MultiplexConnectionServer.run(MultiplexConnectionServer.java:152)
07:19:35.460 ERROR [Thread-1] - Failed to create new connection
java.net.SocketException: Socket closed
at java.net.PlainSocketImpl.socketAccept(Native Method)
at java.net.PlainSocketImpl.accept(PlainSocketImpl.java:353)
at java.net.ServerSocket.implAccept(ServerSocket.java:448)
at java.net.ServerSocket.accept(ServerSocket.java:419)
at org.exolab.core.mipc.MultiplexConnectionServer.run(MultiplexConnectionServer.java:152)
WoW Profile
TS 6.5 SP1
OD 6.0.2
jkm
hi guys,
Also in similar situation ... I openjms is creating a huge log file but that I can avoid by stopping the event subsystem but at the sametime its creating openjms.lk file and deployments just stops after tht ...In my deployment i push the content to recv OD first and then in dnr run data deploy to push the same to database. but becaue of openjms.lck its not able to deploy... any idea why its happening
TS 6.5 solaris + SP2 + OD 6.0.2
jkm
I think my initial investigation was wrong.. I am facing something similar situation as provided in this thread
http://devnet.interwoven.com/forums/cgi-bin/showthreaded.pl?Cat=&Board=PRODUCTS_OPENDEPLOY&Number=40254&page=&view=&sb=&o=&vc=1#Post40254
But as suggested I am not aware how to redirect the index files or intermittent files of OD. Can any body assist on this.
Migrateduser
For the DB disk space issue this might be helpful:
http://devnet.interwoven.com/forums_vb/showthread.php?t=18753&forumid=11
(Can we use Apache Derby (aka. Java DB) for event subsystem DB
?
)