Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
OD Error
kshitiz
Hi All,
I'm getting following error while deploying some files using OpenDeploy. Can anyone tell me what could be the source of the error?
ENG: 2005-10-19 07:23:50 BST GMT+01:00 Thread-108 ***ERROR - Job ID=m19Deployment=wft_opendeploy-all733694
Base: Exceeded all 3 retries to get a connection with the target OpenDeploy host.
Failed creating socket.
Kshitiz Sharma
BT Wholesale | CMS
Mahindra British Telecom
Find more posts tagged with
Comments
Adam Stoller
It sounds like either:
a) you have a defined target node on which the OpenDeploy Receiver is either not running, or not listening on the expected port, or
b) you have a firewall between source and target nodes which is interfering with direct-path communications, or
c) you have some network problems that are causing disruptions between source and target server.
--fish
Senior Consultant, Quotient Inc.
http://www.quotient-inc.com
jed
Or you enabled SSL on the receiver but do not have it setup on the base. (That one dinged me last week.)
--
Jed Michnowicz
jedm@sun.com
Content Management Engineering
Sun Microsystems
nipper
what is the target and port you are trying to reach ?
try
telnet receiver port
kshitiz
Thank you all for help
I've been able to resolve the previous problem. Apparantely, there was port mismatch between OD base and receiver.
But now I'm facing a new kind of error while deploying.
On my base server I'm finding following error in log files:
ENG: 2005-10-24 14:29:26 BST GMT+01:00 Thread-92 Buffer Size 8000
ENG: 2005-10-24 14:29:26 BST GMT+01:00 Thread-92 After Connect RC = 0
ENG: 2005-10-24 14:29:26 BST GMT+01:00 Thread-92 Sender-side handshake timeout = 120 secs
ENG: 2005-10-24 14:29:26 BST GMT+01:00 Thread-92 Send version string to receiver, RC = 13
ENG: 2005-10-24 14:29:26 BST GMT+01:00 Thread-92 Send attributes to receiver, RC = 0
ENG: 2005-10-24 14:29:26 BST GMT+01:00 Thread-92 ***ERROR - Read attributes from receiver failed, got null.
ENG: 2005-10-24 14:29:26 BST GMT+01:00 Thread-92 exiting setup
ENG: 2005-10-24 14:29:26 BST GMT+01:00 Thread-92 entering awaiting-cleanup
ENG: 2005-10-24 14:29:27 BST GMT+01:00 Thread-92 still waiting for 4
ENG: 2005-10-24 14:29:27 BST GMT+01:00 Thread-92 exiting awaiting-cleanup
ENG: 2005-10-24 14:29:27 BST GMT+01:00 Thread-92 entering cleanup
ENG: 2005-10-24 14:29:27 BST GMT+01:00 Thread-92 exiting cleanup
ENG: 2005-10-24 14:29:27 BST GMT+01:00 Thread-92 entering task-failed
ENG: 2005-10-24 14:29:27 BST GMT+01:00 Thread-92 still waiting for 4
While on the receiver end, the corresponding log is not getting generated.
Anybody has some idea about it?
Kshitiz Sharma
BT Wholesale | CMS
Mahindra British Telecom
brandon1
As mentioned earlier by ghoti, etc. You need to ensure that you are able to connect to the target from the base with the proper port. Telnet is a great way to do this since it takes a port number.
1. On the base server get a command prompt
2. Type
telnet targetserverhostname port
3. If the window goes blank success
4. If you get an error than there is something (firewall,proxy,etc) in the way that is preventing you from getting to the target. At that point it is a matter of working with network folks to analyze the problem.
5. A tracert from the base to the target will give you the hops that are occurring hence potential break points
HTH,
Brandon
Current Project: TS 6.1
Environment: Windows
kshitiz
Hi Brandon,
The earlier problem in which I was not able to connect to the receiver has been resolved. But as mentioned in my last post I'm facing a new problem. OD base is successfully able to connect to the OD receiver but the deployment is getting failed and following error is seen in logs:
ENG: 2005-10-24 14:29:26 BST GMT+01:00 Thread-92 ***ERROR - Read attributes from receiver failed, got null.
Kshitiz Sharma
BT Wholesale | CMS
Mahindra British Telecom
Kshitiz Sharma
BT Wholesale | CMS
Mahindra British Telecom
PaulD
You might've figured it out, but I've seen this when I've had SSL mis-configured. The instructions are not that clear to me so it took me several tries to get it right.
Paul
cc96ai
I got that error too
ENG: 2005-11-21 14:31:45 EST GMT-05:00 Thread-12 ***ERROR - Job ID=m1Deployment=odDeploy_test
Base: Exceeded all 3 retries to get a connection with the target OpenDeploy host.
Failed creating socket.
You mention about on SSL,
how to configure SSL in OD ?
--------------------------------------------
TS 6.1 W2K3
TS 6.5 SP2, W2K3 SP1
OpenDeploy 6.0
cc96ai
After restart the machine ,
OD seem working again .... .... . .
--------------------------------------------
TS 6.1 W2K3
TS 6.5 SP2, W2K3 SP1
OpenDeploy 6.0
PaulD
The detailed instructions are in the manual. Basically you create the certificate authority (cacert.pem) and then the public and private key files. Then confure odbase.xml with these. Next create public and private key files for the target/source servers, copy them to the target/source servers and add them to the deployment configurations.
I did it on OD5.6 so make sure this high level fits for v6.0
Paul
cc96ai
we just setup another development machine
however I am unable to deploy any files to live server ( the receiver is working, coz we test OD on production machine)
ENG: 2005-11-21 16:15:16 EST GMT-05:00 Thread-19 ***ERROR - Job ID=m5Deployment=odDeploy_test
Base: Exceeded all 3 retries to get a connection with the target OpenDeploy host.
Failed creating socket.
Does it mean I have to regenerate the public/private key too ?
--------------------------------------------
TS 6.1 W2K3
TS 6.5 SP2, W2K3 SP1
OpenDeploy 6.0
PaulD
Yes, you need to generate a pub/pri key pair for each host you intend to connect to. I would suggest adding the target/source hostname to the common name field for each host you connect with.
Without anymore info, i would only be guessing