Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
Fail-over Problem in WSMP Cluster
jman
A WSMP cluster is setup with the following,
1.1. Configure DNS :
a) Add SrvA …..Ip1
b) Add SrvB-----Ip2
c) Add Cluster name (MP) -------Ip1
d) Add Cluster name (MP) -------Ip2
1.2. Start “Process Manager” on both the servers of the cluster (SrvA and SrvB).
1.3. Start “Configuration Manager” on one of the servers (SrvA).
1.4. Configure one server (SrvA), save the configuration, by clicking on the save icon on Configuration Mgr toolbar. Start everything and see the application connecting to cms server and get data on browser
1.5. Add the second server (SrvB), save configuration again.
1.6. Restart “Process Manager” on both servers and see the configuration manager shows all servers.
Testing Result
1) Loading Balance(for Office Integration)
Client machine can connect to one of the application server in round-robin pattern. Result is OK.
2) Failover (by shutdown SrvA) (for Office Integration)
Current user cannot connect automatically failover to the other second node. Moreover, pop an error window with “Server not found” message. User need to logoff and logon again to connect to the second node. New user cannot find the SrvA as DNS still assign the SrvA IP to the new user based on the round-robin manner of DNS. Result is not OK.
3) Loading Balance (for IE browser)
User can browse the system in round-robin pattern. Result is OK.
4) Failover (by shutdown SrvA) (for IE browser)
Current user will be redirected to the screen with error “The Server is temporarily busy serving other requests. Click back and then repeat your previous steps. If this problem persists, contact your support staff." New user cannot logon and show the page with error code 404. Result is not OK.
Looks like the client (both web and desktop) connects to one of the Process Manager in the cluster based on the IP returned from DNS. So in the above case, SrvA is down but DNS (round-robin manner) still return IP of ServA for the client to connect which becomes a connection error or timeout.
What's the internal logic of the fail-over mechanism? What's missing in my configuration and how to make the fail-over work?
Thanks,
John
Find more posts tagged with
Comments
Migrateduser
If this is for a customer, I would recommend contacting tech support or at least sales tech support. Otherwise if you are not looking for immediate response/resolution, please post your log files (webapp,wom and cms logs. Please generate a clean set of logs; shut down web and cms, remove existing logs, start web and cms.) here.
group.rptdesign
jman
Hi Bijo,
Quick resposne is needed. Even I start fresh on new set of logs, the log files are still too big to attach here. Attached is the web component logs.
Would you please advise which files to look for error message?
Thanks,
John