Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
OpenDeploy 6.0.2 SP1 Services do not shutdown
Bill Klish
TeamSite 6.1 Linux
OpenDeploy 6.0.2 SP1
RedHat EL 3.0
The scripts located in /etc/init.d (iwod60, iwodadmin, iwaccess) do not shut themselves down during a server restart. Are they supposed to? I see Stopping iw.server, iw.local, httpd, etc., but all of the OD services are never shut down.
I had to manually update the scripts for them to shut the services down. Coincidentally, this same issue happened on the TeamSite services until I fixed it. Is this a bug in your scripts? Would you like the updated code back?
Thanks,
-Bill
Find more posts tagged with
Comments
jed
On Solaris, my big gripe is after a hard crash OD will not restart since the ".odrunning" file is not deleted. Why can't OD perform some sort of pid or port check to determine if an instance is already running? A pid/process check could be difficult due to someone running multiple instances, but this should be sufficient, right?
netstat -a | grep <od-port>
PS: We only have hard crashes due to power failures. Our hardware/OS NEVER fails
(Yummy. The company kool-aid is especially tastey today!)
--
Jed Michnowicz
jedm@sun.com
Content Management Engineering
Sun Microsystems
Edited by jed on 11/02/05 10:54 AM (server time).