Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
Web Component Connection Pool Error
jman
i,
WSMP4.1SP1 HFB7 on Windows 2003.
Configured WSMP in a 3-tier structure, i.e. Web Component and WSMP Server are on separate server. DNS should be OK as desktop client is able to connect and works fine. However, after TomCat started up for a while, some Java exceptions on Connection Pool appears and web client (Internet Explorer) cannot connect with error message "The server is temporarily busy serving other requests".
The following is the snapshot of the error log found under c:\worksitemp\log\worksitemp.log, attached is the whole file,
2006-03-20 18:28:00,941 INFO [http8080-Processor4] com.imanage.workteam.appservices.auth.LoginServlet - Received POST request from Host: iw-jman.hktdc.org, Url: /worksitemp/login, ContentLength: 35
2006-03-20 18:28:00,941 INFO [http8080-Processor4] com.imanage.workteam.appservices.auth.LoginServlet - datasource:null, operation:null, objectId:null, sessionId:null
2006-03-20 18:29:00,977 INFO [http8080-Processor4] com.imanage.workteam.exceptions.ServerConnectionPoolTimeoutException - The server is temporarily busy serving other requests.
The server is temporarily busy serving other requests.
Context: ServerAccess
Details: A request for a CMS connection timed out after the maximum wait time. (The default value is 30 seconds.) See the stack trace for more information.
Action: Click Back and then repeat your previous steps. If this problem persists, contact your support staff.
com.imanage.workteam.exceptions.ServerConnectionPoolTimeoutException(com.imanage.cms.exceptions.cmsconnection.CmsConnectionTimeoutException:The POE library was not registered for cluster wimsws.hktdc.org
The following clusters have been registered:
)
Underlying StackTrace:
com.imanage.cms.exceptions.cmsconnection.CmsConnectionTimeoutException: The POE library was not registered for cluster wimsws.hktdc.org
The following clusters have been registered:
at com.imanage.cms.fc.cmsconnection.CmsConnectionPoolMgrData.getPoeLibraryName(CmsConnectionPoolMgrData.java:83)
at com.imanage.cms.fc.cmsconnection.CmsConnectionPoolMgr.getPoeLibraryName(CmsConnectionPoolMgr.java:267)
at com.imanage.cms.t2.jom.impl.PoolManager.getPOELibraryName(PoolManager.java:296)
at com.imanage.cms.t2.jom.SessionManager.getPOELibraryName(SessionManager.java:241)
at com.imanage.cms.t2.jom.impl.EnterpriseSessionImpl.getLoggedOnTrustee(EnterpriseSessionImpl.java:136)
at com.imanage.cms.t2.jom.impl.SessionImpl.logonImpl(SessionImpl.java:86)
at com.imanage.cms.t2.jom.impl.EnterpriseSessionImpl.logon(EnterpriseSessionImpl.java:23)
at com.imanage.cms.api.workteam.impl.EnterpriseSessionImpl.logon(EnterpriseSessionImpl.java:48)
at com.imanage.workteam.appservices.session.CmsEnterpriseSessionProxy.openCmsSession(CmsEnterpriseSessionProxy.java:81)
at com.imanage.workteam.appservices.session.CmsSessionProxy.connect(CmsSessionProxy.java:101)
at com.imanage.workteam.appservices.session.AppSession.connect(AppSession.java:168)
at com.imanage.workteam.appservices.session.AppSessionManager.createSession(AppSessionManager.java:537)
at com.imanage.workteam.appservices.session.AppSessionManager.createSession(AppSessionManager.java:468)
at com.imanage.workteam.BaseServlet.createSession(BaseServlet.java:207)
at com.imanage.workteam.appservices.auth.LoginServlet.tryLogin(LoginServlet.java:236)
at com.imanage.workteam.appservices.auth.LoginServlet.processLogin(LoginServlet.java:143)
at com.imanage.workteam.appservices.auth.LoginServlet.serviceBody(LoginServlet.java:92)
at com.imanage.workteam.AbstractBaseServlet.service(AbstractBaseServlet.java:179)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:247)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:193)
at com.imanage.workteam.dispatch.WsmpFilter.doFilter(WsmpFilter.java:69)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:213)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:193)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:256)
at org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNext(StandardPipeline.java:643)
at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:480)
at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:995)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
at org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNext(StandardPipeline.java:643)
at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:480)
at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:995)
at org.apache.catalina.core.StandardContext.invoke(StandardContext.java:2422)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:180)
at org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNext(StandardPipeline.java:643)
at org.apache.catalina.valves.ErrorDispatcherValve.invoke(ErrorDispatcherValve.java:171)
at org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNext(StandardPipeline.java:641)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:163)
at org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNext(StandardPipeline.java:641)
at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:480)
at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:995)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:174)
at org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNext(StandardPipeline.java:643)
at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:480)
at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:995)
at org.apache.coyote.tomcat4.CoyoteAdapter.service(CoyoteAdapter.java:199)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:828)
at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection(Http11Protocol.java:700)
at org.apache.tomcat.util.net.TcpWorkerThread.runIt(PoolTcpEndpoint.java:584)
at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:683)
at java.lang.Thread.run(Thread.java:534)
Any idea?
Thanks,
John
Find more posts tagged with
Comments
jman
In particular, what's the meaning of "The POE library was not registered for cluster "? What's a POE library?
John
Migrateduser
This generally happens when you library configuration in the Web App deployment manager section is not perfect. Please re-edit the CMS configuration settings and set the logging level to debug before restarting the webapp. Please delete the current set of webapp/wom/cms logs, restart all the services. If you still have problems, please post all the logs as a zip attachment here. I will help you out.
Migrateduser
POE means, Point Of Entry library. This the technical term for the Authentication Library in CMS Configuration Manager's Edit Cluster dialog.