Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
Error
Bhargav Coca
Hello,
Can any one throw a light on this error please, never seen it before.
I am on TS6.5 on Win2k3.
Thank you
Root cause:
SAX Parse:Content is not allowed in prolog.
Details...
com.interwoven.ui.formspub.datacapture.dct.InlineCallout$InlineCalloutException: SAX Parse:Content is not allowed in prolog.
at com.interwoven.ui.formspub.datacapture.dct.InlineCalloutProcessor.evaluateInlineCallouts(InlineCalloutProcessor.java:134)
at com.interwoven.ui.formspub.datacapture.DCRPredicate.buildDCRDocument(DCRPredicate.java:173)
at com.interwoven.ui.formspub.datacapture.NewDCRPredicate.execute(NewDCRPredicate.java:67)
at com.interwoven.ui.formspub.datacapture.NewDCRCommand.execute(NewDCRCommand.java:309)
at com.interwoven.ui.base.impl.command.CommandHandler.doExecuteCommand(CommandHandler.java:865)
at com.interwoven.ui.base.impl.command.CommandHandler.tryRunCommandDescriptor(CommandHandler.java:713)
at com.interwoven.ui.base.impl.command.CommandHandler.tryRunCommandID(CommandHandler.java:596)
at com.interwoven.ui.base.impl.command.CommandHandler.runCommand(CommandHandler.java:425)
at com.interwoven.ui.base.impl.command.CommandCallbackContextImpl.callback(CommandCallbackContextImpl.java:45)
at com.interwoven.ui.base.wizard.WizardCommand.execute(WizardCommand.java:114)
at com.interwoven.ui.base.impl.command.CommandHandler.doExecuteCommand(CommandHandler.java:865)
at com.interwoven.ui.base.impl.command.CommandHandler.tryRunCommandDescriptor(CommandHandler.java:713)
at com.interwoven.ui.base.impl.command.CommandHandler.tryRunCommandID(CommandHandler.java:596)
at com.interwoven.ui.base.impl.command.CommandHandler.runCommandLoop(CommandHandler.java:240)
at com.interwoven.ui.base.impl.command.CommandServlet.doGet(CommandServlet.java:244)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:237)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
at com.interwoven.ui.base.impl.auth.AuthenticationFilter.doFilter(AuthenticationFilter.java:206)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:186)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
at com.interwoven.ui.base.util.SetRequestEncodingFilter.doFilter(SetRequestEncodingFilter.java:105)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:186)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:214)
at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
at org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:198)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:152)
at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:137)
at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:102)
at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:929)
at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:160)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:799)
at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection(Http11Protocol.java:705)
at org.apache.tomcat.util.net.TcpWorkerThread.runIt(PoolTcpEndpoint.java:577)
at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:683)
at java.lang.Thread.run(Thread.java:534)
Find more posts tagged with
Comments
nipper
what were you doing when you got this ? Or was this just in an error log ?
Bhargav Coca
This is generated when i create a New DCT, This occurs for my ipl file which connects to databse to populate the select box.
Thanks
nipper
whar is the ipl returning ?
If the ipl is not there it works ?
Only new DCRs not existing DCRs ?
May want to post your ipl
JonathonG
Typically, this message:
SAX Parse:Content is not allowed in prolog.
from an inline script means that you printed something to STDOUT prior to the <substitution> tag. XML does not allow content to appear before the root element. My best guess as to why is that your inline failed somehow and printed its error to STDOUT.
Jonathon
Interwoven Developer
Allstate, Inc.
Migrateduser
Have you tried running your .ipl from the command line to see what it's output is?
Bhargav Coca
Thank you, I had one print statement before substitution tag which was giving me this error, I was using that to create a log file for debugging my ipl file. Now that it is removed it works fine. But the interesting thing to know is that my script ran when i installed a SQL client on the box, thats kinda strange, and i didn't use any ENV variables.
Thank you all