Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
DD 6.0.2 - No area/basearea/myarea/mybasearea para
boskovuk
Our DD, iwodcmd appears to be succeeding (returned error code is 0 and no other erros are reported in OD logs) . However, the database (Oracle) is not updated (i.e. it doesn't contain inserted DCR).
We see this message, that looks suspicios:
DD : No area/basearea/myarea/mybasearea parameter specified.
This is coming from OD_HOME/log/irc-ce_odbase.log file
ENG: 2005-08-08 17:32:36 EDT GMT-04:00 Synchronous deployment. MacroDeploy Session[m15,irc_dd/tmp/irc_product_TZ9xK]
started
ENG: 2005-08-08 17:32:36 EDT GMT-04:00 Adding session m15(irc_dd/tmp/irc_product_TZ9xK)
DD : Invoking DD with following arguments:
DD : iwdd="irc_product" dcr_to_deploy="/templatedata/CCMC/product/data/bo-47~0500100562" cfg=/opt/Interwoven/OpenD
eployNG/conf/irc_dd.xml need-result=yes depuuid=f01337b0-0853-11da-a3fd-da2ca0be3027 leglabel=database logfile=/opt/
Interwoven/OpenDeployNG/log/irc_dd/tmp/src.irc_product_TZ9xK.irc_product.irc-ce.to.database.log
DD : thread[DDThread] accepted connection(15)!
DD : awaiting msg...
DD : No area/basearea/myarea/mybasearea parameter specified.
DD : Routing the command to DASCommandProcessing Thread.
DD : DataDeploy output : [result=true]
DD : Receieved error code : 0
ENG: 2005-08-08 17:32:37 EDT GMT-04:00 Removing session m15(irc_dd/tmp/irc_product_TZ9xK)
DD : EventHandler class com.interwoven.dd100.syncdb.TUpdateDeltaTables
DD : adds type = CCMC/product - /default/main/IRC/CCMC/WORKAREA/CCMC/templatedata/CCMC/product/data/bo-47~0500100562
DD : Files by type: CCMC/product
DD : /var/tmp/ddt34790.tmp
DD : File list file: /var/tmp/ddt34790.tmp
DD : File list:
templatedata/CCMC/product/data/bo-47~0500100562
DD : Area name: /default/main/IRC/CCMC/WORKAREA/CCMC
DD : Base area name: /default/main/IRC/CCMC/STAGING
DD : Table name: DEFAULT_CCMC_PRODUCT__MAIN_IRC_CCMC_WORKAREA_CCMC
DD : BaseTable name: DEFAULT_CCMC_PRODUCT__MAIN_IRC_CCMC_STAGING
DD : Basetable Prefix: DEFAULT_CCMC_PRODUCT
DD : Basetable Suffix: MAIN_IRC_CCMC_STAGING
DD : Mytable Prefix: DEFAULT_CCMC_PRODUCT
DD : Mytable Suffix: MAIN_IRC_CCMC_WORKAREA_CCMC
DD : DoDeltaUpdate
Would this be the cause of the concern?
thanks ..
Solaris 5.9 - TS 6.5 sp1 - OD 6.0.2; DD enabled
Solaris 5.9 - TS 6.1 sp1 - OD 5.6; DD 5.6
Find more posts tagged with
Comments
Migrateduser
Can you attach your config file? Is it possible that your config file has a param subst for $area or $basearea, etc and you have not specified it on the command line?
Mariam
boskovuk
Well, this turned out to be a quite experience.
In a nutshell:
OD 6.0.2 database.xml config file had a valid IP address (the separate host for Oracle 9).
However, Oracle config file, on the host machine for TS 6.5 and OD 6.0.2:
/usr/local/oracle/9.2.0/network/admin/tnsnames.ora
was still pointing to the old/not-used Oracle server box (invalid IP address).
Therefore, OD, actually DD was executing and succeeding (i.e. no errors reported). However, we could not find new data in a database, since we were looking into new Oracle machine, not the old one (that was updated).
However, I still have a question/concern about DD 6.0.2 configuration environment. Why would DD consult Oracle tnsnames.ora file, even though its database.xml file had a valid and latest IP address information about Oracle server box?
Solaris 5.9 - TS 6.5 sp1 - OD 6.0.2; DD enabled
Solaris 5.9 - TS 6.1 sp1 - OD 5.6; DD 5.6
Migrateduser
DD doesn't use tnsnames.ora ... it simply uses the database.xml info to make the jdbc connection. Specifically, it calls java.lang.Drivermanager getConnection method ...this is a generic call across databases. So perhaps Oracle needs that file to be there ... but DD doesn't look at that file at all.
So I can't explain what you saw.. that's very odd.
Mariam
boskovuk
Mariam,
good and valid point.
You are right. DD exclusively uses database.xml. It was us who were connecting to the database through sqlplus command, which is based on:
/usr/local/oracle/9.2.0/network/admin/tnsnames.ora
So, DD was ok - however, our verification steps (toward database) were happening on the wrong database server machine (we have two, the new and the old one). Since we were connecting to the wrong database, we couldn't (naturally
) confirm that data had been inserted there.
Solaris 5.9 - TS 6.5 sp1 - OD 6.0.2; DD enabled
Solaris 5.9 - TS 6.1 sp1 - OD 5.6; DD 5.6
Ottawa_IWOV
WEIRD PROBLEM w/ Data Deploy 6.0.2
I have turned off DAS in odbase.xml
Now when I try and execute a deployment w iwodcmd start <ddclient> -k iwdd=<deploymentName> it fails
Search through the logs, it is trying to deploy w/
iwdd=master for some ODD reason.
I do not know how to resolve this problem at all:
Here is the log output:
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 Thread-18 Begin logfile [C:\od-home\OpenDeployNG\log\rcv.ke_transactional.XMLs.caws105ctoc.to.mylocalhost.log] ---------
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 Thread-18 Job ID=m1 Deployment=ke_transactional.XMLs.mylocalhost
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 Thread-18 OpenDeploy Version is 6.0.2.0.0
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 Thread-18 Owner started the deployment is SYSTEM
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 Thread-18 Internal config file is C:\od-home\OpenDeployNG\db\.odrcvr.20014
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 Thread-18 ** Simulate flag = false
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 Thread-18 ** Synchronous flag = true
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 Thread-18 exiting initial
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 Thread-18 entering setup
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 Thread-18 Path registry check (sec): checkinterval=30
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 Thread-18 Path registry check disabled
LIB: 2005-10-26 17:09:16 LOGFILE=[C:\od-home\OpenDeployNG\log\rcv.ke_transactional.XMLs.caws105ctoc.to.mylocalhost.log]
LIB: 2005-10-26 17:09:16 Locale=[English_UnitedStates.MS1252@Binary]
LIB: (2) 2005-10-26 17:09:16 Bound to port 20014
LIB: 2005-10-26 17:09:16 [Wed Oct 26 17:09:16 2005] Deployment INITIATED
LIB: id=m1 2005-10-26 17:09:16 Interwoven OpenDeploy(6.0.2.0.0 Build 46963 Interwoven 20050402)
LIB: id=m1 2005-10-26 17:09:16 LIB: Component Version (6.0.2.0.0 Build 47215 Interwoven 20050413)
LIB: id=m1 2005-10-26 17:09:16 Protocol Version(5.0) OK
LIB: id=m1 2005-10-26 17:09:16 Connection Id(id=m1)
LIB: id=m1 2005-10-26 17:09:16 platform: server(MSWIN32), client(MSWIN32)
LIB: id=m1 2005-10-26 17:09:16 Transaction Mode: ON
LIB: id=m1 2005-10-26 17:09:16 Mode(normal)
LIB: id=m1 2005-10-26 17:09:16 Protocol(normal)
LIB: id=m1 2005-10-26 17:09:16 Buffer Size (8000)
LIB: id=m1 2005-10-26 17:09:16 Host(MYHOSTNAME)
LIB: id=m1 2005-10-26 17:09:16 User(nt authority\system)
LIB: id=m1 2005-10-26 17:09:16 Deployname(.ke_transactional.XMLs.mylocalhost)
LIB: (2) id=m1 2005-10-26 17:09:16 Connection accepted!
LIB: (2) id=m1 2005-10-26 17:09:16 Buffer Size (8000)
LIB: id=m1 2005-10-26 17:09:16 Number of local_directories to deploy: 1
LIB: id=m1 2005-10-26 17:09:16 BEGINNING Transactional Deployment
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 Thread-18 After SETUP res=0
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 Thread-18 exiting setup
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 Thread-18 entering awaiting-dotask
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 Thread-18 still waiting for 0
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 Thread-18 exiting awaiting-dotask
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 Thread-18 entering dotask
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 Thread-18 COMPARE
LIB: id=m1 2005-10-26 17:09:16 FailedCommit 0.
LIB: id=m1 2005-10-26 17:09:16 Destination directory [c:\od-home\opendeployng\tmp\ke_content]
LIB: id=m1 2005-10-26 17:09:16 Options: deploy ignore_acls do_manifest_for_dnr verbose_level=5
LIB: id=m1 2005-10-26 17:09:16 COMPARE - dst[c:\od-home\opendeployng\tmp\ke_content] with src[C:\od-home\OpenDeployNG\examples\ke_content]
LIB: (3) id=m1 2005-10-26 17:09:16 Getting directory info for (.)
LIB: (3) id=m1 2005-10-26 17:09:16 Path(.\record1) included.
LIB: (3) id=m1 2005-10-26 17:09:16 Path(.\record2) included.
LIB: (3) id=m1 2005-10-26 17:09:16 Path(.\record3) included.
LIB: (2) id=m1 2005-10-26 17:09:16 (record1) missing from destination.
LIB: (2) id=m1 2005-10-26 17:09:16 (record2) missing from destination.
LIB: (2) id=m1 2005-10-26 17:09:16 (record3) missing from destination.
LIB: (2) id=m1 2005-10-26 17:09:16 COMPARING done
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 Thread-18 After COMPARE res=0
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 Thread-18 write Longline TASKDONE in COMPARE sub stage
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 Thread-18 PRECOMMIT
LIB: id=m1 2005-10-26 17:09:16 FailedCommit 0.
LIB: (3) id=m1 2005-10-26 17:09:16 DEPLOYING to destination path [c:\od-home\opendeployng\tmp\ke_content]
LIB: (3) id=m1 2005-10-26 17:09:16 directive[get .\record1]
LIB: id=m1 2005-10-26 17:09:16 Receiving item(.\record1)
LIB: (3) id=m1 2005-10-26 17:09:16 dir for tempfile [c:\od-home\opendeployng\tmp\ke_content]
LIB: (3) id=m1 2005-10-26 17:09:16 -- Processing file(c:\od-home\opendeployng\tmp\ke_content\record1)
LIB: (3) id=m1 2005-10-26 17:09:16 file created[c:\od-home\opendeployng\tmp\ke_content\record1.iwtmp]
LIB: (3) id=m1 2005-10-26 17:09:16 Renamed [c:\od-home\opendeployng\tmp\ke_content\record1.iwtmp] to [C:\od-home\opendeployng\tmp\ke_content\record1.iwnew]
LIB: (3) id=m1 2005-10-26 17:09:16 directive[reason missing-in-dest]
LIB: (3) id=m1 2005-10-26 17:09:16 directive[get .\record2]
LIB: id=m1 2005-10-26 17:09:16 Receiving item(.\record2)
LIB: (3) id=m1 2005-10-26 17:09:16 dir for tempfile [c:\od-home\opendeployng\tmp\ke_content]
LIB: (3) id=m1 2005-10-26 17:09:16 -- Processing file(c:\od-home\opendeployng\tmp\ke_content\record2)
LIB: (3) id=m1 2005-10-26 17:09:16 file created[c:\od-home\opendeployng\tmp\ke_content\record2.iwtmp]
LIB: (3) id=m1 2005-10-26 17:09:16 Renamed [c:\od-home\opendeployng\tmp\ke_content\record2.iwtmp] to [C:\od-home\opendeployng\tmp\ke_content\record2.iwnew]
LIB: (3) id=m1 2005-10-26 17:09:16 directive[reason missing-in-dest]
LIB: (3) id=m1 2005-10-26 17:09:16 directive[get .\record3]
LIB: id=m1 2005-10-26 17:09:16 Receiving item(.\record3)
LIB: (3) id=m1 2005-10-26 17:09:16 dir for tempfile [c:\od-home\opendeployng\tmp\ke_content]
LIB: (3) id=m1 2005-10-26 17:09:16 -- Processing file(c:\od-home\opendeployng\tmp\ke_content\record3)
LIB: (3) id=m1 2005-10-26 17:09:16 file created[c:\od-home\opendeployng\tmp\ke_content\record3.iwtmp]
LIB: (3) id=m1 2005-10-26 17:09:16 Renamed [c:\od-home\opendeployng\tmp\ke_content\record3.iwtmp] to [C:\od-home\opendeployng\tmp\ke_content\record3.iwnew]
LIB: (3) id=m1 2005-10-26 17:09:16 directive[reason missing-in-dest]
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 Thread-18 After PRECOMMIT res=0
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 Thread-18 exiting dotask
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 Thread-18 entering awaiting-commit
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 Thread-18 still waiting for 0
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 Thread-18 exiting awaiting-commit
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 Thread-18 entering commit
LIB: id=m1 2005-10-26 17:09:16 FailedCommit 0.
LIB: id=m1 2005-10-26 17:09:16 COMMITTING Transactional Deployment
LIB: (3) id=m1 2005-10-26 17:09:16 Renaming: [C:\od-home\opendeployng\tmp\ke_content\record1.iwnew] -> [C:\od-home\opendeployng\tmp\ke_content\record1]
LIB: (3) id=m1 2005-10-26 17:09:16 Renaming: [C:\od-home\opendeployng\tmp\ke_content\record2.iwnew] -> [C:\od-home\opendeployng\tmp\ke_content\record2]
LIB: (3) id=m1 2005-10-26 17:09:16 Renaming: [C:\od-home\opendeployng\tmp\ke_content\record3.iwnew] -> [C:\od-home\opendeployng\tmp\ke_content\record3]
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 Thread-18 After COMMIT res=0
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 Is OD-DD Deployment XMLDEPCFG
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 Thread-18 Do DCR Deployment
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 Thread-18 Generated DD Config file on Rx side :C:\od-home\OpenDeployNG\log\ddcfgr6615.xml
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 Thread-18 FileList(C:\od-home\OpenDeployNG\log\ddmasterlist6616.txt) created from manifest for DD consumption
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 Created master list from manifest res=true
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 Spliced master list into 1 sub filelists: ddargs2=[filelist_0=C:\od-home\OpenDeployNG\log\ddfilelist6617.txt ]
ENG: 2005-10-26 17:09:16 EDT GMT-04:00 doDatadeployTask filelist_0=C:\od-home\OpenDeployNG\log\ddfilelist6617.txt cfg=C:\od-home\OpenDeployNG\log\ddcfgr6615.xml manpath=C:\od-home\OpenDeployNG\log\rcv.ke_transactional.XMLs.caws105ctoc.to.mylocalhost.log.db.mf iwdd=master need-result=yes logfile=C:\od-home\OpenDeployNG\log\rcv.ke_transactional.XMLs.caws105ctoc.to.mylocalhost.log depuuid=c451f3b0-4664-11da-be4e-969c41c8c4f3 leglabel=mylocalhost isrcvr=yes
DAS: Deployment : master
DAS: ERROR
eployment not found
DAS: ERROR:ERROR: Unable to determine operation mode
DAS:
### IWDataDeploy FAILED ###
DAS:
### Sending result ###
ENG: 2005-10-26 17:09:17 EDT GMT-04:00 Thread-18 DataDeploy Task Failed
ENG: 2005-10-26 17:09:17 EDT GMT-04:00 External version for Sender = 6.0.2.0.0
ENG: 2005-10-26 17:09:17 EDT GMT-04:00 Publish DD receive event depUuid=[c451f3b0-4664-11da-be4e-969c41c8c4f3] legLabel=[mylocalhost]
ENG: 2005-10-26 17:09:17 EDT GMT-04:00 MultiTier is = false
ENG: 2005-10-26 17:09:17 EDT GMT-04:00 Failed Commit true
LIB: id=m1 2005-10-26 17:09:17 FailedCommit 1.
LIB: (3) id=m1 2005-10-26 17:09:17 FailedCommitFlag = 0
LIB: (3) id=m1 2005-10-26 17:09:17 FailedCommitFromEngine = 1
LIB: 2005-10-26 17:09:17 ERROR: commit-failed.
LIB: 2005-10-26 17:09:17 ERROR: Failed deploying local_directory[0] () to ()
LIB: 2005-10-26 17:09:17 ERROR: Failed 1 of 1 local_directories
ENG: 2005-10-26 17:09:17 EDT GMT-04:00 Thread-18 After COMMIT1 res=-1
ENG: 2005-10-26 17:09:17 EDT GMT-04:00 Thread-18 exiting commit
ENG: 2005-10-26 17:09:17 EDT GMT-04:00 Thread-18 entering awaiting-rollback
ENG: 2005-10-26 17:09:17 EDT GMT-04:00 Thread-18 Got task failed in COMMIT
ENG: 2005-10-26 17:09:17 EDT GMT-04:00 DB manifest directive: DO-NOT-SEND-DB-MANIFEST
ENG: 2005-10-26 17:09:17 EDT GMT-04:00 Thread-18 still waiting for 0
ENG: 2005-10-26 17:09:17 EDT GMT-04:00 Thread-18 exiting awaiting-rollback
ENG: 2005-10-26 17:09:17 EDT GMT-04:00 Thread-18 entering rollback
ENG: 2005-10-26 17:09:17 EDT GMT-04:00 Thread-18 failedCommit=true shouldWait=true
LIB: id=m1 2005-10-26 17:09:17 FailedCommit 1.
LIB: id=m1 2005-10-26 17:09:17 ROLLBACK Transactional Deployment
LIB: (3) id=m1 2005-10-26 17:09:17 Erasing: C:\od-home\opendeployng\tmp\ke_content\record1
LIB: (3) id=m1 2005-10-26 17:09:17 Removing: C:\od-home\opendeployng\tmp\ke_content\record1
LIB: (3) id=m1 2005-10-26 17:09:17 Erasing: C:\od-home\opendeployng\tmp\ke_content\record2
LIB: (3) id=m1 2005-10-26 17:09:17 Removing: C:\od-home\opendeployng\tmp\ke_content\record2
LIB: (3) id=m1 2005-10-26 17:09:17 Erasing: C:\od-home\opendeployng\tmp\ke_content\record3
LIB: (3) id=m1 2005-10-26 17:09:17 Removing: C:\od-home\opendeployng\tmp\ke_content\record3
LIB: (3) id=m1 2005-10-26 17:09:17 Erasing: C:\od-home\opendeployng\tmp\ke_content\record1.iwnew
LIB: (3) id=m1 2005-10-26 17:09:17 Erasing: C:\od-home\opendeployng\tmp\ke_content\record2.iwnew
LIB: (3) id=m1 2005-10-26 17:09:17 Erasing: C:\od-home\opendeployng\tmp\ke_content\record3.iwnew
LIB: id=m1 2005-10-26 17:09:17
*** ROLLBACK performed: Saved txlist file (C:\WINNT\Temp\iwdir29) ***
LIB: id=m1 2005-10-26 17:09:17
Directories deployed : 0 Files deployed : 3 Links deployed : 0
Directories failed : 0 Files failed : 0 Links failed : 0
Directories deleted : 0 Files deleted : 0 Links deleted : 0
ENG: 2005-10-26 17:09:17 EDT GMT-04:00 Thread-18 After ROLLBACK res=0
ENG: 2005-10-26 17:09:17 EDT GMT-04:00 Thread-18 exiting rollback
ENG: 2005-10-26 17:09:17 EDT GMT-04:00 Thread-18 entering awaiting-cleanup
ENG: 2005-10-26 17:09:17 EDT GMT-04:00 Thread-18 still waiting for 0
ENG: 2005-10-26 17:09:17 EDT GMT-04:00 Thread-18 exiting awaiting-cleanup
ENG: 2005-10-26 17:09:17 EDT GMT-04:00 Thread-18 entering cleanup
LIB: id=m1 2005-10-26 17:09:17 FailedCommit 0.
LIB: id=m1 2005-10-26 17:09:17 File Content transferred: 841 bytes
LIB: id=m1 2005-10-26 17:09:17 [Wed Oct 26 17:09:17 2005] Deployment COMPLETED
ENG: 2005-10-26 17:09:17 EDT GMT-04:00 Thread-18 After CLEANUP res=1
ENG: 2005-10-26 17:09:17 EDT GMT-04:00 Thread-18 exiting cleanup
ENG: 2005-10-26 17:09:17 EDT GMT-04:00 Thread-18 entering task-failed
ENG: 2005-10-26 17:09:17 EDT GMT-04:00 Thread-18 still waiting for 0
ENG: 2005-10-26 17:09:17 EDT GMT-04:00 External version for Sender = 6.0.2.0.0
ENG: 2005-10-26 17:09:17 EDT GMT-04:00 Published receive event depUuid=[c451f3b0-4664-11da-be4e-969c41c8c4f3] legLabel=[mylocalhost]
ENG: 2005-10-26 17:09:17 EDT GMT-04:00 Thread-18 Job ID=m1 Deployment leg=ke_transactional.XMLs.mylocalhost Elapsed Time=969 ms <<<
ENG: 2005-10-26 17:09:17 EDT GMT-04:00 Thread-18 End logfile [C:\od-home\OpenDeployNG\log\rcv.ke_transactional.XMLs.caws105ctoc.to.mylocalhost.log]
Migrateduser
The "DAS" message is OK... it's printed even for standalone deployments. We fixed this in the service pack, OD 602 Service Pack 1.
Mariam