Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
Error 01020: Web Service not Configured
mike_jaixen
My sysadmin just installed OD 6.0.2 on a new Solaris 9 server, and I'm attempting to access the admin GUI, but not getting a response.
Reviewing odbase.log, it appears that OpenDeploy is installed, but one item towards the end of the log caught my attention:
SVR 01020: 2005-08-10 12:54:58 CDT GMT-05:00 *** Web service is not configured. It is not enabled. ***
Find more posts tagged with
Comments
Migrateduser
That is just a status msg indicating that web services is not enabled... that wouldn't cause the admin ui to not come up. Can you get the admin ui logs instead? odadminhome/odadmin/logs .... there are ui logs in that location.
Mariam
mike_jaixen
This is servletd.log:
Aug 10, 2005 9:02:27 AM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8081
Aug 10, 2005 9:02:27 AM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 12186 ms
Aug 10, 2005 9:02:27 AM org.apache.catalina.core.StandardService start
INFO: Starting service servletd
Aug 10, 2005 9:02:27 AM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/5.0.27
Aug 10, 2005 9:02:28 AM org.apache.catalina.core.StandardHost start
INFO: XML validation disabled
LOADING POLICIES...DONE
LOADED POLCIES [
policy allow: return true;
policy deny: return false;
policy master_only: if (rolename.equals("master") { return true; } return false;
]
WARNING: framework.properties does not specify the key "command.root.name". Assuming default value "fwroot".
LOADING COMMANDS...............................................................................................................................................DONE
LOADED ROOT COMMAND "fwroot".
LOADED COMMAND TREE [
com.interwoven.framework.command.DefaultCommand: fwroot
com.interwoven.framework.command.DefaultCommand: ChooseDBServlet
com.interwoven.framework.command.DefaultCommand: ChooseMap
com.interwoven.framework.command.DefaultCommand: ConnectDBServlet
com.interwoven.framework.command.DefaultCommand: CreateDDConfig
com.interwoven.framework.command.DefaultCommand: CreateMappedTreeServlet
com.interwoven.framework.command.DefaultCommand: CreateTreeServlet
com.interwoven.framework.command.DefaultCommand: DASServlet
com.interwoven.framework.command.DefaultCommand: ProcessGroupServlet
com.interwoven.framework.command.DefaultCommand: ProcessServerInfoServlet
com.interwoven.framework.command.DefaultCommand: RemoveGroupServlet
com.interwoven.framework.command.DefaultCommand: SaveFileToLocalFileSystemServlet
com.interwoven.framework.command.DefaultCommand: StartStopESServlet
com.interwoven.framework.command.DefaultCommand: ViewSchemaServlet
com.interwoven.framework.command.DefaultCommand: EditConfigFileServlet
com.interwoven.framework.command.DefaultCommand: FileSystemBrowser
com.interwoven.framework.command.DefaultCommand: ForwardingServlet
com.interwoven.framework.command.DefaultCommand: FrameworkForwardingServlet
com.interwoven.framework.command.DefaultCommand: fwutil
com.interwoven.framework.command.DefaultCommand: docommand
com.interwoven.framework.command.DefaultCommand: finger
com.interwoven.framework.command.DefaultCommand: hup
com.interwoven.framework.command.DefaultCommand: who
com.interwoven.framework.command.DefaultCommand: whoami
com.interwoven.framework.command.DefaultCommand: help
com.interwoven.framework.command.DefaultCommand: LogViewer
com.interwoven.framework.command.DefaultCommand: main
com.interwoven.framework.command.DefaultCommand: navigation
com.interwoven.framework.command.DefaultCommand: opendeploy
com.interwoven.framework.command.DefaultCommand: deployments
com.interwoven.framework.command.DefaultCommand: StartDeployment
com.interwoven.framework.command.DefaultCommand: ViewDeployments
com.interwoven.framework.command.DefaultCommand: schedules
com.interwoven.framework.command.DefaultCommand: EditSchedule
com.interwoven.framework.command.DefaultCommand: ViewSchedules
com.interwoven.framework.command.DefaultCommand: configurations
com.interwoven.framework.command.DefaultCommand: ViewConfigurations
com.interwoven.framework.command.DefaultCommand: UploadConfigurations
com.interwoven.framework.command.DefaultCommand: ddconfigFile
com.interwoven.framework.command.DefaultCommand: dbschemaMapping
com.interwoven.framework.command.DefaultCommand: servers
com.interwoven.framework.command.DefaultCommand: ViewServers
com.interwoven.framework.command.DefaultCommand: ManageServer
com.interwoven.framework.command.DefaultCommand: UploadServerGroupConfig
com.interwoven.framework.command.DefaultCommand: DoRefreshServerGroup
com.interwoven.framework.command.DefaultCommand: ServerGroupStatus
com.interwoven.framework.command.DefaultCommand: ViewServerGroup
com.interwoven.framework.command.DefaultCommand: ManageServerGroup
com.interwoven.framework.command.DefaultCommand: ManageServerGroupPage
com.interwoven.framework.command.DefaultCommand: EditServerGroup
com.interwoven.framework.command.DefaultCommand: reports
com.interwoven.framework.command.DefaultCommand: ReportFrame
com.interwoven.framework.command.DefaultCommand: CustomReport
com.interwoven.framework.command.DefaultCommand: DASReport
com.interwoven.framework.command.DefaultCommand: CHReport
com.interwoven.framework.command.DefaultCommand: DASSQLReport
com.interwoven.framework.command.DefaultCommand: DownloadReport
com.interwoven.framework.command.DefaultCommand: SQLReport
com.interwoven.framework.command.DefaultCommand: EditQuickReports
com.interwoven.framework.command.DefaultCommand: ReportMaintenance
com.interwoven.framework.command.DefaultCommand: users
com.interwoven.framework.command.DefaultCommand: ServerAuth
com.interwoven.framework.command.DefaultCommand: DeploymentAuth
com.interwoven.framework.command.DefaultCommand: dasOps
com.interwoven.framework.command.DefaultCommand: das
com.interwoven.framework.command.DefaultCommand: es
com.interwoven.framework.command.DefaultCommand: startES
com.interwoven.framework.command.DefaultCommand: syndication
com.interwoven.framework.command.DefaultCommand: ViewOffers
com.interwoven.framework.command.DefaultCommand: ViewSubscriptions
com.interwoven.framework.command.DefaultCommand: ViewNextDeployment
com.interwoven.framework.command.DefaultCommand: StartDeploymentDD
]
=========================================================================
LOADED APPLICATION com.interwoven.framework.base.Application@1fbfd6
LOADED AUTHENTICATOR BUILDER com.interwoven.opendeploy.ui.ODAccessSvcAuthenBuilder@1a897a9
Using authenticator class name: com.interwoven.opendeploy.ui.ODAccessSvcAuthen
localHostName: omhq1722
Get Access Service hostname from framework.properties file
Using Access Service hostname: omhq1722
Get Access Service port number from framework.properties file
Using Access Service port number: 12973
Get Access Service transport type from framework.properties file
Using Access Service transport type: http
Get Access Service authen server from framework.properties file
Using Access Service authen server: localservice
Get Access Service login life time from framework.properties file
Using Access Service login life time(milliseconds): 86400000
Get Access Service user locale from framework.properties file
Using Access Service user locale: en_US
Create Authenicator com.interwoven.opendeploy.ui.ODAccessSvcAuthen
Locate the Access Service with parms: com.interwoven.opendeploy.ui.ODAccessSvcSession [ host=omhq1722; port=12973; transport=http;]
In ASClientSetup.locateAccessService()
Got property adminHome: /software/interwoven/OpenDeploy/AdminServer
URL string
http://omhq1722:12973/iw/services/csf/1.1/accessservice
Call locator for CSF Access service
Back from locate Access Service call
Call Access Service to get its version
**ERROR** RemoteException
**Message: ; nested exception is:
java.net.ConnectException: Connection refused
Unable to load Access Service session for host=omhq1722; port=12973; transport=http;
Reason: Failed to locate Access Service, ; nested exception is:
java.net.ConnectException: Connection refused
LOADED AUTHENTICATOR com.interwoven.opendeploy.ui.ODAccessSvcAuthen[ com.interwoven.opendeploy.ui.ODAccessSvcSession [ host=omhq1722; port=12973; transport=http;]]
LOADED LOGIN JSP: /framework/login.jsp
LOADED FINGER
Aug 10, 2005 9:03:55 AM org.apache.catalina.core.StandardHost getDeployer
INFO: Create Host deployer for direct deployment ( non-jmx )
Aug 10, 2005 9:03:55 AM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8081
Aug 10, 2005 9:03:57 AM org.apache.jk.common.ChannelSocket init
INFO: JK2: ajp13 listening on /0.0.0.0:8088
Aug 10, 2005 9:03:57 AM org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=14/342 config=/software/interwoven/OpenDeploy/AdminServer/servletd/conf/jk2.properties
Aug 10, 2005 9:03:58 AM org.apache.catalina.startup.Catalina start
INFO: Server startup in 90575 ms
As I look through the logs and the results of the install, I can't seem to find the ContentServices Foundation anywhere; I believe that's what odadmin is looking for on port 12973 when the ERROR occurred.
nipper
**ERROR** RemoteException
**Message: ; nested exception is:
java.net.ConnectException: Connection refused
Unable to load Access Service session for host=omhq1722; port=12973; transport=http;
Reason: Failed to locate Access Service, ; nested exception is:
java.net.ConnectException: Connection refused
Are you going through a firewall ?
Are the appropriate ports open ?
is the server running ?
try this (prefereably from the teamsite server)
telnet omhq1722 12973
telnet should connect, but you won't see anything.
mike_jaixen
I think part of the problem was that my sysadmin was still working on applying some service packs to TeamSite, and not everything was up and running.
I now get the login page, but login attempts fail:
Failed to locate Access Service, ; nested exception is: java.net.ConnectException: Connection refused
I tried the telnet omhq1722 12973 and a telnet localhost 12973 for good measure, and both failed.
Migrateduser
Can you look at the processes running and see if there is one for the AccessService.
Also there are logs for this under <CSF-HOME>/AccessService/log
This process should get started automatically. But it can be started by doing /etc/init.d/iwaccess start ... see if that starts it.
Mariam
mike_jaixen
I think the problem is that CSF didn't get installed as part of the OpenDeploy install... or if it did, the install hid it somewhere that I haven't been able to find it. The install log says that it was installed, but it never asked where and I haven't found any evidence of it:
From the install log under /OD-HOME/AdminServer/odadmin/install
Start CSF installation.
Finish CSF installation.
The Access Server must be running before starting OpenDeploy 6.0.2 Admin/Reporting Server.
To start Access Server, issue:
/etc/init.d/iwaccess start
So then I looked under /etc/init.d to find iwaccess, and no dice:
$ ls -la /etc/init.d | grep iw
-rwxrwxr-x 4 root daemon 6596 Sep 29 2004 iw.local
-rwxrwxr-x 1 root daemon 6596 Sep 29 2004 iw.local.bak
-rwxr-xr-x 2 root other 1215 Jun 7 13:25 iw.reboot
-rwxr-xr-x 1 root other 1215 Jun 7 13:25 iw.reboot.bak
-rwxrwxr-x 1 root daemon 1517 Sep 29 2004 iw.samba
-rwxrwxr-x 1 root daemon 1517 Sep 29 2004 iw.samba.bak
-rwxrwxr-x 4 root daemon 4232 Sep 29 2004 iw.server
-rwxrwxr-x 1 root daemon 4232 Sep 29 2004 iw.server.bak
-rwxrwxr-x 2 root daemon 13493 Sep 29 2004 iw.wfs
-rwxrwxr-x 1 root daemon 13493 Sep 29 2004 iw.wfs.bak
-rwxrwxr-x 1 root daemon 2209 Sep 29 2004 iw.wfsuninstall.bak
-rwxrwxr-x 3 root daemon 12830 Apr 3 03:02 iwod60
-rwxr-xr-x 3 root other 13152 Aug 9 14:27 iwodadmin
-rwxrwxr-x 1 root daemon 9368 Apr 3 03:02 iwodsnmp60
$
Migrateduser
If you look under /etc, do you see an entry for defaultiwaccesshome? That should tell where it is, if it is indeed on your system somewhere.
Mariam
mike_jaixen
Nope. Nothing under /etc, so I think it's safe to assume that it didn't get installed.
Does anybody know if there is a separate install for CSF around somewhere? I haven't seen one on the download site.
Migrateduser
No, in 602 CSF is supposed to install with the OD admin server.
Todd Scallan
Sr. Dir. Product Mgt.
Interwoven
t: 408-530-7167
e:
tscallan@interwoven.com
Migrateduser
Can you post the log from the admin installation? It's under odadminhome/odadmin/install. It's called install_admin.log. The log should tell you what happened to CSF. That would be useful to know.
CSF is bundled with the admin package. You can reinstall the admin package and not harm your current installation, except for any changes you made post-install. So backup if necc.
Mariam
mike_jaixen
Here are the last lines of the install_admin.log; it just says "start and finish" for CSF...
/software/interwoven/OpenDeploy/AdminServer/odadmin/config/examples/odservers.cfg
System files
Creating /etc/defaulttomcathome
Installing /etc/init.d/iwodadmin
Setting /etc/rc3.d/S89iwodadmin
Setting /etc/rc2.d/K89iwodadmin
Create the tables for the event reporting demo database
Doing ODEvents_hSql.sql
Result: Loaded driver: 'org.hsqldb.jdbcDriver'.
Connection with HSQL Database Engine at jdbc:hsqldb:/software/interwoven/OpenDeploy/AdminServer/odadmin/db/eventReporting.db established.
Executing SQL script file: /software/interwoven/OpenDeploy/AdminServer/odadmin/db/ODEvents_hSql.sql
0 Row(s) affected.
0 Row(s) affected.
0 Row(s) affected.
0 Row(s) affected.
0 Row(s) affected.
0 Row(s) affected.
0 Row(s) affected.
0 Row(s) affected.
0 Row(s) affected.
0 Row(s) affected.
0 Row(s) affected.
0 Row(s) affected.
...done.
Doing quickreportlist_hSql.sql
Result: Loaded driver: 'org.hsqldb.jdbcDriver'.
Connection with HSQL Database Engine at jdbc:hsqldb:/software/interwoven/OpenDeploy/AdminServer/odadmin/db/eventReporting.db established.
Executing SQL script file: /software/interwoven/OpenDeploy/AdminServer/odadmin/db/quickreportlist_hSql.sql
0 Row(s) affected.
1 Row(s) affected.
1 Row(s) affected.
1 Row(s) affected.
0 Row(s) affected.
...done.
Cleanup
#### COMPLETED fresh install of OpenDeploy 6.0.2 Admin/Reporting Server ####
To start OpenDeploy 6.0.2 Admin/Reporting Server, issue:
/etc/init.d/iwodadmin start
Installation logged to /software/interwoven/OpenDeploy/AdminServer/odadmin/install/install_admin.log
End Time: Tue Aug 9 14:28:14 CDT 2005
Start CSF installation.
Finish CSF installation.
The Access Server must be running before starting OpenDeploy 6.0.2 Admin/Reporting Server.
To start Access Server, issue:
/etc/init.d/iwaccess start
Migrateduser
Looks like CSF got installed... but sounds like you don't see it... see if there is a CSF directory. There are some logs under CSF/AccessService. If you see the CSF directory, try starting the service using the iwaccess under the CSF/AccessServic/bin directory.
There is no harm in trying to reinstall the admin (be sure to back it up anyway)... but I'd be surprised if CSF is not there.
Mariam
mike_jaixen
I've looked and looked and looked for a CSF installation, and it ain't there. iwaccess doesn't exist either... So a reinstall appears to be my next target.
sample.zip
mike_jaixen
The reinstall of OD admin (with CSF) was successful; still don't know why CSF didn't install the first time, but that will remain a mystery.
Thanks to all...
Edited by mike_jaixen on 08/19/05 06:43 AM (server time).