Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
Data Deploy rollback not happening
Bill Klish
TeamSite 6.5 SP1
Solaris 2.9
OpenDeploy 6.0.2
Errors are happening during a standalone DataDeploy, and the log says it is rolling back, but the rows that were inserted/updated prior to the failure are committed. Why would this be happening?
Log snippet:
DD : ERROR:Value(s) for PK column [sequence] missing in [templatedata/EnhancedProperty/GuestRooms/data/LONCHCI].
DD : ERROR:Exception occured: Value(s) for PK column [sequence] missing in [templatedata/EnhancedProperty/GuestRooms/data/LONCHCI].
com.interwoven.dd100.dd.InvalidSourceTupleException: Value(s) for PK column [sequence] missing in [templatedata/EnhancedProperty/GuestRooms/da
ta/LONCHCI].
at com.interwoven.dd100.dd.TDeleteTracker.SetPKColNameValues(TDeleteTracker.java:428)
at com.interwoven.dd100.dd.TDeleteTracker.SetPKColNameValues(TDeleteTracker.java:328)
at com.interwoven.dd100.dd.TDbSchemaAgent.UpdateDeleteTracker(TDbSchemaAgent.java:558)
at com.interwoven.dd100.dd.TDbSchemaAgent.BasicWriteTuple(TDbSchemaAgent.java:483)
at com.interwoven.dd100.dd.TDbSchemaAgent.WriteTuple(TDbSchemaAgent.java:334)
at com.interwoven.dd100.dd.TConsumerManager.WriteConsumerInternal(TConsumerManager.java:398)
at com.interwoven.dd100.dd.TConsumerManager.WriteConsumers(TConsumerManager.java:387)
at com.interwoven.dd100.dd.TAgentClient.DoOneTeamSiteSource(TAgentClient.java:974)
at com.interwoven.dd100.dd.TAgentClient.ProcessOneFileList(TAgentClient.java:581)
at com.interwoven.dd100.dd.TAgentClient.ProcessFileList(TAgentClient.java:538)
at com.interwoven.dd100.dd.TAgentClient.DoTeamSiteSources(TAgentClient.java:483)
at com.interwoven.dd100.dd.TAgentClient.DoOneDeployment(TAgentClient.java:261)
at com.interwoven.dd100.dd.TAgentClient.Go(TAgentClient.java:194)
at com.interwoven.dd100.dd.IWDataDeploy.Go(IWDataDeploy.java:545)
at com.interwoven.dd100.dd.IWDataDeploy.run(IWDataDeploy.java:576)
DD : ERROR:WriteTuple failure to consumer[0]
DD : ERROR:Unable to process TeamSite source templatedata/EnhancedProperty/GuestRooms/data/LONCHCI, obtained from filelist=/opt/iw-home/OpenDe
ployNG/hilton/temp/108670_dd_files.txt
DD : Filelist walk done
DD : ERROR:deployment [EnhancedProperty-GuestRooms] FAILED
DD : Error occured in area outside TDbAgent consumer (explicit rollback initiated)
DD : Stat for group [ts_metadata]:
DD : -----------------------------------
DD : Rows inserted : 1
DD : Rows updated : 0
DD : Rows deleted : 0
DD : Rows failed : 0
DD : Rows rolled back : 0
DD : Rows skipped : 0
DD : -----------------------------------
DD : Stat for group [ts_guest_rooms]:
DD : -----------------------------------
DD : Rows inserted : 1
DD : Rows updated : 0
DD : Rows deleted : 0
DD : Rows failed : 0
DD : Rows rolled back : 0
DD : Rows skipped : 0
DD : -----------------------------------
DD : Stat for group [ts_guest_rooms_details]:
DD : -----------------------------------
DD : Rows inserted : 1
DD : Rows updated : 0
DD : Rows deleted : 0
DD : Rows failed : 0
DD : Rows rolled back : 0
DD : Rows skipped : 0
DD : -----------------------------------
DD : Stat for group [ts_guest_rooms_fp_images]:
DD : -----------------------------------
DD : Rows inserted : 0
DD : Rows updated : 0
DD : Rows deleted : 0
DD : Rows failed : 0
DD : Rows rolled back : 0
DD : Rows skipped : 0
DD : -----------------------------------
DD : Stat for group [ts_guest_rooms_pt_images]:
DD : -----------------------------------
DD : Rows inserted : 2
DD : Rows updated : 0
DD : Rows deleted : 0
DD : Rows failed : 0
DD : Rows rolled back : 0
DD : Rows skipped : 0
DD : -----------------------------------
DD : Rollback database [XXXXXXX.****.****:3306/webdb]...
DD : Deployment[EnhancedProperty-GuestRooms]
DD : -----------------------------------
DD : DCRs inserted : 0
DD : DCRs updated : 0
DD : DCRs deleted : 0
DD : DCRs failed : 0
DD : DCRs rolled back : 0
DD : DCRs skipped : 0
DD : -----------------------------------
DD : Started : Fri Nov 25 12:55:06 CST 2005
DD : Finished: Fri Nov 25 12:55:15 CST 2005
Find more posts tagged with
Comments
Migrateduser
Have you set commit-batch-size?
Mariam
Bill Klish
nope.
After reading about this in the manual, I want the whole deployment to be rolled back, as we are talking about just a few records (< 10) per deployment.
from the OD 6.0.2 Reference manual:
commit-batch-size — specifies the number of records that need be successfully
deployed before DataDeploy commits the deployment. If an error occurs while
processing a batch, only that batch is rolled back. Otherwise, when a failure occurs, by
default, DataDeploy rolls back the entire deployment.
I want this to roll back everything, which I assume by not setting this, it *should* roll everything back.
Edited by bk99nd on 11/25/05 12:30 PM (server time).
Bill Klish
This issue was caused by a MySQL mis-configuration. Our tables were created using the default table space, which doesn't support transaction based loading of data. We switched the tables to use the InnoDB engine and everything works correctly. Make sure your databases are setup using the right MySql engine.
Here is a list of information for each engine type:
mysql> show engines;
+------------+----------+------------------------------------------------------------+
| Engine | Support | Comment |
+------------+----------+------------------------------------------------------------+
| MyISAM | DEFAULT | Default engine as of MySQL 3.23 with great performance |
| HEAP | YES | Alias for MEMORY |
| MEMORY | YES | Hash based, stored in memory, useful for temporary tables |
| MERGE | YES | Collection of identical MyISAM tables |
| MRG_MYISAM | YES | Alias for MERGE |
| ISAM | NO | Obsolete storage engine, now replaced by MyISAM |
| MRG_ISAM | NO | Obsolete storage engine, now replaced by MERGE |
| InnoDB | YES | Supports transactions, row-level locking, and foreign keys |
| INNOBASE | YES | Alias for INNODB |
| BDB | YES | Supports transactions and page-level locking |
| BERKELEYDB | YES | Alias for BDB |
| NDBCLUSTER | DISABLED | Clustered, fault-tolerant, memory-based tables |
| NDB | DISABLED | Alias for NDBCLUSTER |
| EXAMPLE | NO | Example storage engine |
| ARCHIVE | YES | Archive storage engine |
| CSV | NO | CSV storage engine |
+------------+----------+------------------------------------------------------------+