Hi, I am getting the following error when deploying editions. It seems looking at the error, one of the paramerters to the external task is null or it is unable to read the OD config file I have verified that both the cases are not correct. All the paramters are passed to the task and the same OD config file is used for promoting to QA environment. Please respond if any one has any idea on why this error occurs. Attached odbase.log, task snippets from WF and OD config file.
Error from ODBase.log
API: 2005-08-12 08:08:03 EDT GMT-04:00 Requested start of deployment Portal_edition_deploy
API: 2005-08-12 08:08:03 EDT GMT-04:00 Calling server to start deployment Portal_edition_deploy
ENG: 2005-08-12 08:08:03 EDT GMT-04:00 Received request to start deployment Portal_edition_deploy.
ENG: 2005-08-12 08:08:03 EDT GMT-04:00 Starting job m50 for deployment Portal_edition_deploy with parameters: {WEEKINV=0, STARTTIME=Fri Aug 12 08:08:03 EDT 2005, DAYINV=0, MONTHDAYS=null, HOURINV=0, DEPLOYNAME=Portal_edition_deploy, JOBID=m50, REPAIR=false, STARTDEPLOY=true, DESCRIPTION=, VERIFY=false, NO_RECUR=NO_RECUR, DEPLOYSUFFIX=, ENDTIME=null, OWNER=mibapm, WEEKDAY=null, RECURSET=NO_RECUR, PAD6=null, PAD5=null, SYNCH=true, PAD4=null, KEYVALUES=wfid=47104
taskid=47111
area=/InterWoven/iwmnt/default/main/Portal/WORKAREA/workarea_Portal
filelist=
ABC_EDITION=/default/main/Portal/EDITION/Test
ABC_ENV=ABC-PROD
ABC_BRANDSITE=/clocal/www/web-data/vserver/
www.abc.com, REPEAT=false, PAD3=null, PAD2=null, PAD1=null, YEARINV=0, LOGLEVEL=UNSPECIFIED, MINUTEINV=0}
ENG: 2005-08-12 08:08:03 EDT GMT-04:00 MultiTier Latch is null
ENG: 2005-08-12 08:08:03 EDT GMT-04:00 ***ERROR - Failed starting deployment: Portal_edition_deploy
Error:
java.lang.NullPointerException
at com.interwoven.deploy.config100.TDeploymentConfiguration.resolveDeploymentInformation(TDeploymentConfiguration.java:1930)
at com.interwoven.deploy.config100.TDeploymentConfiguration.postProcess(TDeploymentConfiguration.java:2581)
at com.interwoven.deploy.config100.TDeploymentConfiguration.<init>(TDeploymentConfiguration.java:540)
at com.interwoven.deploy.engine.TMacroDeploy.<init>(TMacroDeploy.java:378)
at com.interwoven.deploy.engine.TMacroDeployInitiator.startMacroDeploySession(TMacroDeployInitiator.java:2700)
at com.interwoven.deploy.engine.TMacroDeployInitiator.startDeployment(TMacroDeployInitiator.java:1009)
at com.interwoven.deploy.engine.TMacroDeployInitiator.startDeployment(TMacroDeployInitiator.java:780)
at com.interwoven.deployapi.deploy.IWDeployAction.startDeploy(IWDeployAction.java:518)
at com.interwoven.deployapi.deploy.IWDeployRemoterImpl.startDeploy(IWDeployRemoterImpl.java:159)
at java.lang.reflect.Method.invoke(Native Method)
at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:236)
at sun.rmi.transport.Transport$1.run(Transport.java:147)
at java.security.AccessController.doPrivileged(Native Method)
at sun.rmi.transport.Transport.serviceCall(Transport.java:143)
at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:460)
at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:701)
at java.lang.Thread.run(Thread.java:479)
API: 2005-08-12 08:08:03 EDT GMT-04:00 Error encountered while starting deployment Portal_edition_deploy
Error: DEPLOY_CONFIG_FILE., Got Exception: null
UAT Task from WF :
<externaltask name="UAT Deploy"
owner="__TAG__('iw_user');"
start='f'
description="Deploying to UAT" >
<areavpath v="__TAG__('iw_workarea');"/>
<successors>
<successorset description="UAT Confirmation E-mail">
<succ v="UAT Confirmation E-mail"/>
</successorset>
<successorset description="Sending notification e-mail to owner about failed UAT content deployment">
<succ v="Notification E-mail To Owner About Failed UAT Content Deployment"/>
</successorset>
</successors>
<command v="__INSERT__("$iwhome");/iw-perl/bin/iwperl __INSERT__("$iwhome");/httpd/iw-bin/wft_opendeploy.ipl"/>
<wfvarfinishop op="set" name="cbval" value="0"/>
<variables>
<variable key="od_cfg" value="Portal_edition_deploy"/>
<variable key="deploy_type" value="edition"/>
<variable key="dest_env" value="UAT" />
<variable key="dest_website" value="__INSERT__($dest_brand_site);"/>
<variable key="branch" value="__INSERT__($working_branch);"/>
<variable key="edition" value="__INSERT__($sourcedir);"/>
</variables>
</externaltask>
PROD Task from WF :
<externaltask name="PROD Deploy"
owner="__TAG__('iw_user');"
start='f'
description="Deploying to PROD" >
<areavpath v="__TAG__('iw_workarea');"/>
<successors>
<successorset description="PROD Confirmation E-mail">
<succ v="PROD Confirmation E-mail"/>
</successorset>
<successorset description="Sending notification e-mail to owner about failed PROD content deployment">
<succ v="Notification E-mail To Owner About Failed PROD Content Deployment"/>
</successorset>
</successors>
<command v="__INSERT__("$iwhome");/iw-perl/bin/iwperl __INSERT__("$iwhome");/httpd/iw-bin/wft_opendeploy.ipl"/>
<wfvarfinishop op="set" name="cbval" value="0"/>
<variables>
<variable key="od_cfg" value="Portal_edition_deploy"/>
<variable key="deploy_type" value="edition"/>
<variable key="dest_env" value="PROD" />
<variable key="dest_website" value="__INSERT__($dest_brand_site);"/>
<variable key="branch" value="__INSERT__($working_branch);"/>
<variable key="edition" value="__INSERT__($sourcedir);"/>
</variables>
</externaltask>