Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
Installing WorkRoute MP
patel
Hi.
I have installed the WorkRoute MP 4.1. SP1 as per the INSTALLATION & CONFIGURATION GUIDE .pdf manual.
Accordingly as needed have integrated with TOMCAT , created the "teamflowdb" Db on MS SQL Server modifying & executing server scripts files namely :
mkmssqldb.bat , initdb.sql , upgrade.properties.
Set the preferences facility and Home workspace for Enterprise Administrative User.
When the WorkRoute MP is added to Configuration Manager Cluster as a service, it will NOT start even after CURRENT EXISTING (only) library is being authenticated. WHY ? Am i missing some pre-requirements here ?
Could anybody provide solution in resolving this issue based on there experience which might NOT be availabe in the installation manual ?
Thanks for your help, folks.
patel
Find more posts tagged with
Comments
Nicholas
Did you checked logs? WSMP Version, SP?
Thanks Nicholas
PGV.rptdesign
JTNeville
The manual is correct if sometimes generic in it's description in the steps necessary to setup workroute. I've setup up Workroute since 3.0 using the manual and it works. Recently reloaded it in 4.1sp1 clean on my dev server so I can vouch that the steps are complete.
The logs will tell you why it isn't starting, offhand I'd guess the password on the administration account is wrong.
patel
Hello.
My issue is NOW i am NOT able to DELETE the Facility that was created to work with WorkRoute i.e. Enterprise Workflow b'se it gives error message CANNOT delete with Child workSpaces. And then i CANNOT even delete this workspaces...
Things are becoming messy & complicated....
Want to remove this facility , delete the database created for this & then REINSTALL everything again.
First how to take care of Library Manager - Facility Deletion here ?
Please reply in detail.
Thank you.
Patel.
chart.jpg
JTNeville
The only way to cleanly delete (I personally hate this, I would like with appropriate safeguards to be able to delete ANYTHING from the abckend admin tools) is to login as workspace owners, delete all content step by step and then delete the workspace. Then go back to your admin tool and delete your facility. Sorry that's just how it works. HTH
JT
patel
JT,
I was NOT able to access any workspaces on Web b'se ALL the users/trustee were behaving like Administrator !!!!! Yes.
Changed the ADMINISTER THE WORKSPACE property to FALSE on PRIVILEGES node ( with the help of Support Rep. Tip ) and then got all the UNNECESSARY Facility & its Workspace Deleted all together. No idea how this property got set to TRUE b'se its default value is FALSE.
Got the WorkRoute INSTALLED successfully later with all requirements. Now still problem continues .......
As Needed WorkRoute is added as a service to a Server in Configuration Manager SAVED settings and STARTED.
Strange thing is i CANNOT get the Green Triangle indicating Workroute Service has Started/Running, eventhough START icon on toolbar & short cut options is DEACTIVATED/Not AVailable ??
Even shut down & restarted the whole system couple of times, but same problem.
Naturally when tried/tested the templatedesigner.jsp on web getting below ERROR Message :-
NO WORKROUTE SERVERS READY / ACCESSIBLE. WORKROUTE SERVER NOT REGISTERED or NOT YET READY. PLEASE TRY AGAIN LATER ( Empty Server List Found )
Any solution/ideas for this ?
Thanks,
Patel.
PGV.rptdesign
Nicholas
Again, what your logs saying?
patel
Nicholas,
Please check the below ..... Any more details needed do let me know to have Workroute rolling.
LOG FILE OUTPUT :-
1) CMS Service Log.
ERROR [DatabaseConnectionMonitor-1] Resource not found: crypto.properties
Thu Dec 08 13:36:27.187: INFO [DatabaseConnectionMonitor-1] Could not load crypto.properties, Blowfish will use the default key.
Thu Dec 08 13:36:27.640: INFO [execute] *** Server initializing: step 8 of 13 : Initializating return codes ***
Thu Dec 08 13:36:27.812: ERROR [DatabaseConnectionMonitor-1] Resource not found: crypto.properties
Thu Dec 08 13:36:27.812: INFO [DatabaseConnectionMonitor-1] Could not load crypto.properties, Blowfish will use the default key.
2) Configuration Manager Log.
Wed Dec 07 14:04:10.500: ERROR [main] Resource not found: crypto.properties
Wed Dec 07 14:04:10.500: INFO [main] Could not load crypto.properties, Blowfish will use the default key.
3) WorkRoute MP Log.
Thu Dec 08 14:15:28.953: ERROR [patel.patel:…..notification.1864.0] Message from RouterId
atel.patel:…..notification.1864.0 with id 228 was not received
Thu Dec 08 14:15:11.046: ERROR [RMI TCP Connection(6)-….] Message from RouterId
atel.patel:…..notification.1864.0 with id 230 could not be added
Also attached files contain screen shot of :-
Configuration Manager with WORKROUTE MP Service added / started BUT NOT Start respectively.
HereWHY is WorkRoute Services NOT Starting ?
Thanks,
Patel.
patel
Nicholas,
Please check the below ..... File Attached, do unzip and view it's .doc file with screen shots.
LOG FILE OUTPUT :-
1) CMS Service Log.
ERROR [DatabaseConnectionMonitor-1] Resource not found: crypto.properties
Thu Dec 08 13:36:27.187: INFO [DatabaseConnectionMonitor-1] Could not load crypto.properties, Blowfish will use the default key.
Thu Dec 08 13:36:27.640: INFO [execute] *** Server initializing: step 8 of 13 : Initializating return codes ***
Thu Dec 08 13:36:27.812: ERROR [DatabaseConnectionMonitor-1] Resource not found: crypto.properties
Thu Dec 08 13:36:27.812: INFO [DatabaseConnectionMonitor-1] Could not load crypto.properties, Blowfish will use the default key.
2) Configuration Manager Log.
Wed Dec 07 14:04:10.500: ERROR [main] Resource not found: crypto.properties
Wed Dec 07 14:04:10.500: INFO [main] Could not load crypto.properties, Blowfish will use the default key.
3) WorkRoute MP Log.
Thu Dec 08 14:15:28.953: ERROR [patel.patel:…..notification.1864.0] Message from RouterId
atel.patel:…..notification.1864.0 with id 228 was not received
Thu Dec 08 14:15:11.046: ERROR [RMI TCP Connection(6)-….] Message from RouterId
atel.patel:…..notification.1864.0 with id 230 could not be added
Also attached files contain screen shot of :-
Configuration Manager with WORKROUTE MP Service added / started BUT NOT Start respectively.
Here WHY is WorkRoute Services NOT Starting ?
Any more details needed do let me know to have Workroute rolling.
Thanks,
Patel.
Nicholas
Looks like proper java version not installed on your wsmp box, this could be the reason.
Which Java version you are running? 1.4.2_03 is recomended.
Thanks Nicholas
JTNeville
Wrong log. I just looked at my logs because it seemed familiar and I see that crypto error as well. I think it's there because you aren't using that service, just like the log4j error you get out of the box.
Anyway, you do have to have the correct java installed, last I saw it was 1.3.1 (1.4.2_03 is recommended for just WorksiteMP, though I have 08 installed on my test server without issue, and WMP running under T5 ok as well)) for workroute but whateve it is now (jsut check the install PDF), is included in the install in one of the subdirectories and must be used, no way around this.
Sorry but don't have time to go do a dummy install and verify for you what it is with the latest release.
IRC there's accounts you need to create and syncronize for Workroute, I'd guess that didn't happen correctly. If Interwoven has removed these additional management accounts, please feel free to ignore my comments about the passwords not being correct in both places, ie the server setup and in workroute.
HTH
patel
Java Version is JAVA 2 SDK 1.4.2_03. Thanks.
PGNair
Hi,
Patel, could you attach the WorkRoute log file please? The extract you have provided may be missing the main error.
Thanks.
PG
patel
Hi,
Have attached the workroute log file. Do let me know what the problem is.
Thanks,
Patel
patel
Attachment did NOT came through .... !
jbonifaci
I'm not familiar with WorkRoute, but here's a quick tutorial on attaching a file:
1) First Select "Post" or "Reply" to get to get to the post composition screen.
2) Enter the text you want in your post.
3) Make sure that the "I want to preview my post and/or attach a file" checkbox is checked. Then hit "Continue".
4) Hit the "Browse" button below the text that says "You may attach a file if you like (no bigger than 100000 bytes please)."
5) Browse to the file you want to attach and hit the "Open" Button.
6) Hit the "Continue" button that is directly below the "Browse" button you used to browse to the file you selected.
Your post should now appear in the forum/thread with the file you selected attached.
Hope this helps.
~Jeff
patel
Hi PG.
I had tried sending the .log files BUT it was NOT getting attached !!! ( Don't know WHY ? ).
Anyhow, i had called Support and it is found that WorkRoute Service is NOT getting started due to incorrect Database ......... set-up. I will try to work this out and keep you updated.
Thanks to everybody who took time to share and provide the help for this, for now.
Patel.
patel
Hi.
Here's a quick UPDATE :- WorkRoute MP 4.1 SP 1 has been installed , configured and service started.
What i did ........
Database Data Files creation path in script-initdb.sql needed to be set according to PATH where Database is installed for MS SQL Server.
Through Enterprise Manager created the Db for WorkRoute and CHANGED the default names of DATA & LOG files as per the need in properties of Db.
Then executed the scripts which eventually deletes the Db created via Enterprise Manager and then Re-Creates everything again.
Does anybody have material / documents on WorkRoute apart from Process Development Guide available ? Would appreciate IF it is shared.
Thank You.
Patel.