Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
Web Service Create WorkSpace
roachm
Getting the following error when trying to create a workspace through the worksite web on an 8.1 ws web server.
"Server was unable to process request. --> File or assembly name 11k67iql.dll, or one of its dependencies, was not found."
I can login to the server through the web interface without any problem. I also used the same code without any problem on a different server that was 8.0 a couple weeks back.
Code is below and the _workspaceFactoryURL is set to
If _workspaceFactoryUrl Is Nothing Then
Throw New NullReferenceException("WorkspaceFactoryUrl property is null")
Return False
End If
f = New WorkspaceFactory.Factory(_workspaceFactoryUrl)
If _credentials Is Nothing Then
f.Credentials = System.Net.CredentialCache.DefaultCredentials
Else
f.Credentials = _credentials
End If
f.PreAuthenticate = True
id = f.CreateWorkspace(database, templateId, client & "." & matter, description _
, "", WorkspaceFactory.imSecurityType.imPublic, Nothing, profs, Nothing, errs)
Find more posts tagged with
Comments
jny
Check the web.config file to make sure that the value for the server name is correct:
<iManage.WorkSite>
<!--
iManage WorkSite related setting keys and values:
SmtpServer: The host name of the SMTP server used to send notification. By default, localhost is used.
Server: The iManage DMS server name.
OptionsPath: The file path where options.xml file is stored.
-->
<settings>
<add key="SmtpServer" value="localhost"/>
<add key="server" value="ws-red"/>
<add key="OptionsPath" value="data\options.xml"/>
</settings>
</iManage.WorkSite>
roachm
I checked and the server name is correct on the web.config file. Also i have sicne posted upgraded the 8.0 server to 8.1 and teh code works fine when run against that server so it is not a problem with 8.1 but something with the configuration of the server. Any other suggestions will be much appreciated. Thanks.
roachm
Seems like i have solved the problem. ASPNET user account did not have sufficient rights to the WINNT\TEMP folder. I granted it modify rights and now i no longer get this error when trying to create a workspace.
jny
Good to know. Thanks.