Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
backup
sunsun
i read in the documentation that you have to have a backup utility with iwfreeze facility to backup the content store
can anyone suggest what tool can be used to do so?
i mean to backup the entire content store for it to be utilized in the new installation of the teamsite and also that can execute the iwfreeze command.
we are in the process of upgrading from 5.5.2 to 6.5
can some one tell what important backup steps we need to perform and what cautions we need to take so we dont loose our old work.
thanks
Find more posts tagged with
Comments
briggek8717
http://devnet.interwoven.com/forums/cgi-bin/showthreaded.pl?Cat=&Board=PRODUCTS_TEAMSITE&Number=58667&page=&view=&sb=&o=&vc=1#Post58667
sunsun
i tried the script but it copies some file and also gives me a sharing violation error.
and does not create any new workareas in the new store
i did all the steps properly
please suggest the reason
thanks
Bhargav Coca
I would suggest doing it manually. Stop all the services related to Interwoven, mainly the 4 important one, na then back up the iw-store and save it on you local drive, well you can rename it and save it too. Back up your important configuration files, and then install the upgrade and copy back the iw-store and bring the services up. This procedure is explained in many posts over ages, i don't see any complications with this process, on contrary, this is a very risky and critical process, have to be delt with CAREFULLY..!
sunsun
I think that after the installation of the upgrade, modifications are automatically made to the existing backing store to be consistent with the current work. So why do we need to copy back the iw-store content. This probably would only be required if doing a fresh install on a new dev server and copying the existing backing store from the old backing store to the newly created backing store.
correct me if my thinking is wrong.
also suggest me what is the reason for this
any time i use net stop iwserver and use net start iwserver again, i get an error saying the teamsite service could not be started.
does it mean that everytime i stop the iwserver i have to restart the whole development server? because i had read that the server should never be manually started. has to start when the machine boots. and it would also not be possible to start the server since people might be working on the server.
Bhargav Coca
I guess you are right regarding the backing store, i was confused a little. Don't need to copy in an Upgrae scenario, but yes, certainly have to copy if doing a new install. Regarding the starting server, According to the manual, we do a iwfreeze, which freezes the server for sometime, and still people can login and read the content, but cannot modify. I would say depending on number of people accessing teamsite at a time, we can schedule server reboot. Cuz if you do a ner iwserver start/stop will intermittently stop all even when other users are working on the system, and when you restart it, it may throw an error as it was doing it to you. Instead of all this hastle, we can just reboot the system later in the night, when people wouldn't be accessing the services and bring it back up. This will restore normal functionality with out any ambiguous errors.
I hope i have answered your question
Thank you
fiquebem
We're running TS 6.5 SP2 on a Windows 2000 Server. I'm getting a couple of "Sharing violations" myself when trying to back up our content store, even after freezing TS. What can I do about it?
I'm using the XCOPY command with the "/C" switch to continue despite errors. (I'm using other switches too; see the source code of my batch file, meant to be run every night, below.) I noticed that, after XCOPY finished, 2 files were missing from the destination. What am I supposed to do? Ignore the omissions?
Thanks,
S.
@echo
off
::
:: 5/25/06
::
:: This BAT file is used to:
:: 1. Clear e:\Backup-of-TS-Content-Store\iw-store
:: 2. Freeze Interwoven/TeamSite
:: 3. Copy TS's content store from c:\iw-store to e:\Backup-of-TS-Content-Store
:: 4. Thaw TS
::
SETLOCAL
SET PROGRAM_NAME=ts-content-store-copy.bat
SET SOURCE_DIR=c:\iw-store
SET TARGET_PARENT_DIR=e:\Backup-of-TS-Content-Store
SET TARGET_DIR=%TARGET_PARENT_DIR%\iw-store
SET IW_HOME=C:\PROGRA~1\INTERW~1\TeamSite
SET IW_HOME_BIN=%IW_HOME%\bin
FOR %%f IN ("%SOURCE_DIR%";"%TARGET_PARENT_DIR%";"%IW_HOME%"; "%IW_HOME_BIN%") DO (
IF NOT EXIST %%f (
echo %PROGRAM_NAME%: missing item %%f
SET MISSING_FILE="true"
)
)
IF DEFINED MISSING_FILE (
goto ABORT
)
:: Erase the existing target:
:: RMDIR switches:
:: /S: Remove whole directory tree
:: /Q: Quiet mode
RMDIR /S /Q %TARGET_DIR% 2> NUL:
:: Freeze TS for (up to) 10 hours
%IW_HOME_BIN%\IWFREEZE +36000
IF NOT %ERRORLEVEL% == 0 (
echo Couldn't freeze TS!
goto ABORT
)
:: Copy TS's content store to the target:
:: XCOPY switches:
:: /E: Include subdirectories, including empty ones
:: /C: Continue even if encounter errors
:: /I: Assume that destination (e:\Backup-of-TS-Content-Store\iw-store) is a directory
:: /Q: Quiet mode
:: /H: Copy hidden and system files too
:: /K: Copy attributes
:: /X: Copy audit settings, including ownership and ACL information
XCOPY %SOURCE_DIR% %TARGET_DIR% /E /C /I /Q /H /K /X
:: Thaw TS effective immediately
%IW_HOME_BIN%\IWFREEZE --
IF NOT %ERRORLEVEL% == 0 (
echo Couldn't thaw TS!
goto ABORT
)
goto TERMINATION
:ABORT
:: Send e-mail notication to someone?
echo %PROGRAM_NAME%: aborting
:TERMINATION
endlocal