Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
DNR job for server down
bpg
im looking to set up a DNR job from OD 6.0.2 that would allow me to check whether a target server is alive before i send a deployment to it. if its dead, i want to skip that server and move onto the next target server. ive found that if a target server is down when a deployment is attempted, this has a knock-on affect for the teamsite app as well and causes the system to hang and eventually crash.
has anyone got any code that i can beg, steal or borrow to enable me to do this?
ta,
brendan
TS 6.5 SP1
OD 6.02
W2K3 EE
Find more posts tagged with
Comments
ISCBorisB
You may use iwodcmd command to interrogate receivers.
Format is:
OD-Home/bin/iwodcmd -host hostname -port portnumber serverstatus -q
Please note that
-q is a switch of serverstatus "action" and should go after it.
In other words, this is not iwodcmd switch.
- Interrogating host should be "allowed" host on the target.
Few Samples:
*** Check self ***
iwodcmd serverstatus -q
OpenDeploy server is alive.
0 deployments are currently active.
Return Code ($? in Perl) is 0
*** Interrogating host is not in "allowed" list ***
iwodcmd -host good_host -port 20159 serverstatus -q
Failed to receive message from OpenDeploy Server
Reason: sockErr=10054, Connection reset by peer
Check that the OpenDeploy server on host good_host is listening on port 20159.
Return Code is 1
*** Destination does not have OD Receiver in the first palce ***
iwodcmd -host bad_host -port 20159 serverstatus -q
Unable to Connect to OpenDeploy daemon
Reason: Failed to create Socket
Reason: sockErr=10057, Socket is not connected
Check that the OpenDeploy server on host bad_host is listening on port 20159.
Return Code is 1
Edited by ISCBorisB on 08/24/05 12:39 PM (server time).