Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
6.1 restart problems
boskovuk
We are installing a fresh 6.1 on Solaris 8 box and have problems when we are instructed to do a full restart of the TeamSite (iwreset -a). All required steps have been executed successfully prior to this command.
There are two error messages and we looked into two log files (as suggested upon the failure). Nothing comes to our minds.
Any suggestion and pointer will be appreciated:
Upon following all install instructions, iwreset -a command is issued. This is the output of that command:
bash-2.03# ./iwreset -a
Resetting iwserver. This operation takes some time
Please wait...
Resetting UI. This operation takes some time
Please wait...
Performing /Interwoven/TeamSite/private/bin/iwuiboot stop ...
Interwoven Servlet Engine stopping ...
ERROR: Failed to stop Interwoven Servlet Engine. Check /var/adm/iwui/servletd.log
Interwoven Proxy Server stopping ...
Interwoven Web Daemon stopping ...
Performing /Interwoven/TeamSite/iw-webd/bin/iwwebd_conf.ipl ...
Performing /Interwoven/TeamSite/private/bin/iwopenapiboot restart ...
Interwoven OpenAPI stopping ...
Interwoven OpenAPI starting ...
ERROR: Failed to start. Check /var/adm/iwui/openapi.log
Performing /Interwoven/TeamSite/private/bin/iwuiboot start ...
ERROR: OpenAPI has not been started yet.
bash-2.03#
/var/adm/iwui/servletd.log
java.net.ConnectException: Connection refused
at java.net.PlainSocketImpl.socketConnect(Native Method)
at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:350)
at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:137)
at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:124)
at java.net.Socket.<init>(Socket.java:268)
at java.net.Socket.<init>(Socket.java:268)
at java.net.Socket.<init>(Socket.java:95)
at org.apache.catalina.startup.Catalina.stop(Catalina.java:581)
at org.apache.catalina.startup.Catalina.execute(Catalina.java:402)
at org.apache.catalina.startup.Catalina.process(Catalina.java:180)
at java.lang.reflect.Method.invoke(Native Method)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:203)
/var/adm/iwui/openapi.log
wopenapiboot: ---------- STOPPING: Mon Dec 12 13:32:57 EST 2005
iwopenapiboot: ---------- STOPPED: Mon Dec 12 13:32:57 EST 2005
iwopenapiboot: ---------- STARTING: Mon Dec 12 13:32:57 EST 2005
Usage: OpenAPIServer [-h] [-p port] openapi_cfg_path
Starts an RMI registry and Interwoven OpenAPI server
-h This help message
-p The TCP port for the server's RMI registry (default 1099)
Solaris 5.8:
TS 6.1
OD 6.0.2 - DD 6.02 disabled
DD 5.6
Find more posts tagged with
Comments
nipper
When you created the user iwui, what shell did you give it ?
grep iwui /etc/passwd
jasonliu
iwui:x:108:60001:Interwoven TeamSite UI Daemons User:/Interwoven/TeamSite:/bin/sh
nipper
that is proper, see if you can su to it from root
jasonliu
I can su to it from root.
I saw these articles: 51316 & 53135.Can they solve our problems?
nipper
Possibly, but I a coupl eof the points were what we just tested. Check the permissions of the log file first.
Also at the end of the 51316 it shows a command, su iwui ....
try running that as root and post the results,
You probably should open a case with support, there are only a couple more things I know of to look at.
Andy
Adam Stoller
We are installing a fresh 6.1 on Solaris 8 box and have problems when we are instructed to do a full restart of the TeamSite (iwreset -a). All required steps have been executed successfully prior to this command.
If this is a fresh installation - I think you're misreading the instructions - you're not supposed to do an iwreset - you're supposed to do a *reboot* of the actual server machine (something like:
/usr/bin/shutdown -y -i 6
)
The machine needs to be rebooted after a fresh installation in order to get the virtual file system loaded.
--fish
Senior Consultant, Quotient Inc.
http://www.quotient-inc.com
HighlightCrosstab.rptdesign
boskovuk
Right, we did that (the whole box reboot).
The problem with TS restarts appeared in our post-installation phase. We still don't know what exactly happened at that time.
What we did was to uninstall and try a new, fresh, install. This one was successfull.
Solaris 5.8:
TS 6.1
OD 6.0.2 - DD 6.02 disabled
DD 5.6