I am having trouble with presentation templates using the iwov_mediabin_import tag getting "Access is Denied" when attempting to write files to Teamsite. This isn' t just a simple permissions issue (I don't think), so stay with me for a minute.
We have MediaBin setup for our DAM, and have Teamsite DCTs which allow users to select files from MediaBin. We have presentation templates setup for the DCRs which import the files into Teamsite from mediabin.
We are running compiling the presentation templates in a perl script called as an externalTask from Workflow. The perl script uses the presentation templates to import the assets (images, pdfs) from MediaBin, and uses the output of the presentation templates to build filelists which are then passed off to OpenDeploy.
This process generally works, although we have been having problems getting OpenDeploy stable. We're working on that separately, but I think it is contributing to the issue.
So, the user can create a DCR with some images associated from MediaBin, and can submit it through workflow which does all the OpenDeploy stuff we want. The problem arises should the user edit the DCR, and redeploy. We are getting into cases where the presentation template is trying to import files which already exist in Teamsite (from the previous import), and rather than doing the right thing, the importation is failing with an error like that included at the end of the post.
This doesn't happen everytime. Normally, the user can reimport/overwrite the files just fine. There seems to be some process locking the files. I can go in to the interface, delete the files, run the deployment again, and everything works just fine. So the problem occurs kind of at random.
We beleive it may have to do with opendeploy crashing and failed deployments somehow leaving these files locked, but we are narrowing down so many issues at once right now, it's hard to tell. We have found that if we restart OpenDeploy, the problem isn't alleviated, however, if we restart TeamSite, the problem is resolved. Users can then retry the importation and everything goes as planned. This leads us to beleive there is some process associated with Teamsite that is locking the files.
We just made some changes to try to stabilize OpenDeploy, and hopefully that will solve our problem, but only time will tell on that. If it doesn't happen for a day, we could be in the clear.
I'm hoping someone out there may have some feedback on this complicated topic.
If you think I'm just a crackpot newbie with some outrageous problem, you're mostly right, but please refrain expressing that opinion too adamantly.
Michael
==========================================>8 SNIP 8<=====================================================
[Tue Dec 20 15:28:33 2005]: cmd ->

/iwhome/bin/iwpt_compile.ipl -pt Y:/default/main/GamesRadar/us/WORKAREA/testing/templatedata/FutureNet/Article/presentation/mediabin_images.tpl -smartwrite -ofile Y:/default/main/GamesRadar/us/WORKAREA/testing/web/zz_tst_ggraziani_1135121313_images_preview.html -iw_include-location Y:/default/main/GamesRadar/us/WORKAREA/testing -iw_pt-dcr "Y:/default/main/GamesRadar/us/WORKAREA/testing/templatedata/FutureNet/Article/data/xbox_360__gears_of_war-previews-2005122012515756033.xml"
[Tue Dec 20 15:28:34 2005]: iwpt_compile images result ->
<ERROR>
TeamSite:

T::iwov_mediabin_import: HTTP/1.1 500 (Internal Server Error) java.io.FileNotFoundException: Y:\default\main\GamesRadar\us\WORKAREA\testing\mediabin\images\GamesRadar\us\Games\P\Perfect Dark Zero\12_16_2005\PDZ_Xbox360_04--game_thumbnail.jpg (Access is denied)
Connection: close
Date: Tue, 20 Dec 2005 23:28:32 GMT
Server: Apache-Coyote/1.1
Content-Language: en-US
Content-Length: 1594
Content-Type: text/html;charset=ISO-8859-1
Client-Date: Tue, 20 Dec 2005 23:28:34 GMT
Client-Peer: 127.0.0.1:80
Client-Response-Num: 1
Title: Apache Tomcat/5.0.27 - Error report
X-Cache: MISS from localhost
<html><head><title>Apache Tomcat/5.0.27 - Error report</title><style><!--H1 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;} H2 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;} H3 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;} BODY {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;} B {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} P {font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A {color : black;}A.name {color : black;}HR {color : #525D76;}--></style> </head><body><h1>HTTP Status 500 - java.io.FileNotFoundException: Y:\default\main\GamesRadar\us\WORKAREA\testing\mediabin\images\GamesRadar\us\Games\P\Perfect Dark Zero\12_16_2005\PDZ_Xbox360_04--game_thumbnail.jpg (Access is denied)</h1><HR size="1" noshade="noshade"><p><b>type</b> Status report</p><p><b>message</b> <u>java.io.FileNotFoundException: Y:\default\main\GamesRadar\us\WORKAREA\testing\mediabin\images\GamesRadar\us\Games\P\Perfect Dark Zero\12_16_2005\PDZ_Xbox360_04--game_thumbnail.jpg (Access is denied)</u></p><p><b>description</b> <u>The server encountered an internal error (java.io.FileNotFoundException: Y:\default\main\GamesRadar\us\WORKAREA\testing\mediabin\images\GamesRadar\us\Games\P\Perfect Dark Zero\12_16_2005\PDZ_Xbox360_04--game_thumbnail.jpg (Access is denied)) that prevented it from fulfilling this request.</u></p><HR size="1" noshade="noshade"><h3>Apache Tomcat/5.0.27</h3></body></html>
</ERROR>
==========================================>8 SNIP 8<=====================================================
Win 2003
TS 6.5 SP2
OpenDeploy 6.0.2 SP1
DataDeploy
MediaBin 4.5.2