Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
filelistbased deployment
Bhargav Coca
I am on TS6.5 on win2000 with OD 6.0.2. All i am trying to do is to deply files using filelist based deployment. My deploy task works fine and i get a successful deployment email. But if i look the log files, they say that the deployment is not successful and it throws this following error.
ENG: 2005-12-27 15:44:36 CST GMT-06:00 ***ERROR - FileList templatedata\CITS\contract\data\76970511_E not found.
ENG: 2005-12-27 15:44:36 CST GMT-06:00 ***ERROR - Failed to start deployment.
My filelist cointains this file though.
Thank You
Find more posts tagged with
Comments
Migrateduser
This might be a false positive, but what is generating your successful deployment email? In other words, how do you know that the deployment was successful?
Environments:
(1,2) TS6.5, TS6.5SP1 on W2K3
(3) Vignette V7 Portal on Solaris 9
reddyl
Try running the deployment from the command line that will tell you if the deployment was successfull or not.
Bhargav Coca
It s a part of Workflow, It has a email job after deployment is done. That is getting activated successfully. I guess i ahve my configuration file wrong.
I will check on it.
Thank you
Migrateduser
How are you calling OD? With iwodcmd or with the iwodstart.ipl script which actually issues a meaningful return code? I'm thinking that your script (or whatever is wrapping the OD command) is falsely interpreting the deployment as being successful, but I would need more information about how your script works.
Environments:
(1,2) TS6.5, TS6.5SP1 on W2K3
(3) Vignette V7 Portal on Solaris 9
Bhargav Coca
OK here is my configuration file. I have ran the command from command line too it works. when i say it works, i meant that it generated the three log files for this deployment and nothing has errors. But i donot see my files on the target server. I seriously douth about my configuration file. Please suggest if i am wrong anywhere.
<?xml version="1.0" encoding="ISO-8859-1" ?>
<deploymentConfiguration >
<localNode host="172.24.20.138" timeout="" blockMaxWaitTime="" blockCheckInterval="" />
<replicationFarmSet >
<replicationFarm name="MYFARMNAME" quorum="" >
<nodeRef useNode="DLEXT02" />
</replicationFarm>
</replicationFarmSet>
<definition name="MYDEFINITIONNAME" >
<source >
<sourceFilesystem area="$area" filelist="$file" >
<pathSpecification>
<path name = "."/>
</pathSpecification>
</sourceFilesystem>
</source>
<target useReplicationFarm="MYFARMNAME" >
<comparisonRules dateDifferent="yes" revert="no" ignoreAcls="yes" ignoreModes="no" ignoreUser="no" ignoreGroup="no" />
<transferRules doDeletes="no" dontDo="no" preserveAcls="no" followLinks="no" svrTryCount="" svrTryInterval="" svrTryDisableOverwrite="no" rmReadOnly="no" compression="no" compressionLevel="" applySourceFileTime="yes" />
<permissionRules amask="" omask="" directory="0755" file="0644" group="" user="" changeAccess="" setAccess="" />
<targetFilesystem area="E:\necweb\customers\folders\CITS\Contracts" />
<replicationFarmLink >
<internal name="MYFARMNAME" />
</replicationFarmLink>
</target>
</definition>
<deployment transactional="no" >
<execDeploymentTask useDefinition="MYDEFINITIONNAME" />
</deployment>
</deploymentConfiguration>
Thank you
Migrateduser
I'm confused -- in your initial post on this thread, you pasted two errors from your log file. Now, you're saying that there are no errors. As verbose as the OD log files are, you can't always rely on them to tell you if a deployment was successful or not. More reliable is to use the iwodstart.ipl script located in <od-home>/solutions/perl. This script returns a code which reflects the status of the deployment. You're looking for a "0". Anything else means that it failed.
Environments:
(1,2) TS6.5, TS6.5SP1 on W2K3
(3) Vignette V7 Portal on Solaris 9
Adam Stoller
Dave - have you had problems getting a reliable exit status from iwodcmd since OD 5.6 SP1 and/or 6.0.2 were released?
iwodstart.ipl was created specifically for 5.5.1 and pre-dates the existance of iwodcmd.
If at all possible - I'd lean towards using iwodcmd over iwodstart.ipl as much as possible.
--fish
Senior Consultant, Quotient Inc.
http://www.quotient-inc.com
Migrateduser
I generally do, too, but I haven't had problems with iwodstart.ipl and it provides more detail than iwodcmd. Where iwodcmd returns "Completed with error" or simply "Failed", iwodstart.ipl has a couple of additional statuses it can return, which is helpful for error notification.
Environments:
(1,2) TS6.5, TS6.5SP1 on W2K3
(3) Vignette V7 Portal on Solaris 9
Bhargav Coca
I have tried to run the ipl which is called from workflow for Opendeploy, and it gives me this following error. Have you seen such an error before.
C:\Interwoven\TeamSite\iw-perl\bin>iwperl C:\Interwoven\TeamSite\local\config\wf
t\coca\wft_opendeploy.ipl
Locating OpenDeploy service.
Got OpenDeploy service
>>>>>-- Start deployment legal.
iwodstart running in default synchronous mode.
Need to wait for deployment to complete.
>>>>>-- Deployment legal finished:
ID: m41 Start time: Wed Dec 28 16:51:25 CST 2005
Status: Completed
Task 0 does not exist.
ERROR:00920: Object being looked up was not found
Thank you
Adam Stoller
The script you're running is a workflow externaltask script - as such it is expecting to be passed certain arguments on the command line that are passed by default via the workflow engine (jobid, taskid, areavpath, and potentially relative file paths) - which you need to supply at least the first two yourself if you're running the command from the command line.
--fish
Senior Consultant, Quotient Inc.
http://www.quotient-inc.com
TestReport.rptdesign
Migrateduser
The error that you pasted has nothing to do with OpenDeploy and has everything to do with TeamSite and workflow. The task on which you're trying to perform an operation (callback, perhaps?) is not valid. Your externaltask script might be messed up and it wouldn't hurt to attach it to your response (please don't PASTE it, rather ATTACH it).
Dave
Environments:
(1,2) TS6.5, TS6.5SP1 on W2K3
(3) Vignette V7 Portal on Solaris 9
Bhargav Coca
Hey Dave,
I figured this out. It was problem with some deployment running in the background. All id id was restart OD on the base and everything worked.
Thank you