Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
Problem in Login thro Programmatically
Raj77
Hi,
I'm getting the following error while am trying to login using EnterpriseSession.
My code looks like this.....
*********
session1 = sessionMgr.createEnterpriseSession();
System.out.println("After the creation of Enterprise Session");
// Connection pool configuration setup logic.
PoolConfiguration[] poolConfig = new PoolConfiguration[1];
System.out.println("User id - " + userid);
System.out.println("Password - " + password);
System.out.println("Library Name - " + libraryName);
poolConfig[0] = new PoolConfiguration(libraryName, "rcosvr0774", 5, userid, password);
sessionMgr.startPoolsFor(poolConfig);
System.out.println("After pooling.........");
session1.logon(applicationName, "rcosvr0774", userid, password);
System.out.println("Successfully logged on...");
session1.ping();
System.out.println("Pinging.......");
*********
I'm trying to make use of connection pooling concept thro EnterpriseSession. Your immediate response would be appreciated. Thanks in advance.
com.ftt.edr.exception.DocumentServiceException: com.ftt.edr.exception.DocumentServiceException: com.imanage.cms.exceptions.library.AuthenticationException: Error Switching Context
at org.apache.axis.AxisFault.makeFault(AxisFault.java:101)
at org.apache.axis.providers.java.JavaProvider.invoke(JavaProvider.java:333)
at org.apache.axis.strategies.InvocationStrategy.visit(InvocationStrategy.java:32)
at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:118)
at org.apache.axis.SimpleChain.invoke(SimpleChain.java:83)
at org.apache.axis.handlers.soap.SOAPService.invoke(SOAPService.java:453)
at org.apache.axis.server.AxisServer.invoke(AxisServer.java:281)
at org.apache.axis.transport.http.AxisServlet.doPost(AxisServlet.java:699)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:709)
at org.apache.axis.transport.http.AxisServletBase.service(AxisServletBase.java:327)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:856)
at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection(Http11Protocol.java:744)
at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80)
at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
at java.lang.Thread.run(Thread.java:595)
Caused by: com.ftt.edr.exception.DocumentServiceException: com.ftt.edr.exception.DocumentServiceException: com.imanage.cms.exceptions.library.AuthenticationException: Error Switching Context
at com.ftt.edr.documentservice.DocumentServiceSoapBindingImpl.getViewDocumentLink(DocumentServiceSoapBindingImpl.java:323)
at com.ftt.edr.documentservice.DocumentServiceSoapBindingSkeleton.getViewDocumentLink(DocumentServiceSoapBindingSkeleton.java:200)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at org.apache.axis.providers.java.RPCProvider.invokeMethod(RPCProvider.java:397)
at org.apache.axis.providers.java.RPCProvider.processMessage(RPCProvider.java:186)
at org.apache.axis.providers.java.JavaProvider.invoke(JavaProvider.java:323)
... 23 more
Caused by: com.ftt.edr.exception.DocumentServiceException: com.imanage.cms.exceptions.library.AuthenticationException: Error Switching Context
at com.ftt.edr.documentservice.DocumentServiceSoapBindingImpl.getSession(DocumentServiceSoapBindingImpl.java:205)
at com.ftt.edr.documentservice.DocumentServiceSoapBindingImpl.getViewDocumentLink(DocumentServiceSoapBindingImpl.java:236)
... 31 more
Caused by: com.imanage.cms.exceptions.library.AuthenticationException: Error Switching Context
at com.imanage.cms.fc.cmsconnection.CmsConnectionPool.getConnectionViaVirtualConnection(CmsConnectionPool.java:874)
at com.imanage.cms.fc.cmsconnection.UserConnection.getConnectionImpl(UserConnection.java:45)
at com.imanage.cms.fc.cmsconnection.CmsConnectionVirtual.getConnection(CmsConnectionVirtual.java:380)
at com.imanage.cms.fc.cmsconnection.CmsConnectionVirtual.validateConnection(CmsConnectionVirtual.java:208)
at com.imanage.cms.fc.cmsconnection.UserConnection.<init>(UserConnection.java:36)
at com.imanage.cms.fc.cmsconnection.CmsConnectionPool.getConnection(CmsConnectionPool.java:785)
at com.imanage.cms.t2.jom.impl.PoolManager.getLoggedOnLibraryFor(PoolManager.java:212)
at com.imanage.cms.t2.jom.impl.DefaultReconnector.getLibraryByName(DefaultReconnector.java:28)
at com.imanage.cms.t2.jom.impl.EnterpriseSessionImpl.getLoggedOnTrustee(EnterpriseSessionImpl.java:137)
at com.imanage.cms.t2.jom.impl.SessionImpl.logonImpl(SessionImpl.java:86)
at com.imanage.cms.t2.jom.impl.EnterpriseSessionImpl.logon(EnterpriseSessionImpl.java:23)
at com.imanage.cms.api.workteam.impl.EnterpriseSessionImpl.logon(EnterpriseSessionImpl.java:38)
at com.ftt.edr.documentservice.DocumentServiceSoapBindingImpl.getSession(DocumentServiceSoapBindingImpl.java:197)
... 32 more
Thanks,
-Raj.
Find more posts tagged with
Comments
jny
I believe you're in the wrong forum; you should post this within the WorkSite MP Product Line branch.