Home Documentum

Custom Widget is not appearing in widgets list in xCP Designer

edited May 12, 2015 in Documentum


I have a widget which I have developed for using in xCP Designer and to be dropped onto the interface pages. It is a bare bones one because I just want it get it worker before I tackle anything more complex.

The following is the JavaScript

Ext.define("stg.widgets.demographics", {

    extend: 'Ext.Component',

    alias: 'widgets.demographics',

initComponent : function() {

    }

});

I can't see any error in the javascript

and the corresponding config file

<?xml version="1.0" encoding="UTF-8"?>
<widget xmlns="http://documentum.emc.com/2010/UI-Model" xmlns:xcp="http://documentum.emc.com/xcp/2010"
        id="demographics" xtype="demographics"
        version="1.0.0000.001">

    <name>Patient Demographics</name>
    <description>Display Patient Demographics.</description>
    <author email="[email protected]">Joseph Wong</author>

    <icon src="icons/person_24_wig.png" width="24" height="24"/>
<icon src="icons/person_wig.png" width="16" height="16"/>

    <content src="content/stg/widgets/demographics.js" type="text/javascript"/>
    <content src="content/stg/widgets/designer/demographics.js" type="text/javascript" nls="stg/widgets/designer/demographics.js" mode="design"/>

    <category>xcpPalette:Custom</category>

    <configuration> 
    </configuration>

</widget>

Again I cannot see any error in the XML - the lack of properties is deliberate as I was thinking of adding some once the widget appears.

JAR file is attached.

However even though it imports without any error into the Application Model it does not appear within the interface designer in xCP, can anyone see a reason why? xCP Version is Build: 2.0.0070.5035)

Thanks in advance

Thanks in advance

Tagged:

Comments

  • edited August 21, 2014

    Found it - just needed to restart xCP designer. That said now I find that the widget selection window on the right has vanished and cannot see how to get it back.

    Any ideas gratefully received.

  • dnvhariprasaddnvhariprasad Hari Prasad Dontu
    edited August 21, 2014

    Try this to resolve the designer issue

    1. Close designer

    2. clear .m2 (do backup before it)

    3 remove the contents under C:\Users\<<userid>>\AppData\Local\eclipse

    4. launch the designer

    5. Clear contents under C:\Users\<userid>\AppData\Roaming\Mozilla\eclipse

  • edited September 15, 2014

    Hi Hari,

    I tried your suggestion but I still don't see my custom widget appearing in the Libraries list.

    custom-widget-list.png

    Strangely enough it appears in the Custom widget palette.

    custom-slider-widget.png

    I have checked the manifest file and have the correct xcp execution environment.


    EMC-XCP-ExecutionEnvironment: com.emc.executionenvironment.xcp:2.1.4

    Attached is the custom widget JAR. Am I missing some information that is necessary for xCP Designer to function properly?

  • edited September 28, 2014

    Was able to fix the issue by making the following changes to the manifest file:

    1.     Changed the Bundle-Versionto have three digits.  
      Bundle-Version: 1.1.2
    2.     Changed the JAR filename to contain the Bundle-Version number  
      JahanToolbox-1.1.2.jar
    3.     Changed Bundle-SymbolicName to contain namespace (jbt)  
      Bundle-SymbolicName: jtb.JahanToolbox
  • edited May 12, 2015

    widgets issue.PNG.png

    WIDGETS PALLET NOT VISIBLE IN XCP 2.2

  • nkingnking EM
    edited May 12, 2015

    It looks like the eclipse cache may be corrupted.  Try closing Designer, deleting the folder %LOCALAPPDATA%\eclipse folder, and re-opening Designer.

  • edited May 12, 2015

    Thanks For the Quick Reply,

    I Have deleted .m2 folder

    & the eclipse folder is not creating in my system...

  • nkingnking EM
    edited May 12, 2015

    The folder is usually in this location:

    C:\users\<username>\appdata\local\eclipse\cache


    It must be there somewhere....

  • edited May 12, 2015

    Yup i knw ... actually  the problem is when i am using XCP designer 2.1 the eclipse folder is Created but when i am using XCP 2.2 the eclipse folder is not created ??

    Are there any issues with XCP 2.2 ??

    or any compatible jdk or jre is required??

  • nkingnking EM
    edited May 12, 2015

    What happens if you create a new application and open that?  Does Designer open OK then?  It might be something in your custom widget that is preventing Designer from loading.

  • edited May 12, 2015

    yup designer is opening  without anu problem ... and i am not using any custom widgets ...

  • edited May 12, 2015

    Run xcp designer as administrator. Have you tried this option?

  • nkingnking EM
    edited May 12, 2015

    So one app opens OK, but another doesn't.  Then it sounds like that application / page has maybe become corrupted.  There must be an eclipse cache somewhere on your machine though, but maybe it is put somewhere else due to a policy on your machine.

  • edited May 12, 2015

    I have tried that too ...

  • edited May 12, 2015

    Okk i wll check ...

  • edited May 12, 2015

    Is there Any XCP 2.2 Designer Guide or Something...

  • edited May 12, 2015

    I suspect you are using Windows 8. If this is the case then apply this Microsoft patch (http://www.microsoft.com/en-in/download/details.aspx?id=14632), and reopen the page in Designer.


    The reason the layout tab is blank is because Windows 8 does not have the libraries required to run applications compiled with Visual C++ 2010 x64.

  • nkingnking EM
    edited May 12, 2015

    You have the xCP release notes and deployment guide that can be downloaded from the support site, and then Designer has it's own inline help instead of an xCP Designer manual. 

    Can I double check though that if you create a second app and open that Master page up, do you see the widget palette? 

    In any case, when you open the bad app can you get the xCP Designer log file and attach it to a post here.

  • edited May 12, 2015

    I have Tested the 2.2 designer in Win Server 2012 (64 bit )there widgets are visible & also eclipse folder is created

    But in Win Server 2008 and win 7 (64 bit )... the widgets are not visible 

    so finally its OS issue .... , so do i need to apply any Patch or Something .... for Win 7 and Win Server 2008 ????

  • edited May 12, 2015

    OHH .... AT LAST GOT SOLUTION ...

    thnks all for your help

    Apply Patch Download Microsoft Visual C++ 2010 Redistributable Package (x64) from Official Microsoft Download Center

    then Start Designer

Sign In or Register to comment.