Home Documentum

webtop not starting in Tomcat

edited April 13, 2015 in Documentum

I have a customized webtop 6.7SP1 application. After upgrading the application to 6.7 SP2 and deploying it on a new tomcat 7 server, the application does not start. How do I fix this issue and start up the application?

The error displayed is:

SEVERE: Exception starting filter WDKController
java.lang.NullPointerException
  at java.util.regex.Pattern.<init>(Unknown Source)
  at java.util.regex.Pattern.compile(Unknown Source)
  at com.documentum.web.env.WDKController.init(Unknown Source)
  at org.apache.catalina.core.ApplicationFilterConfig.initFilter(ApplicationFilterConfig.java:277)
  at org.apache.catalina.core.ApplicationFilterConfig.getFilter(ApplicationFilterConfig.java:258)
  at org.apache.catalina.core.ApplicationFilterConfig.setFilterDef(ApplicationFilterConfig.java:382)
  at org.apache.catalina.core.ApplicationFilterConfig.<init>(ApplicationFilterConfig.java:103)
  at org.apache.catalina.core.StandardContext.filterStart(StandardContext.java:4650)
  at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5306)
  at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
  at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:901)
  at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:877)
  at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:618)
  at org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:1100)
  at org.apache.catalina.startup.HostConfig$DeployDirectory.run(HostConfig.java:1618)
  at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
  at java.util.concurrent.FutureTask.run(Unknown Source)
  at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
  at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
  at java.lang.Thread.run(Unknown Source)

Comments

  • edited January 14, 2015

    Hello , check WEB-INF\web.xml file and compare it against the default 6.7 SP2 version.

  • edited January 14, 2015

    Thanks @rstein but I there must be something else. I put the original webtop 6.7sp2 web.xml and restarted the app server but the error remains.

    Can the error message be caused by another configuration file other than web.xml?

  • edited January 14, 2015

    The deployment guide states some other configuration that need to be done in Tomcat before app deployment:

    • Disable the enablePooling property in web.xml

    DA 7.1 also requires, and I believe that some of them are needed for Webtop on Tomcat 7 as well:

    • In the file catalina.properties insert: org.apache.jasper.compiler.Parser.STRICT_WHITESPACE=false
    • In context.xml modify the Context element adding useHttpOnly="false", like:

                   <Context useHttpOnly="false">

    Check these configurations and tell me if it works.

  • edited January 14, 2015

    Thank you for you answer.

    The following modification have been made:

    1. Failover turned off in app.xml
    2. enablePooling disabled in web.xml
    3. useHttpOnly="false" in context.xml
    4. org.apache.jasper.compiler.Parser.STRICT_WHITESPACE=false added to catalina.properties

    Tomcat 7.0.29 restarted, work folder cleared, and the error remains in localhost.2015-01-14.log

  • edited January 14, 2015

    I suggest you deploy the original out-of-the-box Webtop 6.7 SP2 and try it out in that same Tomcat 7. Then, if it works, you'll have to identify what modification introduced by your customization causes this behavior.

  • edited January 16, 2015

    disable all the components you extend in the custom (or your) layer, then re-enable them one after the other to find which one crashes....

  • edited April 13, 2015

    Did you find a solution?

    Regards

    Alain

Sign In or Register to comment.