Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
Connection failed: Could not find matching OpenDeploy client for (helios).
boskovuk
Our two servers host OD 6.02. In addition, there is firewall between them - needed firewall port, 20014, is open (tested by:
telnet 132.246.18.2 20014
odnodes.xml on the base side, is defining a new node, which points to firewall (IP address, port number, etc.). Is this correct?
<node name="firewall_Helios_irc-ce"
host="132.246.18.2"
port="20014"
/>
odbase.xml on the receiver side, behind the firewall, is including a firewall in its list of allowed hosts:
<allowedHosts>
<node host="132.246.18.2">
<allowedDirectories>
<path name="/default/main/CCMC/WORKAREA/development/testOD"/>
</allowedDirectories>
</node>
</allowedHosts>
ENG: 2005-09-13 14:48:37 EDT GMT-04:00 Thread-16 ***ERROR - I/O error with [/cms/iw-home/OpenDeploy/BaseServer/OpenDeployNG/log/src.Helios_irc-ce.CCMC-workarea.helios.to.firewall_helios_irc-ce.log.mf]: File not found
Attached is the log file.
Something is wrong, I am not able to find out. We'll continue to troubleshoot - any help greatly appreciated.
Solaris 5.9 - TS 6.5 sp1 - OD 6.0.2; DD enabled
Solaris 5.9 - TS 6.1 sp1 - OD 5.6; DD 5.6
Find more posts tagged with
Comments
boskovuk
Attached is deployment configuration file.
Solaris 5.9 - TS 6.5 sp1 - OD 6.0.2; DD enabled
Solaris 5.9 - TS 6.1 sp1 - OD 5.6; DD 5.6
boskovuk
Solved!
The problem was caused by the fact that receiver odbase.xml (yes, we have base on that machine) did not have the base machine IP address (within list of allowedHosts). Instead, it was pointing to firewall.
As soon as sending machine IP address was added (and the OD restarted), things started working.
Solaris 5.9 - TS 6.5 sp1 - OD 6.0.2; DD enabled
Solaris 5.9 - TS 6.1 sp1 - OD 5.6; DD 5.6