Number of items exceeds the maximum allowed

edited March 21, 2016 in Documentum

Hi,

I'm getting this error in Taskspace :Number of Items exceeds the maximum allowed.

I have a dropdown that I populate using an adaptor, when its populated I get the error below.

What am I doing wrong, what do I need to fix to make this work.

2016-03-18_15h24_55.png

2016-03-18_15h31_13.png

2016-03-18_15h59_37.png

Tagged:

Comments

  • nkingnking EM
    edited March 19, 2016

    There must be a limit to the number of items in a drop down and so you would need to add a dql hint (return top) to the query (if it's a custom adaptor) or add an additional filter to restrict the number of results returned.

    Sent from my iPhone

  • edited March 20, 2016

    Hi Nick,

    I just tried that but I'm still getting the same error message.

    Here's my edited adaptor's dql

    2016-03-20_08h18_06.png

    2016-03-20_08h21_06.png

  • nkingnking EM
    edited March 21, 2016

    It must be something in the configuration of the dropdown widget or the SDT where the data is being saved, that is set to only allow one value.  Can you compare the configuration with the Place of Exam for example?

  • edited March 21, 2016

    I removed the adaptor from Special(execute when input changes) and only left with the one in Data & Storage.

    Now it's working fine.

    Thanks for your assistance

Sign In or Register to comment.