Home Documentum

Taskspace workflow xform not translated

666666
edited October 28, 2016 in Documentum

Hello all,

I am trying to modify an old application implemented on Taskspace 6.5, to add a new step onto an workflow and I have the following scenario:

- i opened the workflow template with Process Builder to edit it

- i added the new step and i attached it with a form created in Forms Builder

- i installed the form and the process template and run the workflow in Taskspace

Taskspace is configured to run in two languages.

The problem is that when i open my form in Taskspace, the form appears only in the default language. All the other forms from my workflow are changing from a language to another when i change the language at login, only the new form i added did not change his language.

What should i do specially for this new form to be translated like the other forms. I mention that all untranslated labels are the default labels which are coming from Forms Builder, not custom label introduced by me.

Update: I observed that there are two entries in the object type dm_xfm_resource for the other forms and just one for my form. So, i suppose that i need to attache the other language somewhere through an option. The question now is: where could be found that option?

Update: I added a dm_xfm_resource type document for the other language using DA, but still not working. I suppose that this isn't the standard procedure.

Thank you

Best Answer

  • 666666
    edited October 28, 2016 Accepted Answer

    Hello,

    The situation was solved. Thank you all for the answers.

    The complete solution is as follows:

    1. If you don't have the language available in Forms builder, you should add it, by adding an entry like "<locale>ro_RO</locale>" in the file "<dctm_local_path>\FormsBuilder\custom\locale\custom_locale_config.xml". Usualy <dctm_local_path> is "c:\Documentum". Keep in mind that if that file is missing, it should be created. See more details in the chapter "Configuring additional locales" in http://www.emc.rs/collateral/TechnicalDocument/docu7780.pdf.

    2. In Forms Builder, from the option Tools -> Localization -> Export, you should export the file for your language and translate the labels inside. Keep in mind to not change the name of file.

    3. In Forms Builder, from the option Tools -> Localization -> Import, you should import the file just modified at the previous point.

    ...and that's all

    Thank you!

Answers

  • edited October 24, 2016

    Hi,

    You can localize Forms by exporting the English Resource file in Forms Builder and creating a new file by translating the English

    resource into the required language.

    For detailed instructions please refer to EMC Documentum Process Builder Localization Guide version 6.5

    Thank you,
    Alex

  • edited October 24, 2016

    I would like to mention 6.5 support already end of life.  Suggest upgrade to the latest 67sp3.

  • edited October 25, 2016

    Forms Builder user guide chapter 6 has information on localizing template.  The document still available on support.emc.com.

  • 666666
    edited October 28, 2016 Accepted Answer

    Hello,

    The situation was solved. Thank you all for the answers.

    The complete solution is as follows:

    1. If you don't have the language available in Forms builder, you should add it, by adding an entry like "<locale>ro_RO</locale>" in the file "<dctm_local_path>\FormsBuilder\custom\locale\custom_locale_config.xml". Usualy <dctm_local_path> is "c:\Documentum". Keep in mind that if that file is missing, it should be created. See more details in the chapter "Configuring additional locales" in http://www.emc.rs/collateral/TechnicalDocument/docu7780.pdf.

    2. In Forms Builder, from the option Tools -> Localization -> Export, you should export the file for your language and translate the labels inside. Keep in mind to not change the name of file.

    3. In Forms Builder, from the option Tools -> Localization -> Import, you should import the file just modified at the previous point.

    ...and that's all

    Thank you!

Sign In or Register to comment.