Hi all,
I have installed TS 6.5 SP2 on Solaris 8 and did some initial testing and everything worked fine.
Then i brought down the server to do some custom perl module installation.
I started iwserver today and accessing admin interface gives me below error:
Error:
======
HTTP Status 500 -
type Exception report
message
description The server encountered an internal error () that prevented it from fulfilling this request.
exception
javax.servlet.ServletException: Servlet.init() for servlet CommandServlet threw exception com.interwoven.ui.base.impl.auth.AuthenticationFilter.handleInvalidAuthentication(AuthenticationFilter.java:163) com.interwoven.ui.base.impl.auth.AuthenticationFilter.doFilter(AuthenticationFilter.java:198) com.interwoven.ui.base.util.SetRequestEncodingFilter.doFilter(SetRequestEncodingFilter.java:105)
root cause
org.apache.commons.digester.xmlrules.XmlLoadException: /apps/iw-home/servletd/work/Catalina/localhost/iw-cc/loader/com/interwoven/ui/base/config/ConfigManager.rules (No such file or directory) org.apache.commons.digester.xmlrules.FromXmlRuleSet.addRuleInstances(FromXmlRuleSet.java:139) com.interwoven.ui.base.config.ConfigManager.getInstalledToolkits(ConfigManager.java:344) com.interwoven.ui.base.config.ConfigFileset.getIndividualFiles(ConfigFileset.java:214) com.interwoven.ui.base.config.ConfigManager.doSetup(ConfigManager.java:160) com.interwoven.ui.base.config.ConfigManager.setup(ConfigManager.java:104) com.interwoven.ui.base.impl.command.CommandServlet.init(CommandServlet.java:102) javax.servlet.GenericServlet.init(GenericServlet.java:211) com.interwoven.ui.base.impl.auth.AuthenticationFilter.handleInvalidAuthentication(AuthenticationFilter.java:163) com.interwoven.ui.base.impl.auth.AuthenticationFilter.doFilter(AuthenticationFilter.java:198) com.interwoven.ui.base.util.SetRequestEncodingFilter.doFilter(SetRequestEncodingFilter.java:105)
note The full stack trace of the root cause is available in the Apache Tomcat/5.0.27 logs.
Apache Tomcat/5.0.27
Thanks,
Mohit.