Label name is not showing in workspace and widgets

edited September 21, 2017 in Documentum

We are using D2 4.2 version application for pharmaceutical domain. For some users, Label name is not getting reflected in workspace and widgets tab that we had configured in D2 Config. Instead of that, the name of the configuration element (workspace, widget) is coming when they are logging into the application.

Kindly let me know, what could be the reason for that.

Tagged:

Best Answer

  • Sanjay_KumarSanjay_Kumar Sanjay Kumar Kothari
    edited September 20, 2017 Accepted Answer

    This could be due to difference in the locale settings on the client machine and the app server.

    You need to have the specific language pack installed or enforce the English language using the settings in the settings.properties file of your D2 deployment folder.

    Set the "language.user.forced=en"

    Usually this setting exists and is commented.

Answers

  • edited September 19, 2017

    They might want to trying clearing their browser's cache.

    Also, you might want to try to delete their user preferences object in the docbase, they will be regenerated automatically).

    Also, could it be you have multiple locale in the docbase and the labels are not populated for all locales ??

  • edited September 19, 2017

    Hi Francois,

    Thanks for your reply.

    I had tried deleting the preferences and clearing their browser's cache many times. still they are facing this issue.

    I checked in the dm_docbase_config object. i can see that the attribute dd_locale is having only one locale value i.e en.

  • edited September 19, 2017

    Worst case: did you try to stop the App server, clear its cache and restart it ?

    Also, in D2-Config, did you reload the cache ?

  • Sanjay_KumarSanjay_Kumar Sanjay Kumar Kothari
    edited September 20, 2017 Accepted Answer

    This could be due to difference in the locale settings on the client machine and the app server.

    You need to have the specific language pack installed or enforce the English language using the settings in the settings.properties file of your D2 deployment folder.

    Set the "language.user.forced=en"

    Usually this setting exists and is commented.

  • edited September 21, 2017

    We had changed the locale setting on the user's machine to English language. Finally, it worked..

    Thank you Sanjay for giving your suggestion on the query.

Sign In or Register to comment.