import_component.xml, just won't work

edited November 7, 2017 in Documentum

Folks,

I am very EXTREMELY frustrated with this import_component.xml not working. I have tried both, modifies and extends; I even made a copy of import_component.xml and put it in my custom/config folder.

Pretty much I want it to either:

a) Take the tags:

<component modifies="import:webcomponent/config/library/contenttransfer/importcontent/import_component.xml">

         <replace path="document-docbase-base-type">

            <document-docbase-base-type>xa_content</document-docbase-base-type>

         </replace>

         <replace path="document-docbase-type">

            <document-docbase-type>xa_content</document-docbase-type>

         </replace>

     </component>

OR

b) Take the <start> tags to refer a custom .jsp:

<replace path="pages">

         <pages>

               <start>/custom/jsp/import_component/importContent.jsp</start>

               <folder>/webcomponent/library/contenttransfer/importcontent/importFolder.jsp</folder>

         </pages>

         </replace>

None of the above works. I replaced the <start> tag as follows:

<start>THISLOCATIONDOESNOTEXISTS</start>


And I don't get an error; if I misspell the <start> to <startx> then I get an error. Seems like if the .xml is well formed with the correct tags it goes well, but it is not taking my changes AT ALL from either extends, modifies, or the ORIGINAL file.


I did modify, after backing up, the copy of importContent.jsp in its original location and I get the results that I want, BUT, I need these in the custom/config. NOTE: I have other customization in custom/config and I don't have these problems! It all seems to do ONLY with import_component.xml.I have cleaned the clien't cache, TomCat's cache, etc.


Any ideas?

Tagged:

Comments

  • edited November 7, 2017

    Have you tried /wdk/refresh.jsp in the url to reload wdk component?

  • edited November 7, 2017

    I have tried **everything** I can think of.

    It is just that particular import_component.xml behaving that way on the custom/config

  • edited November 7, 2017

    As of last resort, I would just use start (forget the replace feature) and define all the start options that you need.

Sign In or Register to comment.