Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
Random "Commit Failed"
System
Hey Everyone,
We are running into an issue when deploying content using opendeploy 6.0.1.
We are deploying to a webserver and an appserver using 2 OD profiles which are being called on via a DnR. We also have another DnR to execute BEA's bulkloader.
It seems like randomly we get an error "Commit Failed" when deploying to the application server. I am saying random because we tried to find some pattern to this error, but it seems to happen randomly.. we can't find any specific file which causes this error.
The error logs on the source display the following:
LIB: 2006-06-12 15:38:39 ERROR: client_after_deploy DNR script failed during commit phase.
LIB: 2006-06-12 15:38:39 ERROR: Failed to deploy local_directory[.] of area[/default/main/Intranet/Risk/STAGING] for filelist[/tmp/nLQJcuzSLY]
LIB: 2006-06-12 15:38:39 ERROR: Failed 1 of 1 filelists
ENG: 2006-06-12 15:38:40 EDT GMT-04:00 Thread-589 After COMMIT, res=-1
The error logs on the target display the following:
LIB: 2006-06-12 15:44:11 ERROR: commit-failed.
LIB: 2006-06-12 15:44:11 ERROR: Failed deploying filelist[0]
LIB: 2006-06-12 15:44:11 ERROR: Failed 1 of 1 filelists
ENG: 2006-06-12 15:44:11 EDT GMT-04:00 Thread-813 After COMMIT1 res=-1
I have read several postings who mentioned something about commit failure occurring when the DnR takes too long.. could that be the case here?
Thanks,
Ido
Find more posts tagged with
Comments
Migrateduser
Turns out you can't have file names longer then 50 characters, because Bulkloader won't work properly. It seems just to halt instead of fail gracefully, which causes a commit failed error since the DnR is taking too long.