Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
TeamSite Upgrade from 6.1 to 6.7
Icebreaker
Hi There,
I currently in the initial stage of setting up an implementation plan for this upgrade.
Potential points that needs to be covered for the upgrade would be.
1. Changing the old DTDs to be compatible to TS6.7.
2. Check the Customization scripts for its compatablity with TS6.7.
3. Check in the UID files as the user authentication is being moved to LDAP.
4. Check for IWOV config files.
Is anything I am missing here. Kindly let me know all your thoughts.
Thanks in Advance.
Find more posts tagged with
Comments
Bill Klish
Be careful about ldap. We applied the latest sun patches and it causes group size error messages within TeamSite that can be ignored. Most of the command line tools produce this message. More severely, standalone database deployments will fail in all versions of OpenDeploy.
I am not sure what you mean by customizations, but if you have done any ui toolkit customizations in java, the JDK switches from 1.3 in 6.1 to 1.5 in 6.7.1. I think it is still 1.4 in 6.7 (not 100% on that).
Some of our UI customizations fail in TS 6.7.1 and the ordering of them in CC std doesn't work the same way in CC pro.
Make sure you check the KB article about installing OD and TS together. You need to install OD first, followed by TS.
ccprofessional
bk99nd,
I'm not sure what you are smoking, but none of what you say makes sense:
Be careful about ldap. We applied the latest sun patches and it causes group size error messages within TeamSite that can be ignored.
huh?
In LDAP integration, all that Teamsite cares about is the ldap settings in iw.cfg. The rest depends on configuring Solaris to Natively integrate with LDAP. Nothing to do with Teamsite.
If you are migrating an existing store, you may need to run iwidmap to change user / token mappings.
Most of the command line tools produce this message.
We have not faced this issue.
Not sure what message you are talking about to begin with.
Some of our UI customizations fail in TS 6.7.1 and the ordering of them in CC std doesn't work the same way in CC pro.
What ordering are you talking about?!
Make sure you check the KB article about installing OD and TS together. You need to install OD first, followed by TS.
Icebreaker is talking about an upgrade, not a fresh install.
You need to install OD first, followed by TS.
When you state something broad like this, it will be nice if you can tell us about KB numbers or bug numbers(so we can contact support about it). Also, I think this depends on TS (6.7.0/6.7.1, etc) and OD versions.
Icebreaker -
1. Changing the old DTDs to be compatible to TS6.7.
I guess you meant DCT.. right?
6.7.0 has plenty of bugs, make sure you are upgrading to 6.7.1
Bill Klish
As for the LDAP issues:
Our customer recently installed the latest LDAP patches for Solaris 9 and OpenDeploy fails to execute standalone database deployments, due to a WARNING group size should be..... message. This is identified as OpenDeploy bug #70043. So, my guidance still stands. If you are using LDAP in your environment, be careful installing the latest ldap patches from Sun. Patch #112960-43 seems to break things. We tried rolling the patch back and that resulted in a kernel panic, so we are stuck waiting for a solution from Interwoven.
As for the UI:
We have extended the customer toolkit significantly but what I am referring to is basic things like the ordering of the action links in the upper right of the window (logout, etc.) where we have added some additional links appear in different orders on the ccstd homepage, inside the ccstd workarea view and in cc professional.
As for OpenDeploy:
TS 6.7.x is what the poster is referring to, right? Please see Support KB article #56722
ccprofessional
mr. impatient, can you tell me where the original poster mentioned OD?
Granted you had some OS patch issues - but that's not relevant to what the original poster mentioned. That's the reason why it's a "native" integration between Solaris and LDAP - nothing to do with Teamsite (which you fail to mention)
Icebreaker
Thanks guys,
Your msgs does give some headsup for the upgrade.
Regards,
Bill Klish
Actually the WARNING group size message occurs regularly inside of iwtrace.log for any of the TeamSite command line tools (i.e. iwstat, iwextattr, etc.).
I did make the assumption that they are using OD to get data out of teamsite. I just had provided the heads up that if they are doing standalone database deployments, the bug i mentioned effects all versions of OD.
See KB 57829 for more info.
FI114exampleTestDB.rptdesign
FI114exampleTestDB1.rptdesign
RajatChopra
See KB 57829 for more info.
Could you post the link to this article, I wasn't able to get to it.
Anyhow, I strongly recommend changing the 'Teamsite.version' attribute in deploy.cfg to 6.7.1 after the upgrade. Otherwise, TS will not recognize any DD paths!! You will end up with the 'Path not present' error.
-Rajat