Hi all,My OD receiver is bouncing due to 2 or more concurrent OD commands being run at the same time. Could anyone provide any suggestions or pointers as how to tackle the situation... as it is very difficult to get hold of Server admin again and again and thats too.... in off late hours.We are calling the odcmd start command from our external task script and is in our hands to change the same. Is there any method or CLT which can check if the OD is free to deploy or busy in handling any deployment at that moment of time.Please take this as an urgent call.
Please define "bouncing" - If the OD Receiver is dying - that's a problem for you to take up with IWOV Support.
If the request to perform a deployment is being denied because a request with the same instance name is already running - that's a case of either enabling the pending queue or (generally better) adding unique instance tags to your deployment command lines.
Also - please be clear about the type of deployment - handling transactional deployments is different than handling non-transactional deployments. Handling diff-based deployments is different than handling file list deployments, and so-on.
Lastly - please provide information about platforms and versions.
ENG: 2007-04-04 06:02:40 CDT GMT-05:00 Thread-9302 Buffer Size 8000ENG: 2007-04-04 06:02:44 CDT GMT-05:00 Thread-9302 ***ERROR - Job ID=m1174Deployment=deploy760722_1 Base: Exceeded all 3 retries to get a connection with the target OpenDeploy host. Failed creating socket.
This is the snippet of the OD logs
we only get that error when the sender can't connect to the reciever because of network issues or server is down...it seems that your receiver quits listening on port 20014 after each deployment?
when you said "the OD receiver needs to be restarted" do you mean restart the OD services or the box?if it is restarting the whole box that might be network/server issue and not Opendeploy issue... if it is just restarting OD services then it is Opendeploy and it might be better to contact the support.
I know... as it only happens when 2 concurrent jobs requested to deploy some files to the same folder at the same time. By the time first one gets deployed all 3 retries gets exceeded fo the 2nd job in queue. I cant say it as server is down... bcoz of the fact the first job deploy the files successfully.It is only the services, which needs to be restarted, not the complete set box.I think... it should be stated to IWOV support.
Doesn't OD6.1 have receiver-side queueing?Have you tried that out?