Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
Error Message
Kapil
Hi,
When i created a new File, new DCR, this error pops up. Does anyone has an idea about this error:
"Call to sci_GetUserIDFromName() returned with an error"
Kapil
Find more posts tagged with
Comments
Bowker
This is caused by the ".html" document not being tied correctly to a valid DCR.
Verify that the extended attributes (from within TeamSite look at either the file details or file properties) include items like:
Attribute Value
TeamSite/Templating/Encoding
TeamSite/Templating/PrimaryDCR personal\index
TeamSite/Templating/PrimaryDocumentType standard/standard-page
TeamSite/Templating/PrimaryPT NTcom.tpl
Verify that the file (in my case /standard/standard-page/data/personal/index) exists and has extended attributes that look something like:
TeamSite/Templating/DCR/Type standard/standard-page
(the TeamSite/Templating/DCR/Type must match TeamSite/Templating/PrimaryDocumentType from above).
- OR -
In our case this caused this same problem: PERMISSIONS.
This error popped up when we upgraded from ts 5.0.1 to ts 5.0.2 (NT environment) and people didn't have at least read access to EVERY FOLDER above the DCR.
You may run into other problems if the user doesn't have CHANGE access to the parent directory of the DCR.
Kapil
Hi,
I appreciate your reply. I am a novice with Interwoven and I was about to experiment with it. Basically I did the following:
1. Installed Interwoven, Templating, DataDeploy, OpenDeploy
2. Created a branch called test.
3. Created a test_workarea under this branch.
4. Dropped in the example template folder.
5. Tried to create "New Date Record" and i get this error.
Also when i try to create "New Job" it just hangs andi stays there. Is this a permissions error some thing to do with ACL.
Thanks
tvaughan
Did you make the necessary changes to your $IWHOME/local/config/templating.cfg file?
You've got to tell TeamSite which branches contain which templates. Just having a "templatedata" directory in a WORKAREA isn't enough.
Use the iwreset -ui command to have TeamSite re-read your templating.cfg file.
Good luck,
Tom
Kapil
hi,
No i didnt change the template.cfg file. I was following the steps in templating documentation.
1. Well I can see the form that asks me to choose a "Data Type" once i click "New DCR", so i select the Data type and enter the Data Record Name and hit continue.
2. So i see another form that takes in a sample data and when i hit "Save & Exit" i get this error:
Teamsite Templating DCR Edit
Error: Unable to acquire a lock on this dir \default\main\test\WORKAREA\test_workarea\templatedata\internet\auction\data\ file auction1.
Call to sci_GetUserIDFromName() returned with error.
I am also including the template.cfg here:
<?xml version="1.0" encoding="UTF-8" standalone="no" ?>
<!DOCTYPE templating SYSTEM "templating4.5.dtd">
<templating>
<category name="custom-dtd-examples">
<locations>
<branch vpath-regex=".*" />
</locations>
<data-type name="PressRelease" dcr-type="xml">
<presentation>
<template name="PressRelease.tpl" extension="html">
<locations>
<branch vpath-regex=".*" preview-dir="/">
<directory dir-regex=".*" />
</branch>
</locations>
</template>
</presentation>
</data-type>
</category>
<category name="intranet">
<locations>
<branch vpath-regex=".*" />
</locations>
<data-type name="deptInfo" dcr-type="iwov">
<presentation>
<template name="deptInfo.tpl" extension="html">
<locations>
<branch vpath-regex=".*" preview-dir="/">
<directory dir-regex=".*" />
</branch>
</locations>
</template>
</presentation>
</data-type>
<data-type name="weather" dcr-type="iwov">
<presentation>
<template name="weather.tpl" extension="html">
<locations>
<branch vpath-regex=".*" preview-dir="/">
<directory dir-regex=".*" />
</branch>
</locations>
</template>
</presentation>
</data-type>
</category>
<category name="internet">
<locations>
<branch vpath-regex=".*" />
</locations>
<data-type name="careers" dcr-type="iwov">
<presentation>
<template name="jobDesc.tpl" extension="html">
<locations>
<branch vpath-regex=".*" preview-dir="/">
<directory dir-regex=".*" />
</branch>
</locations>
</template>
</presentation>
</data-type>
<data-type name="auction" dcr-type="iwov">
<presentation>
<template name="auction.tpl" extension="html">
<locations>
<branch vpath-regex=".*" preview-dir="/">
<directory dir-regex=".*" />
</branch>
</locations>
</template>
</presentation>
</data-type>
<data-type name="pr" dcr-type="iwov">
<presentation>
<template name="pr1.tpl" extension="html">
<locations>
<branch vpath-regex=".*" preview-dir="/">
<directory dir-regex=".*" />
</branch>
</locations>
</template>
<template name="pr2.tpl" extension="html">
<locations>
<branch vpath-regex=".*" preview-dir="/">
<directory dir-regex=".*" />
</branch>
</locations>
</template>
<template name="nested_component_example.tpl" extension="html">
<locations>
<branch vpath-regex=".*" preview-dir="/">
<directory dir-regex=".*" />
</branch>
</locations>
</template>
</presentation>
</data-type>
<data-type name="book" dcr-type="iwov">
<presentation>
<template name="book.tpl" extension="html">
<locations>
<branch vpath-regex=".*" preview-dir="/">
<directory dir-regex=".*" />
</branch>
</locations>
</template>
</presentation>
</data-type>
<data-type name="medical" dcr-type="iwov">
<presentation>
<template name="medical.tpl" extension="html">
<locations>
<branch vpath-regex=".*" preview-dir="/">
<directory dir-regex=".*" />
</branch>
</locations>
</template>
</presentation>
</data-type>
<data-type name="periodic" dcr-type="iwov">
<presentation>
<template name="periodic.tpl" extension="html">
<locations>
<branch vpath-regex=".*" preview-dir="/">
<directory dir-regex=".*" />
</branch>
</locations>
</template>
</presentation>
</data-type>
<data-type name="yacht" dcr-type="iwov">
<presentation>
<template name="yacht.tpl" extension="html">
<locations>
<branch vpath-regex=".*" preview-dir="/">
<directory dir-regex=".*" />
</branch>
</locations>
</template>
</presentation>
</data-type>
</category>
</templating>
tvaughan
Are you running on Solaris?
If you are, you need to either be (A) the ower of the 'test_workarea' directory or (B) a member of the group that owns the 'test_workarea' directory.
Tom
Kapil
I am running on Windows 2000 Server, but we are using it as a WORKGROUP and not as a DOMAIN. Is that an issue?
To double check the ownership, i logged in as "Master" but i still get the same error.
Thanks
Kapil
Regarding ACL, when i checked the Security tab for test_workarea:
everyone has fullcontrol
Do i need to add any more users.