Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
Teamsite 6.7.1 on Linux
System
I did a fresh installation of teamsite 6.7.1 on Red hat Linux Enterprise 4. After completing all the installation steps i rebooted the machine. After the reboot the interwoven servlet daemon did not start.
This is the error messages i see in the servletd.log file :
Using CATALINA_BASE: /opt/teamsite/servletd
Using CATALINA_HOME: /opt/teamsite/servletd
Using CATALINA_TMPDIR: /opt/teamsite/servletd/temp
Using JAVA_HOME: /opt/teamsite/tools/java
Using CLASSPATH: :/opt/teamsite/tools/java/lib/tools.jar:/opt/teamsite/servletd/bin/bootstrap.jar:/opt/teamsite/servletd/bin/
commons-logging-api.jar
Jul 13, 2007 6:13:26 AM org.apache.catalina.startup.Catalina stopServer
SEVERE: Catalina.stop:
java.net.ConnectException: Connection refused
at java.net.PlainSocketImpl.socketConnect(Native Method)
at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)
at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)
at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
at java.net.Socket.connect(Socket.java:516)
at java.net.Socket.connect(Socket.java:466)
at java.net.Socket.(Socket.java:366)
at java.net.Socket.(Socket.java:179)
at org.apache.catalina.startup.Catalina.stopServer(Catalina.java:394)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at org.apache.catalina.startup.Bootstrap.stopServer(Bootstrap.java:343)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:434)
cat: /var/teamsite/iwui/servletd.pid: No such file or directory
Killing:
cat: /var/teamsite/iwui/servletd.pid: No such file or directory
kill: usage: kill [-s sigspec | -n signum | -sigspec] [pid | job]... or kill -l [sigspec]
nohup: cannot run command `/opt/teamsite/servletd/bin/servletd': Permission denied
Currently the /opt/teamsite/servletd/bin/
servletd
file has user/group as
iwts
-rwx------ 1 iwts iwts 10864 Oct 7 2006 servletd
I changed this as :
-rwxr-xr-x 1 iwts iwts 10864 Oct 7 2006 servletd
But even after making the above change still the Interwoven Servlet Daemon has NOT started. If anybody has faced and solved the issues, please let me know.
Also i want to know from the group if anyone has sucessfully installed Teamsite 6.7.1 on Linux ? If so please can you share if any problems/issues you have faced and solutions you found to solve those issues.
Thanks !
Find more posts tagged with
Comments
Bill Klish
Yes we are running it on multiple servers without a problem.
Did you check to make sure your linux firewall is not blocking that port? From the log, it looks like it was unable to connect on the tomcat port (8080 I believe by default). I would check to make sure you are not blocking 8080 in iptables or your firewall of choice.
Migrateduser
The firewall is not blocking port 8080.