Exception in getProjects call, for EStudio

Hello,
I’ve just made a TeamSite16.4.1. installation on a new server and then brought in a pre-existing content-store (+ templating.cfg etc), prior to installing the Runtime as I think this is the best way to get the content I want on a new server with TS16.4.1.

CCPRo is working well, but when I go to EStudio no projects are showing (asked to “Create”) and “:Service.Project.Error” shows.

The various estudio.properties files all came over in the store, but I do see the following in wcm_service.log.

How can I rectify this? Is there another config file I’ve neglected to bring over?

**wcm_service.log
**2019-01-04 14:08:14,986 [default task-14] ERROR com.hp.wcm.wcmservice.service.cssdk.ProjectServiceImpl () - Exception in getProjects call:
org.dozer.MappingException: java.lang.reflect.InvocationTargetException
at org.dozer.util.MappingUtils.throwMappingException(MappingUtils.java:82)

2019-01-04 14:08:14,987 [default task-14] ERROR com.hp.wcm.wcmservice.controller.ProjectController () - A business service exception occurred.
com.hp.wcm.wcmservice.service.cssdk.ProjectServiceException: Service.Project.Error
at com.hp.wcm.wcmservice.service.cssdk.ProjectServiceImpl.getProjects(ProjectServiceImpl.java:324)
……
2019-01-04 14:08:14,981 [default task-14] ERROR org.dozer.MappingProcessor () - Field mapping error -->
MapId: null
Type: null
Source parent class: com.interwoven.cssdk.access.impl.CSUserImpl
Source field name: displayName
Source field type: null
Source field value: null
Dest parent class: com.hp.wcm.wcmservice.model.User
Dest field name: displayName
Dest field type: java.lang.String
org.dozer.MappingException: java.lang.reflect.InvocationTargetException
at org.dozer.util.MappingUtils.throwMappingException(MappingUtils.java:82)

Comments

  • A comment from Support that swapping in a pre-existing content store into a new TeamSite installation may not be supported now.

    Interested to know, in the real world we live in, who else does this rather than just upgrade TS in-place? I always used the install-TS-software-on-fresh-server-and-migrate-store approach as there was no risk and minimal downtime, and sometimes I absolutely had to because we had to move to new servers.

    If that would be true and swapping-in your existing content-store is not supported, what would be the ramifications? Doomed to forever upgrade TeamSite on the same old server? What happens when you need to move to a new server, and obviously need all your content there? What happens when you want to create a failover server? Or make a new Dev server with your existing content?

    Interested to hear opinions.
    BB

  • That is really freaking bad. Horrible.

    I always have customers install new and port over. It takes longer but allows them to get on new hardware/OS/DB etc.

    Do they expect that you will run iwmigrate every time ? We have several hundred branches.

    Now working on Windows has problems with local accounts, so if you are on Windows and local accounts I can see there will be problems, but as a rule this could be catastrophic.

  • Hey Andy,
    thought I should reply so you don't have sleepless nights...

    That may have been just 1 Support person's opinion, I did get Support on my ticket to resolve the issue on the content store I brought in.

    The hint I needed was I was "missing owner on one or more branches" (or projects?), as per messages in wcm-service.log like
    2019-01-08 17:05:19,360 [default task-18] ERROR com.interwoven.cssdk.sci.access.AccessServiceSciImpl () - Error getting user data for : 1013
    2019-01-08 17:05:19,390 [default task-18] ERROR org.dozer.MappingProcessor () - Field mapping error -->

    When I looked I saw:
    l /iwmnt/default/iwconfig/main/
    drwxrwxr-x 5 1005 iwglobal 512 May 17 2018 InnovateFinancial/
    drwxrwxr-x 5 root nobody 512 Sep 13 14:02 InnovateFinancial_MASTER/
    drwxrwxr-x 5 1013 iwglobal 512 Nov 20 16:04 JG-Testing-Template/
    drwxrwxr-x 5 1012 iwglobal 512 Nov 19 16:36 Joe_2nd_Project/
    etc, which I am guessing was the reason eStudio was complaining (but not CCPro).

    So I just added those 3 Linux users with the same uid's and it worked - could see all the projects in eStudio.

    One of the users had actually left, so I guess this means that user should remain in /etc/passwd for as long as she owns projects.

    I think iwidmap is another way to go, but I just did it my way to check if I had diagnosed the error correctly and it could be simply solved via standard Linux user adding.

    Cheers
    BB

  • Cool, thanks for posting, I know I has to clean up my owners as well, but that prevented the UI from even completing. Glad you got it working.

    Andy

Sign In or Register to comment.