We have a DNR script in a directory on target server which is a symbolic link. The DNR execution fails with the following error in the receiver log file- ERROR: DNR Execution failed. where clause is not a directory = /www/wbqa/appserverThe appserver directory is actually a link which points to another location.lrwxrwxrwx 1 enuser engrp 38 Jul 13 11:26 appserver -> /www/wbqa/wls81-sp6/wbqa10Is there a known issue with OD when specifying a symbolic link as the 'where' clause for DNR scripts?Env: OD 5.5.1/solarisTIA
Hi , The same issue is there with OD 6.1 , I too had faced the same issue. CheersPrem
In , The server is Unix , so this could also be a Problem .But i have a simple question , if symbolic Link deployments would work , then there would be no need of OD Receiver (In General Case). On server A : we would install the OD base Server . Do a Deployment to some Path in Base Server A . There the soft link would be there for some path on Server B. So finally the file would get deployed to Server B , without server B having any OD Receiver . Pls let me know if i have missed out any thing.CheersPrem Pratick.