Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
deploy between edition and edition/IW_PREV
DebSaunders
I am trying to deploy difference between latest edition and previous edition.
I did wrote deploy script...
iwstore name="diffPub"
areaDiff name="deployDiffEdition" area="home/EDITION" previousArea="home/EDITION/IW_PREV"
pathSpecification
path name="."
/pathSpecification
/areaDiff
/iwstore
question i have is do i need to specify names for 'edition' and 'previous edition' or opendeploy will automatically take care. If i have to specify names...how do i get latest name and previous names for edition.
Find more posts tagged with
Comments
nipper
OpenDeploy by default will look at the latest edition and then compare (because of IW_PREV) to the previous edition
DebSaunders
I am getting following error if i do the way mentioned before...
API: 2008-02-10 19:46:04 EST GMT-05:00 Requested start of deployment daily_content_prod_deploy404953_404964
API: 2008-02-10 19:46:04 EST GMT-05:00 Calling server to start deployment daily_content_prod_deploy404953_404964
ENG: 2008-02-10 19:46:04 EST GMT-05:00 Received request to start deployment daily_content_prod_deploy with instance name 404953_404964 (daily_content_prod_deploy404953_404964).
ENG: 2008-02-10 19:46:04 EST GMT-05:00 Starting job m173 for deployment daily_content_prod_deploy404953_404964 with parameters: {PAD6=null, DEPLOYSUFFIX=404953_404964, JOBID=m173, LOGLEVEL=UNSPECIFIED, PAD3=null, ENDTIME=null, PAD5=null, MINUTEINV=0, HOURINV=0, SYNCH=true, REPAIR=false, VERIFY=false, EXTERNALTASKID=null, YEARINV=0, REPEAT=false, WEEKDAY=null, PAD2=null, OWNER=root, KEYVALUES=area=/default/main/non-portal/EDITION
previousArea=/default/main/non-portal/EDITION/IW_PREV
ftp_config=/app/iw-home/opendeploy/OpenDeployNG/adapters/delivery/ftpadapter/branchoffice.cfg
, DEPLOYNAME=daily_content_prod_deploy, NO_RECUR=NO_RECUR, STARTTIME=Sun Feb 10 19:46:04 EST 2008, PAD4=null, RECURSET=NO_RECUR, DAYINV=0, PAD1=null, STARTDEPLOY=true, MONTHDAYS=null, DESCRIPTION=, WEEKINV=0}
ENG: 2008-02-10 19:46:04 EST GMT-05:00 MultiTier Latch is null
CFG: 2008-02-10 19:46:04 EST GMT-05:00 ***WARNING - Ignoring unrecognized element or element out of place {1} in section
"iwstore"
CFG: 2008-02-10 19:46:04 EST GMT-05:00 ***ERROR - No set information (Source base cfg)
CFG: 2008-02-10 19:46:04 EST GMT-05:00 ***ERROR - Invalid com.interwoven.config100.TSourceCfg object returned from source
CFG: 2008-02-10 19:46:04 EST GMT-05:00 ***WARNING - followLinks attribute of the transferRules element has been DISCONTINUED and is ignored. This will become an ERROR in the next major release of OpenDeploy.
CFG: 2008-02-10 19:46:04 EST GMT-05:00 ***ERROR - No valid source objects.
CFG: 2008-02-10 19:46:04 EST GMT-05:00 ***ERROR - "definition" object is invalid.
ENG: 2008-02-10 19:46:04 EST GMT-05:00 (invalid configuration element)
Configuration information
name= : : isValid=no : use= : dictionary=
parent =
error vector=Set begin java.util.Vector [
vector size=12
(1) Element begin [Message class: 104
Message key: OdCfgW0010
Message :
Parameters : "iwstore"
Details : OdCfgW0010:com.interwoven.config100.TSourceCfg
] (1) Element end
(2) Element begin [Message class: 104
Message key:
Message : CfgWarning: Logger was null.
Parameters
Details : com.interwoven.config100.TSourceCfg
] (2) Element end
(3) Element begin [Message class: 103
Message key: OdCfgE0012
Message :
Parameters : Source base cfg:
Details : OdCfgE0012:com.interwoven.config100.TSourceCfg
] (3) Element end
(4) Element begin [Message class: 103
Message key:
Message : CfgError: Logger was null!!!
Parameters
Details : com.interwoven.config100.TSourceCfg
] (4) Element end
(5) Element begin [Message class: 103
Message key: OdCfgE0022
Message :
Parameters : com.interwoven.config100.TSourceCfg
Details : OdCfgE0022:com.interwoven.config100.TDefinitionCfg
] (5) Element end
(6) Element begin [Message class: 103
Message key:
Message : CfgError: Logger was null!!!
Parameters
Details : com.interwoven.config100.TDefinitionCfg
] (6) Element end
(7) Element begin [Message class: 104
Message key: OdCfgW0065
Message :
Parameters : followLinks: transferRules
Details : OdCfgW0065:com.interwoven.config100.TTransferRulesCfg
] (7) Element end
(8) Element begin [Message class: 104
Message key:
Message : CfgWarning: Logger was null.
Parameters
Details : com.interwoven.config100.TTransferRulesCfg
] (8) Element end
(9) Element begin [Message class: 103
Message key: OdCfgE0025
Message :
Parameters : source
Details : OdCfgE0025:com.interwoven.config100.TDefinitionCfg
] (9) Element end
(10) Element begin [Message class: 103
Message key:
Message : CfgError: Logger was null!!!
Parameters
Details : com.interwoven.config100.TDefinitionCfg
] (10) Element end
(11) Element begin [Message class: 103
Message key: OdCfgE0012
Message :
Parameters : deploymentConfiguration: "definition"
Details : OdCfgE0012:com.interwoven.config100.TDeploymentConfiguration
] (11) Element end
(12) Element begin [Message class: 103
Message key:
Message : CfgError: Logger was null!!!
Parameters
Details : com.interwoven.config100.TDeploymentConfiguration
] (12) Element end
] Set end java.util.Vector
ENG: 2008-02-10 19:46:04 EST GMT-05:00 Routed Multi Tier = null
CFG: 2008-02-10 19:46:04 EST GMT-05:00 ***WARNING - Ignoring unrecognized element or element out of place {1} in section
"iwstore"
CFG: 2008-02-10 19:46:04 EST GMT-05:00 ***ERROR - No set information (Source base cfg)
CFG: 2008-02-10 19:46:04 EST GMT-05:00 ***ERROR - Invalid com.interwoven.config100.TSourceCfg object returned from source
CFG: 2008-02-10 19:46:04 EST GMT-05:00 ***WARNING - followLinks attribute of the transferRules element has been DISCONTINUED and is ignored. This will become an ERROR in the next major release of OpenDeploy.
CFG: 2008-02-10 19:46:04 EST GMT-05:00 ***ERROR - No valid source objects.
CFG: 2008-02-10 19:46:04 EST GMT-05:00 ***ERROR - "definition" object is invalid.
ENG: 2008-02-10 19:46:04 EST GMT-05:00 ***ERROR - Failed to processing config file /app/iw-home/opendeploy/OpenDeployNG/conf/daily_content_prod_deploy.xml
ENG: 2008-02-10 19:46:04 EST GMT-05:00 Completed session queue capacity reached. Removed oldest session.
ENG: 2008-02-10 19:46:04 EST GMT-05:00 Removing session m173
ENG: 2008-02-10 19:46:04 EST GMT-05:00 ***ERROR - Failed starting deployment: daily_content_prod_deploy404953_404964
API: 2008-02-10 19:46:04 EST GMT-05:00 Error encountered while starting deployment daily_content_prod_deploy404953_404964
Error: DEPLOY_CONFIG_FILE., Failed to processing config file /app/iw-home/opendeploy/OpenDeployNG/conf/daily_content_prod_deploy.xml
DebSaunders
Attach is my deploy config file...
Frederik
iwstore should be iwStore.
XML is case-sensitive.
This may not be the only error in there, it's the first I picked up on. Suggest you double check the rest of the syntax, against the DTD or the manual
curiousmaverick
try writing the file using OD GUI. It takes off a lot of headache.
Regards,
Mav
DebSaunders
that was the problem...i had iwstore instead of iwStore...it is case sensitive....thanks for everybody's help......