Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
Open Deploy Transfer Problem
Ken3992927
Our client is using Open Deploy 6.2 on Windows 2003. When open deploy runs successfully, the deployment job should finish within 30 seconds but once in a while (possibly once a month) the job doesn't finish and the open deploy service must be stopped manually to end the job.
We noticed that this issue occurs because during the transfer phase, the average data rate drops to 0. We think this might be a connection problem but have not located the cause just yet. Therefore in the meantime is there a check on Open Deploy that stops the deployment job if average data rate remains at 0 for X minutes, where X is a configuration setting?
Thank you all for your help.
Find more posts tagged with
Comments
Passenger
I've had similar issues in the past as well. It turned out the deployments did finish, but only after 50 minutes or so.
In my situation, I was deploying source files of running web services. Although the services were designed to be updated while running, due to differences in modification dates (the exe files were never modified though) the locked exe files were also deployed. OpenDeploy was not able to update the files and kept trying several times to update them. While trying the transfer rate also dropped to 0, implying there were troubles with the connection while there weren't any.
Have you tried to look at the log files on the receiver? Normally these will give you a pretty good picture of what goes wrong. You can see which files are transferred and which fail.
Ken3992927
We've been through the logs and have passed them to support and they told us that they could not find anything wrong in the logs. The deployment job ran for more than 30 hours on our client's server before anyone noticed that it wasn't working.