A class needed by class com.interwoven.livesite.hibernate.tool.hbm2ddl.SchemaUpdateTask cannot be found: org/hibernate/HibernateException
I am not sure why exactly the installer failed without looking at installation logs, but from the description it sounds like you are hitting an old known issue with previous versions of SitePublisher. There was a SP bug about installation drive that required tmp and temp to point to the same drive as installation. That is, if temp says " C:\temp " then you could only install SP on "C" drive. I'm not sure the bug was resolved in 6.7.2 or not. What you may want to try is change the "temp" and "tmp" variables to point to E (E:\temp, E:\tmp as you are installing 6.7.2 on drive E) and run the scripts again or run the installer again. Hopefully it will work. If that fails too then open a case with Interwoven Support. Hope it works.