Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
Teamsite not coming up after reboot
Maya_Pillai
Our teamsite development server is not coming up after a reboot.We have teamsite 6.5 SP2 on Solaris 9. The same unix server hosts few other applications also. Sever faced issues and was down for sometime yesterday and they rebooted the machine.
While trying to restart teamsite, it gives the following error:-
Interwoven OpenAPI starting ...
ERROR: Failed to start. Check /web1/teamsite/logs/iwui/openapi.log
openapi.log
-----------
Exception: non-JRMP server at remote endpoint
java.rmi.ConnectIOException: non-JRMP server at remote endpoint
at sun.rmi.transport.tcp.TCPChannel.createConnection(TCPChannel.java:217)
at sun.rmi.transport.tcp.TCPChannel.newConnection(TCPChannel.java:171)
at sun.rmi.server.UnicastRef.newCall(UnicastRef.java:313)
.
.
Exception: null
java.lang.reflect.InvocationTargetException
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
at java.lang.reflect.Constructor.newInstance(Constructor.java:274)
at com.interwoven.api.service.IWServiceServer.startService(IWServiceServer.java:384)
at com.interwoven.api.service.IWServiceServer.startServiceList(IWServiceServer.java:312)
at com.interwoven.api.service.IWServiceServer.server(IWServiceServer.java:136)
at com.interwoven.api.service.IWServiceServer.main(IWServiceServer.java:148)
at com.interwoven.api.OpenAPIServer.main(OpenAPIServer.java:164)
Caused by: com.interwoven.api.service.IWService$ConfigException: Exception registering service.
at com.interwoven.api.service.IWServiceRemoterImpl.(IWServiceRemoterImpl.java:128)
at com.interwoven.api.access.IWPolicedServiceRemoterImpl.(IWPolicedServiceRemoterImpl.java:46)
at com.interwoven.api.access.IWAccessServiceRemoterImpl.(IWAccessServiceRemoterImpl.java:50)
servletd.log
----------
Using JAVA_HOME: /web1/teamsite/iw-home/tools/java
Using CLASSPATH: /web1/teamsite/iw-home/tools/java/lib/tools.jar:/web1/teamsite/iw-home/tools/java/lib/tools.jar:/web1/t
eamsite/iw-home/cssdk/cssdkjni.jar:/web1/teamsite/iw-home/cssdk/cssdkiface.jar:/web1/teamsite/iw-home/servletd/bin/boots
trap.jar:/web1/teamsite/iw-home/servletd/bin/commons-logging-api.jar
Catalina.stop: java.net.ConnectException: Connection refused
java.net.ConnectException: Connection refused
at java.net.PlainSocketImpl.socketConnect(Native Method)
Any suggestions is highly appreciated.
Thanks
Find more posts tagged with
Comments
Mr_Cruise
What database are you using for your eventsubsystem ?
Migrateduser
Hi
Check For Interwoven and Teamsite Services..as sometimes the services don't start automatically on reboot.
Check also your DB Server Status if using.
Thanks
Prabhat
Maya_Pillai
Thanks all. Teamsite is back.
https://support.interwoven.com/kb/kb_show_article2.asp?ArticleID=51316
The port 1099 was blocked by another app in the server. We stopped that application and restarted teamsite.