Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
Deployment error--Read attributes from receiver failed, got null.
nflp
Hi,
I am trying to test deploy from my dev box to another dev box and I get the following error..
Thanks for any help,
-----------------------------------------------
ENG: 2008-09-14 22:14:01 PDT GMT-07:00 Thread-73 Begin logfile [/apps/Interwoven/OpenDeployNG/log/src.test.MYDEFINITIONNAME.prasadp.to.Roger.log] ---------
ENG: 2008-09-14 22:14:01 PDT GMT-07:00 Thread-73 Job ID=m29 Deployment=test
ENG: 2008-09-14 22:14:01 PDT GMT-07:00 Thread-73 OpenDeploy Version is 6.1.1.0.0
ENG: 2008-09-14 22:14:01 PDT GMT-07:00 Thread-73 Owner started the deployment is root
ENG: 2008-09-14 22:14:01 PDT GMT-07:00 Thread-73 Internal config file [/apps/Interwoven/OpenDeployNG/db/.test.MYDEFINITIONNAME.roger]
ENG: 2008-09-14 22:14:01 PDT GMT-07:00 -------------------------------------------------
deployment_name=.test.MYDEFINITIONNAME.roger
hostname=prasadp.la.net
remote_server=10.207.33.171
remote_port=9173
buffer_size=8000
verbose_level=5
do_manifest_for_dnr
do_manifest_for_events
deployment=.test.MYDEFINITIONNAME.roger
teamsite_based
previous_area=//IWSERVER/default/main/GRAYSITE/EDITION/IW_PREV
area=//IWSERVER/default/main/GRAYSITE/EDITION
local_directory=test
date_different
ignore_acls
applyExtAttrs
remote_directory=//IWSERVER/default/main/GRAYSITE/WORKAREA/main
;
;
ENG: 2008-09-14 22:14:01 PDT GMT-07:00 -------------------------------------------------
ENG: 2008-09-14 22:14:01 PDT GMT-07:00 Thread-73 End of internal config file [/apps/Interwoven/OpenDeployNG/db/.test.MYDEFINITIONNAME.roger]
ENG: 2008-09-14 22:14:01 PDT GMT-07:00 Thread-73 exiting initial
ENG: 2008-09-14 22:14:01 PDT GMT-07:00 Thread-73 entering setup
LIB: 2008-09-14 22:14:01 LOGFILE=[/apps/Interwoven/OpenDeployNG/log/src.test.MYDEFINITIONNAME.prasadp.to.Roger.log]
LIB: 2008-09-14 22:14:01 Locale=[UTF-8]
ENG: 2008-09-14 22:14:01 PDT GMT-07:00 Thread-73 Connecting to host=10.207.33.171 port=9173
ENG: 2008-09-14 22:14:01 PDT GMT-07:00 Thread-73 Sender Side timeout = 0
ENG: 2008-09-14 22:14:01 PDT GMT-07:00 Thread-73 Buffer Size 8000
ENG: 2008-09-14 22:14:01 PDT GMT-07:00 Thread-73 After Connect RC = 0
ENG: 2008-09-14 22:14:01 PDT GMT-07:00 Thread-73 Sender-side handshake timeout = 120 secs
ENG: 2008-09-14 22:14:01 PDT GMT-07:00 Thread-73 Send version string to receiver, RC = 13
ENG: 2008-09-14 22:14:01 PDT GMT-07:00 Thread-73 Send attributes to receiver, RC = 0
ENG: 2008-09-14 22:14:01 PDT GMT-07:00 Thread-73 ***ERROR - Read attributes from receiver failed, got null.
ENG: 2008-09-14 22:14:01 PDT GMT-07:00 Thread-73 exiting setup
ENG: 2008-09-14 22:14:01 PDT GMT-07:00 Thread-73 entering awaiting-cleanup
ENG: 2008-09-14 22:14:01 PDT GMT-07:00 previousPhaseStr:setup
ENG: 2008-09-14 22:14:01 PDT GMT-07:00 currentPhaseStr:awaiting-cleanup
ENG: 2008-09-14 22:14:01 PDT GMT-07:00 Thread-73 exiting awaiting-cleanup
ENG: 2008-09-14 22:14:01 PDT GMT-07:00 Thread-73 entering cleanup
ENG: 2008-09-14 22:14:01 PDT GMT-07:00 Thread-73 exiting cleanup
ENG: 2008-09-14 22:14:01 PDT GMT-07:00 Thread-73 entering task-failed
ENG: 2008-09-14 22:14:01 PDT GMT-07:00 Thread-73 still waiting for 0
LIB: 2008-09-14 22:14:01
Find more posts tagged with
Comments
yogesh_agrawal
can you put OD receiver logs also?. is this deployment on window or unix?
Migrateduser
This could happen if the file you are deploying is deleted or there are two deployment running concurrently for the same file.
Sam
TS 6.7.1, Solaris 10
Lozza
Yes, I encountered this error when doing two simultaneous deployments to the same target location. In my case, I was doing this in a single OD configuration, so that I could run different DNR scripts against different file lists.
You can fix this by enabling concurrency management, off by default, on the receiver node by amending odbase.xml or odrcvr.xml, depending on the receiver type. A knowledge base article for this is available here:
https://support.interwoven.com/kb/kb_show_article2.asp?ArticleID=56667
I get this error from a 6.2.0 base running on a Linux VM, but not from a 6.0.2 base running on a Solaris server. So I'm not sure if it's the version, the OS or the fact it's a VM. Who cares, it works for me now