Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
TeamSite ASPX Preview Problem - Apache File Mapping
Annad
We have an intermittent problem when previewing an ASPX code page within TeamSite. It seems that a completely incorrect physical path is being accessed...see below.
The REAL physical path to the file I am previewing is
"Y:\global\main\iwglobal\WORKAREA\iwglobal\docs\utilities\page1.aspx"
The physical path below is what Apache is tryng to access. It appears that the first part of this path [before iw-mount] is possibly cached from some previous preview of a page within that particular folder.
"Y:\store1\main\internet-internet\site1\branch1\WORKAREA\content-contenu\iw-mount"
This is an intermittent problem, and is "sometimes" resolved by running "aspnet_regiis.exe -i" on IIS, or even re-publishing an unrelated ASPX code page.
Note that we never have a problem on the target server, only when previewing ASPX pages within TeamSite
Full Page Error
--------------------------------------------------------------------------
Server Error in '/iw-mount' Application.
Directory 'Y:\store1\main\internet-internet\site1\branch1\WORKAREA\content-contenu\iw-mount' does not exist. Failed to start monitoring file changes.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.
Exception Details: System.Web.HttpException: Directory 'Y:\store1\main\internet-internet\site1\branch1\WORKAREA\content-contenu\iw-mount' does not exist. Failed to start monitoring file changes.
Source Error:
An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.
Stack Trace:
[HttpException (0x80070002): Directory 'Y:\store1\main\internet-internet\site1\branch1\WORKAREA\content-contenu\iw-mount' does not exist. Failed to start monitoring file changes.]
System.Web.FileChangesMonitor.FindDirectoryMonitor(String dir, Boolean addIfNotFound, Boolean throwOnError) +527
System.Web.FileChangesMonitor.StartMonitoringPath(String alias, FileChangeEventHandler callback) +477
System.Web.Caching.CacheDependency.Init(Boolean isPublic, Boolean isSensitive, String[] filenamesArg, String[] cachekeysArg, CacheDependency dependency, DateTime utcStart) +1535
System.Web.Caching.CacheDependency..ctor(Boolean isSensitive, String[] filenames, DateTime utcStart) +50
System.Web.Configuration.HttpConfigurationSystem.GetCacheDependencies(Hashtable cachedeps, DateTime utcStart) +154
System.Web.Configuration.HttpConfigurationSystem.ComposeConfig(String reqPath, IHttpMapPath configmap) +760
System.Web.HttpContext.GetCompleteConfigRecord(String reqpath, IHttpMapPath configmap) +434
System.Web.HttpContext.GetCompleteConfig() +49
System.Web.HttpContext.GetConfig(String name) +195
System.Web.CustomErrors.GetSettings(HttpContext context, Boolean canThrow) +20
System.Web.HttpResponse.ReportRuntimeError(Exception e, Boolean canThrow) +39
System.Web.HttpRuntime.FinishRequest(HttpWorkerRequest wr, HttpContext context, Exception e) +486
Version Information: Microsoft .NET Framework Version:1.1.4322.2300; ASP.NET Version:1.1.4322.2300
Find more posts tagged with
Comments
nipper
How do you have TS configured to preview ASPX ? By default it won't and you need to make some changes. There are 2 basic approaches I have used, create a folder iwmount-dummy in the Inetpub (and follow a KB you can get from support). Another approach is to use a proxy remap that redirects to a specific port configured for aspx.
It sounds like you have one of them *partially* working.
Faizi
Hi,
At the time of installation Teamsite prompted to configure IIS server. You can also configure it manually. This is the command for configuring IIS:
>iw-home\iw-perl\bin\perl
iw-home\install\tspostreboot.pl iw-home IIS
Run this command, IIS server should be installed in server.
Hope this helps.
Annad
Just a few more details...
We are having this problem on all DEV, QA, and PROD servers. This is not a simple configuration item that has been omitted, as all ASPX TeamSite previews work just fine.
The problem we have is "intermittent"; when we publish one particular version of an ASPX page to STAGING and the target server, all TeamSite previews [all ASPX files] are broken. Somehow this causes Apache/IIS to be placed into a wonky state. Note that this same file causes no problems on the target server; the code is benign. If we republish the older version to STAGING only, the preview problem goes away.
Upon preview of an ASPX, the preview server cannot find the folder:
"Y:\store1\main\internet-internet\site1\branch1\WORKAREA\content-contenu\iw-mount"
There are severel problems:
1) This folder path is completley wrong, as the root is "iw-mount". It seems that part of the folder path is being placed in front of "iw-mount".
2) The folder path [ before iw-mount "Y:\store1\main\internet-internet\site1\branch1\WORKAREA\content-contenu\"] does NOT match the URL I was previewing. The folder path before iw-mount is valid, but does NOT match the URL I was previewing. It seems that something is being cached and used incorrectly.